SVN 3877 No boot file name received



  • Ever since I updated FOG to SVN 3877 I’ve been unable to boot to pxe. It times out with an error of " No boot file name received". I’ve already restarted my ubuntu server and the problem still occurs.



  • I found out what the issue was. Somebody on my team removed option 66 and 67 from our dhcp servers. So the network boot didn’t know where to look for any files.



  • @jamesb Like Wayne Workman said, if you are using dnsmasq you need to recreate a link to your undionly.kkpxe files as undionly.0.



  • I went through the entire wiki and I still have the issue. If I’m in windows I have no problem using the command prompt to tftp the undionly.kkpxe file. However when it tries to grab the file from boot up I get the “No boot filename recieved” error/



  • @jamesb The drop down menu for the boot file in 1.2.0 and in FOG Trunk is nothing more than a place-holder. It doesn’t actually do anything.

    Can you please go through the tests in the article I posted? Everything you need to solve this is in there, and for me to help you here in the forums, I’d just be retyping what is in that article.



  • The tftp service is running. I’m not noticing any issues on that part. I have noticed as I have looked over my FOG config that I’m not finding the undionly.kkpxe file referenced anywhere. There used to be a dropdown setting that would allow me to pick it. It looks like that drop down doesn’t exist anymore. I’m wondering if that is the issue since we have our systems look for that file to pull.



  • Are you using dnsmasq? Have you checked that TFTP is running? Have you tested that TFTP is functional?

    Look through this article: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP


 

400
Online

41.5k
Users

11.9k
Topics

113.3k
Posts