Image Size: ON SERVER 0.00 iB and although no way to do an Kernel update



  • Hello there,

    we got two issues in our network. Firstly I will start by discribing the issues and the steps I’ve done trying to solve it. The first not working component is the kernel update. It shows following error:

    Kernel Update Error.PNG
    As the error describes is the issue between the /tmp/bzimage Path and the
    /var/www/fog/service/ipxe/bzimage, I did some research on the internet, which said I should check the permissions. Well, that didn’t change anything. We are actually running on FOG 1.2.0. And we’re virtualizing the FOG with Proxmox VE. I don’t know if this is an important information, but we’re saving our files on a NAS (Synology). The new Kernel is saved in the /tmp/ and I tried to put the kernel manually in the …/ipxe/ Path. After that the bugs were more creepy than before. Cause since that we weren’t able to register an host. A reinstall of the fog server and Linux didn’t help either. So I decided to put back the Kernel we used before. I also researched about that ftp_put(), and saw some configs which should be changed, but I don’t know, where I have to change it. Maybe you guys have some advices/tips where to find it. I hope this are enough information for that issue.

    Our second issue is the Imaging itself. It could be, that these issues stick together cause both are using FTP. After we’ve Uploaded the Image to the server it says that the SIZE ON SERVER IS 0 iB. I read a bug report about that too on this forum, which weren’t solved. I don’t know if you need a screenshot of that but I’ll put that in here:

    Image.PNG
    This image is only on one partition. (I don’t now if the reserved partition of Windows is a partition too but I guess it is like that). But we’ve also tried to make it with Single Disk only. Didn’t work either. I think we already had that problem some time ago, but I can’t remember how we solved that issue. Let me know if you need to more information about our Network, or some other stuff.

    I can show you the errors, if you tell me where I can find the log file which shows the errors. :smiley:

    Greetings from Germany hope you got better weather than us :de: :smiley:
    ~Mario


  • Moderator

    For future readers, this is most commonly an FTP credentials problem, and the answer is located here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords



  • Never mind I found a solution on the wiki after researching… just slap my face :D I think it’s solved now ^^



355
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.