Next upgrade of FOG/Ubuntu



  • So in preparation of the new LTS version of Ubuntu coming out, I decided to do some testing. I figure of those using Ubuntu to run FOG on, most of you are running the LTS version. For those that don’t know, the new LTS version comes out this month, 12.04 and both the server and desktop editions will now be supported for 5 years. Be ready for the Unity interface as well. Nothing that a little sudo apt-get install gnome-panel can’t fix :)This makes for a good platform to run FOG on, due to the long support of the OS. Granted, 12.04 is still in the beta 2 stage, however, it’ll only be bug fixes for the final release. So I decided to try it out on the test VM I have for FOG. The goal, at least for me, is to upgrade FOG to .33 and then upgrade the production servers from 10.04 LTS to 12.04 LTS.

    Since the official release isn’t available yet I downloaded the beta 12.04 and tried to upgrade my test server from 10.04 to 12.04. So for those of you wondering if it works, the answer is no. My images are still intact, but that’s pretty much it. The web server is gone, mysql is gone etc. So at least in the beta stage, don’t try upgrading from the CD when the time comes. Though when the official release is out, i’ll try upgrading through the OS, which might make a difference. But for now, time to roll back to the previous snapshot :)

    Just thought I’d share the beginning of the testing phase of the pretty hefty Ubuntu upgrade.



  • From my user account I just went in via su -


  • Moderator

    Did you login as root, or sudo -i ?



  • Running it as root appeared to have fixed the problem.



  • are you running the script as root or with sudo?



  • So I just tried running the install script from within the bin folder, while I get further (lets me enter IP info) it never actually gets to the install point. I just get command not found errors when it tries to install the packages.



  • I will give that a try when I get home, that might be the issue. And who knows, this could be fixed when the official upgrade is released.



  • This post is deleted!


  • Have you tried running the installer from ~/Desktop/fog_0.32/bin/ yet? I seem to recall the install script having a hard time with relative paths if you don’t launch the script from it’s current directory.



  • Also, I’ve tried installing the current version of FOG on the daily build of 12.04. As of right now, FOG is very unhappy when it tries to install. It looks like the install.sh might have to be tweaked.[ATTACH=full]86[/ATTACH]

    [url="/_imported_xf_attachments/0/86_Capture.PNG?:"]Capture.PNG[/url]


 

402
Online

5.4k
Users

12.6k
Topics

118.9k
Posts