Fog 1.2.0 - Multicast not cloning



  • Hi there. I´m new on Fog, it´s really nice and useful. I could successfully achive unicast tasks; I can clon ONE host without problem. But when I try to do a Multicast (either with one host or more), the clients boot fine, they pass all the steps, but then they stop at the cloning screen and don´t go on and don´t clon anything. Some kind of help? Thanks in advance.



  • @pabloinza Hi my friends. Finally i could solve this changing Ubuntu to ver 12.04. Here muticast works fine.



  • @ch3i No problem pal. I´ll try to investigate. Thanks!


  • Moderator

    @pabloinza said:

    @ch3i Ok, great! By the way, I´d like to install Fog WITHOUT dhcp service, on a PC which is currently running on a network that gets IP from the dhcp of a TP-LINK Router. I know I need to install dnsmasq service. I did it, the pxe clients get ip from the tplink router, but thay can´t reach properly the pxe boot file. Would you please give a hand whith this? The name of the files to edit and lines to type so as to let pxe clients boot prperly? Thanks so much!

    Never used dnsmask, sorry.



  • @ch3i Ok, great! By the way, I´d like to install Fog WITHOUT dhcp service, on a PC which is currently running on a network that gets IP from the dhcp of a TP-LINK Router. I know I need to install dnsmasq service. I did it, the pxe clients get ip from the tplink router, but thay can´t reach properly the pxe boot file. Would you please give a hand whith this? The name of the files to edit and lines to type so as to let pxe clients boot prperly? Thanks so much!


  • Moderator

    @pabloinza said:

    @ch3i Hi ch3i. Thanks fot contacting. If I decide to try a newer version of Ubuntu, which one would you recomend me? What is SVN?

    Ubuntu 14.04, for SVN version you have to read that : https://wiki.fogproject.org/wiki/index.php/SVN
    SVN versions are dev releases for next FOG (1.3)



  • @ch3i Hi ch3i. Thanks fot contacting. If I decide to try a newer version of Ubuntu, which one would you recomend me? What is SVN?


  • Moderator

    @pabloinza said:

    @ch3i Well well well…my last update of this thread:
    I restart the system, restart fog server, restart FOGMulticastManager service, and yes!..now it restart successfuly and let me do a multicast!
    I don´t know if it´s a momentary failure, if it´s my mistake or what. The point is I could solve it. I hope it keeps working! :(
    Thanks to all of you. If I have nes I tell you.

    Hi, not sure if it’s a momentary failure, but you have the solution to solve it. Please consider to use a recent version of Ubuntu/Fedora/Debian with FOG 1.2 or SVN version (SVN have awesome features and tweaks).



  • @ch3i Well well well…my last update of this thread:
    I restart the system, restart fog server, restart FOGMulticastManager service, and yes!..now it restart successfuly and let me do a multicast!
    I don´t know if it´s a momentary failure, if it´s my mistake or what. The point is I could solve it. I hope it keeps working! :(
    Thanks to all of you. If I have nes I tell you.



  • @ch3i
    /etc/init.d/FOGImageReplicator
    /etc/init.d/FOGMulticastManager
    /etc/init.d/FOGScheduler

    Finally now I understand the sentences in Ubuntu are CASE sensitive! :(

    So, I type again:
    service FOGMulticastManager restart

    and I get:
    start-stop-daemon: warning: failed to kill 948: No such process

    and the it fails to restart the service

    How to solve it?


  • Moderator

    @pabloinza said:

    Hi all you folks! Thanks for answering! Ubuntu version 10.04. How do I check if FOGMulticastManager service is running? I tried the comman line: sudo service FOGMulticastManager restart, and it says “service not recognized” How come?

    Result of ls -l /etc/init.d/FOG* ?



  • @Wayne-Workman Ubuntu 10.04



  • Hi all you folks! Thanks for answering! Ubuntu version 10.04. How do I check if FOGMulticastManager service is running? I tried the comman line: sudo service FOGMulticastManager restart, and it says “service not recognized” How come?


  • Moderator

    @pabloinza said:

    Hi there. I´m new on Fog, it´s really nice and useful. I could successfully achive unicast tasks; I can clon ONE host without problem. But when I try to do a Multicast (either with one host or more), the clients boot fine, they pass all the steps, but then they stop at the cloning screen and don´t go on and don´t clon anything. Some kind of help? Thanks in advance.

    Hi, can you check if FOGMulticastManager service is running ? The stuck a Partclone step in multicast is because Parclone wait for data.



  • What Linux distribution and version?


 

438
Online

5.4k
Users

12.6k
Topics

118.8k
Posts