Cannot connect to database after Ubuntu update and putting a password on MySql database



  • Ubuntu 14.4 - and I think Fog .32 (based only on my last post here as i dont remember how to check the fog version)
    Well, Ubuntu was saying there was an update and i figured updates are good (possibly my first mistake). There came a screen while doing the update that highly recommended i put a password on my database. so-I-did. Now i cant connect to fog in the web interface. The error is “cannot connect to database”. I found the following info :

    If you set a password for mysql when prompted on that blue box…during install.
    You need to do this in Terminal:
    sudo gedit /var/www/fog/commons/config.php
    And scroll down to mysql password and put your password in between the " " and save it.
    Then browse to your fog site and it should work.

    While many people responded that this fix helped them, it didnt help me. I got the error : rsp_write() failed:Bad File Descripter

    i’m thinking maybe because it was a 4 year old post and the paths may have changed? Help, someone please. I’m supposed to be updating images for the next school year and this has me at a standstill.



  • @Wayne-Workman ok, yeah, i understand my images are separate but i just wanted to make sure they wouldnt lose their DB identity. This may be a little above my area of expertise or even more than i have time for, but i will give it a look tomorrow and tackle it thursday if i am back down this way, or next monday. (I bet you cant wait!) Thanks so much, really, thanks



  • @obxmaureen said:

    @Wayne-Workman but then wouldnt i lose all my info? Would i have to recreate the images? I hope you know, i do appreciate all this feedback!

    If you can connect to the DB manually, you can easily export the entire DB.
    There are examples here:
    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL

    Also, the information in the DB is not your actual images. Your images are files located in the /images directory. The data in the DB is simply information about your images. We call this information the Image Definition.



  • @Wayne-Workman and i think Tom was having a hard time just staying connected, he never got farther that getting a putty session open. No biggie, he tried and i do appreciate that.



  • @Wayne-Workman but then wouldnt i lose all my info? Would i have to recreate the images? I hope you know, i do appreciate all this feedback!



  • @obxmaureen Vi works terribly through TeamViewer… Vim works perfectly though with TeamViewer.

    I’d say perhaps try to uninstall mysql and mysql-server and try to install mariadb on the box, and then run the installer.

    You’ll need to figure out how to take off mysql and this site looks like a good walk through for installing mariadb.
    http://www.liquidweb.com/kb/how-to-install-mariadb-5-5-on-ubuntu-14-04-lts/



  • @Wayne-Workman i realized i was missing the colon before the commands. oops. but i did manage to get the file changed. Still cant get the database to update. I have to leave for a couple days. Tom was trying to help me remotely but i think he was having issues with teamview. Maybe it’s just gonna have to be a wash. UGH!



  • @Junkhacker I did, they are. Still getting an error trying to upgrade the database in the browser.



  • @obxmaureen said:

    thanks Wayne, i did use those commands. q or q! never took me back to the prompt. They never really moved my cursor out of the file.

    You have to hit the “Esc” key to exit insert mode and go into command mode. Only in command mode does commands work.


  • Developer

    i recommend opening the file and making sure the changes were saved



  • thanks Wayne, i did use those commands. q or q! never took me back to the prompt. They never really moved my cursor out of the file. zz moved the cursor down to the bottom of the screen but never gave me the prompt. Believe me, your info and the link for Vi was valuable indeed and i appreciated it. I now have the password in the file but still get prompted to install/upgrade the database when i hit fog from the browser. And then the task fails :(

    am i SOL with this thing at this point?



  • @obxmaureen said:

    One question, how do you gracefully exit Vi after editing?

    :w means write
    :q means quit
    :wq means write then quit
    :q! means quit without saving

    These are in the tutorial I linked. https://wiki.fogproject.org/wiki/index.php/Vi



  • @obxmaureen said:

    One question, how do you gracefully exit Vi after editing?

    :w means write
    :q means quit
    :wq means write then quit
    :q! means quit without saving

    These are in the tutorial I linked.



  • thank you Junkhacker. i went into the Config.class file and added the password i had inadvertently added when i did the first Ubuntu update. It is still not working. One question, how do you gracefully exit Vi after editing? I typed zz and that did seem to close the file out but i didnt know how to get back to the prompt i know and love. So, i shutdown the server and restarted it. (I know, right?) I went back into the file to make sure the changes were there but got an error about the file still being open or not having been closed correctly and was walked thru fixing it. Well, the file now has the password in it, but still when I try to access Fog from the browser it prompts to install/upgrade the database and still bombs out. #anotherdaywasted I gotta head back up the beach. This server is 60 miles away from my office. Maybe some suggestions for tomorrow? Thanks so much for any help, i’m sure it is apparent, i have no idea what i am doing.


  • Developer

    the “update/install failed” was because it couldn’t connect to the database, because fog didn’t have the database password set
    now that you’re on 1.2.0, you need to edit the password in <web-root>/fog/lib/fog/Config.class.php



  • Well, interesting enough, the file does have info in it and the password field is empty, which, originally i had no password. (The last thing i did last week while waiting to hear any response from the forum, was a second Ubuntu update, hoping it would give me chance to change the database password) After that update instead of getting “cannot connect to the database”, I was getting a 404 error. I went ahead and upgraded fog to 1.2.0 cause you said i needed to do that anyways, (I’m sure i am just digging a deeper hole.) So, during that update, i am getting “update/install failed” from the web browser during the database update. No specific error, just a long list of stuff and no option to continue. I continued the Fog install but if i try to access the fog webpage, i just get kicked to the screen to install/update mysql. I found post that said to run sudo dpkg-reconfigure mysql-server-5.5 to reset the password but it wont let me set it back to no password. Am i just screwed, cause that’s kinda how i am beginning to feel. Should i open up another thread or just give up :/ i would love to save these images. I have hours of work on this server.



  • @Wayne-Workman i will be back at the location of the server on thursday morning. i will try your suggestions then. thanks so much!



  • @obxmaureen Don’t use gedit. Use Vi. Here is a brief tutorial: https://wiki.fogproject.org/wiki/index.php/Vi

    If the file is still blank when you view it with Vi, then odds are you’re looking at the wrong file or the documentation/posts you’re looking at do not apply to the version of FOG that you are using.

    Beyond this, I can’t help you any further than to ask you to upgrade to - most likely - FOG Trunk (because 1.2.0 has issues with Ubuntu 14.04). But, before you move to FOG Trunk, I would highly recommend upgrading first to 1.2.0 and then to FOG trunk.



  • thank you for your reply, i am sorry if i was not clear enough. i never see the contents of the file because when i run the command: sudo gedit /var/www/fog/commons/config.php in Terminal, all i get on the screen is the rsp_write error



  • Does the file have the things in it that the post says? A field for the mysql password?

    try editing the file with sudo. Then restart apache (or reboot the machine).


 

381
Online

41.5k
Users

12.0k
Topics

113.5k
Posts