Invalid Host - ID 0, has name and imageID - no MAC address



  • One of my hosts tried to register, got “invalid host” error. I cannot search specifically for that client (Search failed: Internal Server Error), but I can pull up the full list and it shows the host.

    I click on the host and it goes to a blank page with the ID=0 at the end of the URL. I exported the host list and see that it shows only the hostname (14-14924) and image id (62).

    Any ideas how to fix this? If I have to delete from the database manually, can you briefly describe how to?

    Thanks!!

    FOG 3735, Ubuntu 13.10



  • @Wolfbane8653 That worked to delete my host! Thanks


  • Developer

    You’re going to have to go into mysql database and delete the host with hostID=0.

    mysql -u root -p fog
    

    in mysql…

    select * from hosts where hostID=0 \G
    

    That will show all your hosts with a bad hostID then you will need to delete them…

    delete from hosts where hostID=0;
    

    FINALLY re-register the host you were having trouble with.


Log in to reply
 

430
Online

38940
Users

10697
Topics

101497
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.