Could not start download: Operation not supported (http://ipxe.org/3c092003)



  • Installed the latest FOG 1.2.0 on Ubuntu 12.04.4 LTS using all the defaults advised.

    When we PXE boot to inventory/Imaging a computer, we get an error:
    Could not start download: Operation not supported (http://ipxe.org/3c092003)

    If I pause at the point where it shows:
    iPXE 1.0.0+(3a02) – Open Source Network Boot Firmware – Features: NFS FTP HTTP HTTPS iSCSI DNS TFTP VLAN AoE bzImage ELF MBOOT PXE PXEXT Menu
    Configuring (net0 my MAC address)
    ……

    Then escape; I see the ‘FOG PXE menu’ as expected…

    This implies a timing issue. We have experienced this on several platforms, and despite not seeing anyone on here complaining of this, wonder if there might be a bug, or a TFTP setting that needs to be changed?

    My environment is on a test LAN with one ISP-router , FOG is also set as DHCP server. The same behaviour for all 4 different laptop models I tested. Also tested with gPXE USB-Boot, same result.

    Any help appreciated!

    Many thanks in advance.

    Kind regards,



  • Solved.
    Reason: windows 2012 dhcp failover error. (Two dhcp server with load balancing. Synhronization was’nt perfect, fog settings exist just one of them.) Sorry my english.



  • Same issue!
    Tryed: Lubuntu 15.04, Debian 8.04
    DHCP: windows 2012
    Any solution?



  • @duanekaeb said:

    @Wayne-Workman I can’t thank you enough. I forced the replication and my Scope Options are on both servers. I was able successfully access Fog 10 straight times.

    You’re welcome. Sometimes it’s good that I run my mouth when I don’t really know the answer lol.
    Just throwing darts at the board, ya know?



  • @Wayne-Workman I can’t thank you enough. I forced the replication and my Scope Options are on both servers. I was able successfully access Fog 10 straight times.



  • We might be getting somewhere. I have the DHCP roll install on two of my Win 2012R2 VM with one being the primary and one being the replica. The Scope options do not replicate from the primary to the replica for some reason just the address leases.

    The Computer in this picture is getting the same IP address each time and its pulling the correct bootfile. I only have 066 and 067 on our primary DHCP server which means it has to be using that server other wise I wouldn’t even get this far, correct?



  • @Wayne-Workman The other half of the time, it’s a mixture of weird firmware on computers, or bad DHCP helper addresses, or rogue DHCP.

    Some people will have redundant DHCP setup, and will only set their DHCP scope options on one and not the other… or a rogue is running and not handing out the right options… all kinds of craziness could be causing this.



  • @duanekaeb Inconsistency issues like this are - probably 50% of the time here on the forums - IP conflicts.



  • @Wayne-Workman I just tried this and I got the same results. Four out of the seven times I tried it it worked. Here is the error I got.

    image1 (1).jpg



  • @duanekaeb Try to use undionly.kkpxe and see what happens.



  • I’ve been having the same problem for a long time now. When I use the default undionly.kpxe and boot off my NIC port 50% of the time I get this error. Could not start download: Operation not supported (http://ipxe.org/3c092003) PXE-M0F: Exiting PXE Rom.

    I had been running Ubuntu 13.10 with Fog 1.2.0 and had been using a custom undionly.kpxe file I found online that worked a little better but it took over a minute to boot into the fog interface. I got frustrated with it and decided to start over and set up a new fog server. This time I installed ubuntu 14.04 with Fog 1.2.0 and I’m have the same issue.


  • Developer

    Are you using Cisco switches?



  • A few questions…

    What boot file are you using?

    Is your network a managed network? I.E. you have V-Lans established?

    What are these four models of laptops?

    Have you updated this 12.04 Ubuntu?

    Is Ubuntu firewall off? (UFW)

    Has/does FOG work on anything?


 

485
Online

41.5k
Users

11.9k
Topics

113.3k
Posts