CA certifiate and new client install : error



  • I’ve got a problem after uninstalling 0.8 : each time I try to reinstall 0.8 or new 0.9, I’ve got error

    Failed to download CA certificate.
    

    In fog.log

     06/07/2015 09:01 RegistryHandler 64 bit registry detected
     06/07/2015 09:01 Middleware::Communication URL: http://192.168.10.60/fog/management/other/ca.cert.der
     06/07/2015 09:01 Middleware::Communication ERROR: Could not download file
     06/07/2015 09:01 Middleware::Communication ERROR: Le serveur distant a retourné une erreur : (404) Introuvable.
    

    And in /var/www/fog/management/other, no file called ca.cert.der

    I tried to reinstall fog with ./installfog.sh -C -K or with ./installfog.sh --recreate CA --recreate keys, but still no file in fog/management/other, and same error message when installing client…

    And just for testing, I created a file called “ca.cert.der” (just with “touch” command) in /fog/management/other/, and after re-installed last svn with “./installfog.sh -C” command, file was no more present in “other” folder…

    Thanks for help


  • Senior Developer

    @el-psycho the new client can only be used with the development versions of fog. This is because the new client was coded along side the development versions. And believe me there are a lot of changes to make it work. The compatibility of legacy and new clients is still present, but 1.2.0 will NOT work with the new client.



  • Hi, I have the same error and would like to know how I can fix this.
    I have Fog server 1.2.0 and would like to use the fog client from github 0.9.4

    Thanks.


  • Senior Developer

    Teamviewered in and manually created the missing elements. i want to figure out exactly why it works or fails, but for now you should be good to go.


Log in to reply
 

370
Online

38983
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.