FOG Client 0.9.0 - Joining to domain?



  • So, I thought things should be all happy and fine with the new client update, but it appears not. Newly imaged machines end up in a reboot loop; each time they log on, I check the log and I can see the following:

     07/07/2015 14:24 Client-Info Version: 0.9.0
     07/07/2015 14:24 HostnameChanger Running...
     07/07/2015 14:24 Middleware::Communication URL: http://fog.cst.beds.ac.uk/fog/service/servicemodule-active.php?moduleid=hostnamechanger&mac=78:24:AF:39:02:A6|00:50:56:C0:00:01|00:50:56:C0:00:08||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     07/07/2015 14:24 Middleware::Communication Response: Success
     07/07/2015 14:24 Middleware::Communication URL: http://fog.cst.beds.ac.uk/fog/service/hostname.php?moduleid=hostnamechanger&mac=78:24:AF:39:02:A6|00:50:56:C0:00:01|00:50:56:C0:00:08||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService=1
     07/07/2015 14:24 Middleware::Communication Response: Success
     07/07/2015 14:24 HostnameChanger Checking Hostname
     07/07/2015 14:24 HostnameChanger Renaming host to CSTC112-2465469
     07/07/2015 14:24 HostnameChanger Unregistering computer
     07/07/2015 14:24 HostnameChanger Removing host from active directory
     07/07/2015 14:24 HostnameChanger Success, code =  0
     07/07/2015 14:24 Power Creating shutdown command in 60 seconds
     07/07/2015 14:24 Bus {
      "channel": "Power",
      "data": "{\r\n  \"action\": \"request\",\r\n  \"period\": 60,\r\n  \"options\": 2,\r\n  \"command\": \"/r /c \\\"Host joined to active directory, restart needed\\\" /t 30\",\r\n  \"message\": \"This computer needs to perform maintance.\"\r\n}"
    }
     07/07/2015 14:24 Bus Emmiting message on channel: Power
     07/07/2015 14:24 HostnameChanger Updating registry
     07/07/2015 14:24 RegistryHandler ERROR: Could not set SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerNameComputerName
     07/07/2015 14:24 RegistryHandler ERROR: Cannot create a stable subkey under a volatile parent key.
    
     07/07/2015 14:24 Power Power task already in-progress
     07/07/2015 14:24 HostnameChanger Registering host with active directory
     07/07/2015 14:24 Bus Emmiting message on channel: Power
     07/07/2015 14:24 Bus Emmiting message on channel: Power
     07/07/2015 14:24 Power Delayed power action by 10 minutes
     07/07/2015 14:24 Bus {
      "channel": "Notification",
      "data": "{\r\n  \"title\": \"Shutdown Delayed\",\r\n  \"message\": \"Shutdown has been delayed for 10 minutes\",\r\n  \"duration\": 10\r\n}"
    }
     07/07/2015 14:24 Bus Emmiting message on channel: Notification
     07/07/2015 14:24 Bus Emmiting message on channel: Notification```
    
    

    Anyhow - the point is, that the machine name doesn’t actually change. Is that anything to do with ERROR: Could not set SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerNameComputerName ? and why would that happen?


  • Senior Developer

    Fixed in v0.9.1.


  • Senior Developer

    Confirmed joining AD fails. I will work on this tonight and release a patch ASAP.


  • Senior Developer

    Just confirmed that hostname changing works as intended. It may be an issue with AD joining in combination with hostname changing though. Can I teamviewer into a machine having this issue (PM me if you are willing)?


  • Senior Developer

    If you manually reboot the computer does is the named changed?


  • Moderator

    @Jbob I can confirm that domain joining with FOG Client 0.9.0 - finally - works in my environment lol.

    Although, no hostname change was performed on the machine or inside AD for this particular host… and for the computers I’m about to image, no name change in AD is needed either, I believe…

    if it blows up in my face, I can revert to a previous snapshot and pretend it never happened. :-)


  • Senior Developer

    I’ll look into it later, its an issue with volatile registry keys… not fun at all.


  • Moderator

    @Jbob ???


  • Senior Developer

    Ew…


  • Moderator

    @Trevelyan

    And I was literally in the process of building an image with the 0.9.0 client…

    I’ll be on the lookout for this… but I don’t expect to encounter it since I use the early hostname change feature.


Log in to reply
 

373
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.