SVN3575 to SVN3696 hanged (php5-fpm)



  • I’m running fog svn on Ubuntu 14.04. Before the svn update, the system updater was run and the system was rebooted.

    When updating from svn3575 to svn3696 the fog installation hanged for more than 30 minutes at (other packages were all in the state “Already Installed”):

    * Installing package: php5-fpm..............
    

    I canceled the installation and tried to run again - then it failed at:

    * Installing package: php5-mcrypt.....................Failed!
    

    Installing “php5-fpm” by apt-get failed because it told me the dpkg process was cancelled and I should run “sudo dpkg --configure -a”. After this I could install php5-fpm by apt-get an run the fog installation script till the end.
    Didn’t test that much yet, but it seems to be OK now.

    Maybe it could be related to svn3609 (“Allow the output of php5-fpm to prompt user what to do”).
    If it is not related to fog and it is just another strange behavior of Ubuntu 14.04 this might also just be ignored…



  • Yesterday after getting SVN3696 working like described before i run the apt-get with dist-upgrade. But no updates have been found anymore.

    Today I updated from SVN3696 to SVN3710 and was able to install it without any problems.


  • Senior Developer

    I’m attempting, and failing I suppose, to use a “noninteractive” debian frontend statement that is supposed to keep the questions at bay and just perform the defaults, but this appears it isn’t working.

    I don’t know what to do for it. The documentation presented tells me this should work, and obviously it’s not.

    The quickest way I can say is to just run an apt-get update;apt-get dist-upgrade;

    Of course only confirm what you want to install, but this seems to be a much simpler approach at first.


Log in to reply
 

425
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.