Error when trying to upload to new storage node on USB Drive



  • I added a new storage node on our Fog server. The new storage node is located on a USB drive which I have auto mount at boot. The /etc/fstab file has the entry which mounts the drive and the /etc/exports file has been updated to include the path of the new storage node and its /dev path too.

    I have the permissions set the same on the new path as they are on the original path for the default storage node. I am able to use the original storage node as before to push images down or upload images. All that still works. I have copied a couple of images into the new storage node and been able to push them down to a couple of different computers. The only issue I’m having now is that when I try to upload a new image from a computer to a new image located on the new storage node it gives me an error saying that it can’t move the image from the temp area in /dev to the /images location on the new node. I checked the new storage node /dev directory and the temp image isn’t even being created. I’d expect it would have something to do with permissions or ownership but have matched those with what I see in the default storage node.

    So it would be great to hear of anything I may have overlooked. At this point, I could upload to the original, then copy it over, and then I’d be able to use it on the new node. That’s a workaround I’d rather not do. It would be cleaner just to upload straight to the new node.

    Also…I’ve noticed the Fog Dashboard Disk Information isn’t working properly. It shows two storage nodes now that I can pick from but no matter which one I select, I only see info that pertains to the original node. It isn’t showing all the extra space that exists on the USB drive which holds the new node. I’ve checked a few config files…freespace.php is one I’ve looked at but nothing seems to jump out at me as far as what I need to change to see the correct data displayed.

    Any ideas?

    Thanks,
    Steve


  • Moderator

    I assume you’re using FOG 1.2.0 ?

    The first thing to make sure of, since you want two INDEPENDENT storage nodes (non - replicas of each other), both storage nodes need to be inside their OWN storage group. They can’t be in the same group, it’ll only create problems down the road (for your specific desires).

    Set both as the master node of their storage group.

    Can you verify that the new storage node’s credentials are set correctly? https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP#Credentials_.2F_Passwords

    Also, you might wanna look into FOG Configuration -> FOG Settings -> Storage nodes. Those two fields are for the FTP user and pass, which would be the same since your 2nd storage node is local…

    You may also wanna look at how you’re mounting the USB disk with in /etc/fstab and make sure you’re mounting in a way that includes full permissions (read and write).


Log in to reply
 

493
Online

38916
Users

10687
Topics

101373
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.