Add new storage node with problems



  • Hello,
    i’m sorry for my English… i’m french!
    I’ve a fog server at school, i’m system administrator.
    i’ve ubuntu 14.04.02 LTS with fog 1.2.0 and about 500go of images (school’s computers)
    I’ve added a new storage node:

    • the same IP of the server
    • but on another disk that it is mounted without problems
      When i try to upload image, i can see the files on /images-test/dev/MACADDRESS but at the end of upload the image is not moved to the correct folder!
      I’ve checked permission (777), owner (i tried fog:root and root:root) with no solution!
      fog doesn’t display any error… so I’ve not idea!
      can someone help me?

    -mod edited /spelling-


  • Moderator

    @Tom-Elliott said:

    @rintintin76 Can you hit me up on chat? I’m not a french speaker (sorry) but I’m pretty sure I can get this all working properly.

    Thank you !!!

    TomEliot is so fast than @Tom-Elliott lol


  • Senior Developer

    This is solved through Teamviewer and @rintintin76.

    It was found that there were two nodes, and two groups.

    Remember, each group should have at least one master. The “Warning” that’s displayed is specific to changing the Master Node within a group, not adding a master node to a single group.

    So, the setting for the master node simply needed to be checked and all started working.


  • Senior Developer

    @rintintin76 Can you hit me up on chat? I’m not a french speaker (sorry) but I’m pretty sure I can get this all working properly.


  • Senior Developer

    @ch3i,

    To notify me, as I have a space in my username, Use the - symbol where the spaces are at. Also, I have 2 L’s and 2 T’s in my lastname.


  • Moderator

    @Tom Elliot I try to solve his problem without any solution >> please help lol


  • Moderator

    @rintintin76 lol tu peux me répondre en Anglais aussi ;) C’est juste qu’en PM ça va plus vite.



  • @ch3i
    Je viens de tester un upload sur l’ancien nœud (le raid 5) et ça fonctionne correctement:
    il a déplacé les fichiers du répertoire /images/dev/MACADRESS vers /images/nom_image.
    C’est le deuxième nœud qu’il n’arrive pas à le faire!

    @wayne-workman
    I just tested an upload on the old node (raid 5) and it works properly:
    it moved the files in the /images/dev/MACADRESS to /images/nom_image.
    is the second node that it can not do it!



  • @Wayne-Workman
    thank you for your answer.
    I’ve two storage groups with one node each one because i have added a disk to have more free space.
    now the configuration is:

    • one group with one node of about 600go (raid 5 sdb)
    • another group with on node of about 70go (jbod sdc)

    at the beginning the configuration was on group with one node (raid 5 600go sdb) and all worked fine. the problem began with the adding the second disk.
    with these news, do you need that i do what you asked me?
    best regards


  • Moderator

    Just for troubleshooting purposes only,

    Can you remove the two storage groups, and remove the two storage nodes, and just make one storage group, and one storage node?

    please set it to your /images directory.

    Then, set your permissions on the directory
    [CODE]sudo chmod -R 777 /images[/CODE]

    and try again?

    This should be a quick and easy process.


  • Moderator

    @rintintin76 said:

    @Wayne-Workman
    thank you for your answer.
    this is teh output:

    root@fogserver:~# cat /etc/vsftpd.conf
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES
    seccomp_sandbox=NO
    
    root@fogserver:~# cat /etc/exports
    /images                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1)
    /images/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2)
    /images-test                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=3)
    /images-test/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=4)
    
    root@fogserver:~# ls -laR /images-test/
    /images-test/:
    total 28
    drwxrwxrwx  4 fog  root  4096 juin  15 16:37 .
    drwxr-xr-x 27 root root  4096 juin  15 16:00 ..
    drwxrwxrwx  3 fog  root  4096 juin  15 13:58 dev
    drwxrwxrwx  2 fog  root 16384 juin   8 15:36 lost+found
    -rwxrwxrwx  1 fog  root     0 juin   8 15:54 .mntcheck
    
    /images-test/dev:
    total 12
    drwxrwxrwx 3 fog root 4096 juin  15 13:58 .
    drwxrwxrwx 4 fog root 4096 juin  15 16:37 ..
    drwxrwxrwx 2 fog root 4096 juin  15 16:37 080027d7ce6d
    -rwxrwxrwx 1 fog root    0 juin   8 16:05 .mntcheck
    
    /images-test/dev/080027d7ce6d:
    total 1053940
    drwxrwxrwx 2 fog root       4096 juin  15 16:37 .
    drwxrwxrwx 3 fog root       4096 juin  15 13:58 ..
    -rwxrwxrwx 1 fog root          0 juin  15 16:12 d1.has_grub
    -rwxrwxrwx 1 fog root    1048576 juin  15 16:12 d1.mbr
    -rwxrwxrwx 1 fog root   48207461 juin  15 16:12 d1p1.img
    -rwxrwxrwx 1 fog root        126 juin  15 16:12 d1p2.img
    -rwxrwxrwx 1 fog root 1029954830 juin  15 16:26 d1p5.img
    -rwxrwxrwx 1 fog root        310 juin  15 16:12 d1.partitions
    
    /images-test/lost+found:
    total 20
    drwxrwxrwx 2 fog root 16384 juin   8 15:36 .
    drwxrwxrwx 4 fog root  4096 juin  15 16:37 ..
    
    

    I want to clarify that the new storage node is part of another group
    so i’ve 2 groups with a node each one

    @Wayne-Workman Another information, he can move these files via FTP using Filezilla.



  • @Wayne-Workman
    thank you for your answer.
    this is teh output:

    root@fogserver:~# cat /etc/vsftpd.conf
    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_std_format=YES
    listen=YES
    pam_service_name=vsftpd
    userlist_enable=NO
    tcp_wrappers=YES
    seccomp_sandbox=NO
    
    root@fogserver:~# cat /etc/exports
    /images                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1)
    /images/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2)
    /images-test                        *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=3)
    /images-test/dev                    *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=4)
    
    root@fogserver:~# ls -laR /images-test/
    /images-test/:
    total 28
    drwxrwxrwx  4 fog  root  4096 juin  15 16:37 .
    drwxr-xr-x 27 root root  4096 juin  15 16:00 ..
    drwxrwxrwx  3 fog  root  4096 juin  15 13:58 dev
    drwxrwxrwx  2 fog  root 16384 juin   8 15:36 lost+found
    -rwxrwxrwx  1 fog  root     0 juin   8 15:54 .mntcheck
    
    /images-test/dev:
    total 12
    drwxrwxrwx 3 fog root 4096 juin  15 13:58 .
    drwxrwxrwx 4 fog root 4096 juin  15 16:37 ..
    drwxrwxrwx 2 fog root 4096 juin  15 16:37 080027d7ce6d
    -rwxrwxrwx 1 fog root    0 juin   8 16:05 .mntcheck
    
    /images-test/dev/080027d7ce6d:
    total 1053940
    drwxrwxrwx 2 fog root       4096 juin  15 16:37 .
    drwxrwxrwx 3 fog root       4096 juin  15 13:58 ..
    -rwxrwxrwx 1 fog root          0 juin  15 16:12 d1.has_grub
    -rwxrwxrwx 1 fog root    1048576 juin  15 16:12 d1.mbr
    -rwxrwxrwx 1 fog root   48207461 juin  15 16:12 d1p1.img
    -rwxrwxrwx 1 fog root        126 juin  15 16:12 d1p2.img
    -rwxrwxrwx 1 fog root 1029954830 juin  15 16:26 d1p5.img
    -rwxrwxrwx 1 fog root        310 juin  15 16:12 d1.partitions
    
    /images-test/lost+found:
    total 20
    drwxrwxrwx 2 fog root 16384 juin   8 15:36 .
    drwxrwxrwx 4 fog root  4096 juin  15 16:37 ..
    
    

    I want to clarify that the new storage node is part of another group
    so i’ve 2 groups with a node each one


  • Moderator

    How many storage nodes do you have?

    What is the output of this:
    [CODE]cat /etc/vsftpd.conf
    cat /etc/exports
    ls -laR /images
    ls -laR /images-test[/CODE]



  • @Wayne-Workman
    yes i’ve enough free space (63G on /images-test):

    [CODE]root@fogserver:~# df -h
    Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
    /dev/sda1 145G 6,1G 132G 5% /
    none 4,0K 0 4,0K 0% /sys/fs/cgroup
    udev 1001M 4,0K 1001M 1% /dev
    tmpfs 202M 396K 202M 1% /run
    none 5,0M 0 5,0M 0% /run/lock
    none 1010M 0 1010M 0% /run/shm
    none 100M 0 100M 0% /run/user
    /dev/sdb1 538G 422G 88G 83% /images
    /dev/sdc1 67G 701M 63G 2% /images-test
    root@fogserver:~#[/CODE]

    -mod edited to use code box-


  • Moderator

    Can you check your free space on your FOG server, do you have enough?

    [CODE]df -h[/CODE]



  • @Wayne-Workman

    yes, i have tried again, after change fog setting password, but the files are not moved…
    i don’t understand…


  • Moderator

    @rintintin76

    Moving from /images/dev to /images happens during image upload.

    Have you tried to upload again since you’ve set your credentials?



  • Thank you for your reply.
    i’ve found a mismatch password on FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD

    now the username and the password are the same everywhere:

    • The local ‘fog’ user’s password on the Linux FOG server
    • list itemStorage Management -> Your storage node -> Management Username & Management Password
    • FOG Configuration -> FOG Settings -> TFTP Server -> FOG_TFTP_FTP_USERNAME & FOG_TFTP_FTP_PASSWORD

    but the files are not moved from /images-test/dev/MACADRESS to the correct folder!

    the all others test are ok (test ftp file download and delete, vsftpd restart)

    can you help me?
    best regards


  • Senior Developer


Log in to reply
 

468
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.