Error mounting XX.XX.XX.XX:/fog/ on /fog



  • I’ve noticed I’m getting this error once I’ve downloaded the image.

    The image downloads correctly.

    I’ve checked /etc/exports and I haven’t seen any /fog export

    Any idea?


  • Senior Developer

    I see the error too. I’m glad you were able to find it and I went ahead and solved this thread.

    Thank you for reporting back as to what you found and the potential fix for this particular issue.



  • Found the issue!!!

    It was one of the postdownload scripts that we use

    if [ $osid == "5" -o $osid == "6" -o $osid == "7" ]; then #only handling Win7/8/8.1
        clearScreen;
        mkdir /ntfs &>/dev/null
        ntfs-3g -o force,rw $part /ntfs #mount image (remember this is mounting partition [U][B]after[/B][/U] new image is deployed)
        mkdir /fog &>/dev/null
        mount -o nolock,proto=tcp $storageip:/fog/ /fog #this is a share created on server under /fog which contains drivers, software etc.. (just add /fog to exports but you could use existing location i.e. /images and if you do, do not need to do this mount as /images is still mounted at this point)
        dots "Mounting Device";
        if [ "$?" = "0" ]; then
            echo "Done";
            #'. ${postdownpath}fog.drivers # run fog.drivers script
            . ${postdownpath}fog.ad # then run fog.ad ... you get the jist
            #'. ${postdownpath}fog.snapins
            umount /ntfs; # unmount when all is done :-)
        else
            echo "Failed To Mount Device";
            sleep 30;
        fi
    fi
    


  • So now, the question is… Why is your clients trying to mount x.x.x.x:/fog ??

    I’ve been very busy today. I’ll get back to this either tonight or tomorrow, but keep checking back because someone else might help.



  • @Wayne-Workman said:

    select ngmRootPath from nfsGroupMembers;

    mysql> use fog;
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Database changed
    mysql> select ngmRootPath from nfsGroupMembers;
    +-------------+
    | ngmRootPath |
    +-------------+
    | /images     |
    +-------------+
    1 row in set (0.00 sec)
    
    mysql> 
    


  • Can you tell us what the output of this is?

    [CODE]sudo mysql
    use fog;
    select ngmRootPath from nfsGroupMembers;
    exit[/CODE]



  • root@fog2:~# service nfs-kernel-server restart
     * Stopping NFS kernel daemon                                                                                                 [ OK ] 
     * Unexporting directories for NFS kernel daemon...                                                                           [ OK ] 
     * Exporting directories for NFS kernel daemon...                                                                             [ OK ] 
     * Starting NFS kernel daemon                                                                                                 [ OK ] 
    root@fog2:~# 
    
    root@fog2:~# service rpcbind restart
    rpcbind stop/waiting
    rpcbind start/running, process 27783
    root@fog2:~# 
    

    They seem to restart correctly

    This is how the Default Storage Node looks like:

    Captura de pantalla 2015-06-15 a las 9.00.08 PM.png

    All the images under /images are drwxrwxrwx


  • Senior Developer

    In your Storage Management Page, you have the images path for this node set to look at /fog, but the exports looks like it’s looking for /images. Which path are your images located in?



  • Can you set 777 perms recursively for the /images directory?

    [CODE]sudo chmod -R 777 /images[/CODE]

    Also, what happens when you re-start NFS? Any errors?

    [CODE]sudo service nfs-kernel-server restart
    sudo service rpcbind restart[/CODE]



  • Hi, I’m running Ubuntu 14.04 with fog version SVN 3551

    My exports file looks like this

    root@fog2:~# cat /etc/exports 
    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    root@fog2:~# 
    

    2015-06-15 11.11.11.jpg


  • Senior Developer

    I’m just guessing, you setup your fog server on a fairly recent revision of fog? That’s the only way, I can think of, that you were able to tell with storage node you want FOG to operate with.

    Check your exports file and show us a copy please?

    To display it without potential markdown translating here on the forums, use the </> icon above or three backticks[enter]yourcontent[enter]three backticks.


  • Moderator

    @YuYo

    Hi,

    Fog version ? OS ?
    Please provide the configuration of the image and the storage concerned. (screenshots if you want)

    Ch3i.


 

450
Online

41.5k
Users

12.0k
Topics

113.5k
Posts