TFTP no go for me...



  • I have been having issues with my fog install/operation for a few days.
    I had installed Ubuntu 10.04, 12.04, & 14.04 with FOG 1.2.0 and all seemed like it was going to work until I booted a laptop with PXE and the TFTP area on the screen was blank…and it stated that it was exiting intel boot agent.
    Client IP, Mask, DHCP IP, and Gateway were all correct.
    But failed to see FOG boot screen options.
    I would like to use a newest version available, but not sure if I need to go all the way back to 10.04 & 0.32.
    Any help would be greatly appreciated.



  • Thanks to Wayne for all his help!


  • Moderator

    I was able to help him get FOG Trunk working on Fedora 22.

    The issue was with his DHCP scope settings. He was setting one location as specified (undionly.kpxe), but a higher up global setting was overriding it with pxelinux.0 and was breaking everything.


  • Senior Developer

    I am considering this posting solved. There are two ways you can fix this issue. First way, as you likely don’t want to upgrade to trunk quite yet, would be to edit the file from the install folder location which will be lib/ubuntu/functions.sh. Search for 0.0.0.0:69 and replace it with just :69. The second way would be to upgrade to trunk. https://wiki.fogproject.org/index.php/Upgrade_to_trunk


  • Developer

    I noticed this issue yesterday on my 1.2.0 test server. After digging through several unresolved bug reports for Ubuntu and Debian, I found that tftpd-hpa no longer likes being bound to 0.0.0.0:69. It now prefers :69 without the IP. Apparently, it can’t resolve 0.0.0.0 (which is ridiculous).

    The quick fix is to edit the /etc/default/tftpd-hpa file. Change the value of TFTP_ADDRESS to equal “:69” instead of “0.0.0.0:69”.

    This was resolved in SVN 3539/Commit eadae1b.

    Try that out and see if it fixes your problem.



  • I would like to run 12.04 and 1.2.0…I changed the DHCP setting on 067 from the prelinux.0 to the undionly.kpxe. That was the only thing on the DHCP that was changed.
    Regarding the old OS…I attempted to upgrade to 12.04 and it bombed in the middle of the process and did not allow me to access. So…I wiped it and installed the 12.04 via cd…then all the others via cd. My images are gone.
    The problem I was having with the TFTP when the server is connected to the network is that it does not list any item on the PXE boot screen of the client in the TFTP area…and exits the boot…and never shows the FOG boot screen where I can choose Full Host Registration/Quick Image/etc. If I disable the server from the network and attempt to boot my client machine instead of the TFTP area being blank…it times out…with about 5 or 6 periods following the TFTP area in the PXE boot area…then exits boot…obviously never seeing a FOG boot screen with Full Host Reg/Quick Image/etc.
    This happens on all versions of Ubuntu that I installed. The only constant in the mix is the same version of FOG 1.2.0.
    What do you suspect would change with running the install again. I think everything is basically set to default from what I remember…
    I set the ipaddress of the server
    I set the ipaddress of the DHCP server
    I set the ipaddress of the DNS server
    all in the install process.
    Does this sound funny…I feel like I am doing a small step wrong or something…but…it sure is eating my lunch…breakfast…and dinner.
    Thanks for your time.


  • Moderator

    There are no reasons why 12.04 and 1.2.0 shouldn’t work.

    You said you changed DHCP? Perhaps your old FOG build was using dnsmasq?

    So… you installed a newer OS on top of the machine that had your images? Did you upgrade or wipe and install ? Do you have SSH access to the box? Can you use SSH to verify if your images are still there or not?

    How about trying to re-run the 1.2.0 installer? See what happens?



  • I am not certain on the firmware settings.
    I have been using the same computer as my FOG server for nearly 3 years and not touched it for any reason until yesterday…thought it was time to update and then upgrade. I lost all my settings and images and data. Not happy, but not the end of the world.
    Some things that I do remember that I have changed earlier today is the DHCP to the undionly.kpxe in 067 settings from the 0.32 recommendation. I don’t know much about linux, as you can probably tell, but I don’t think this should be this hard to configure especially since it worked with 10.04 & 0.32 on the same box.
    I have read through the trouble shooting TFTP and was able to transfer the undionly.kpxe from the FOG server to a windows box using command window.
    I have not tried FOG with any other box…I have nearly 1300 laptops that we imaged the past 2 summers using FOG.
    Is there any reason that 12.04 & 1.2.0 should not work for me?
    Thanks for your help…


  • Moderator

    Is (u)EFI turned on in the firmware settings? Is Secure Boot turned off? Do you have legacy ROM support enabled in the firmware?

    What model is it? Look at our hardware lists?
    https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices

    What bootfile are you using? Have you tried undionly.kkpxe yet?

    Have you read the article on Troubleshooting TFTP ?
    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP

    Does FOG still work with other devices?


Log in to reply
 

402
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.