Fog 1.2.0 PXE Problems with Certain models



  • Hey everyone, i’m having a issue with certain models of computers and i’m not sure how to fix it.

    FOG Server (Dell2900) Ubuntu 10.04
    Fog Version: 10.2.0 (fresh install, imported in my hosts)
    DHCP: Set the DHCP to point to udionly.kpxe

    Here is my problem, when i boot up a Dell Latitude e5550 PXE Starts, and it gets to a spot that shows "configuring (net0 34:e6:d7:37:52:0b)…

    It reboots the computer and never uploads the image like the task shows. I’ve had this happen with an acer laptop, so i don’t think it’s specific to this dell model, but some of my dell models will boot up just fine. I’ve updated the kernel to the latest published version, still they boot loop. Has anyone seen this? It did not do this to me on version 0.32.

    IMAG0354.jpg

    It reboots right after this.

    UPDATE: I just had the same issue happen with a dell 6500 (older model). any help would be appreciated! Thanks!!



  • @Wayne-Workman

    That makes sense, the only reason we stuck with the desktop version is we have on site people that are not all that technical. Walking them through a CLI is tough sometimes if we can’t remotely manage. If i can’t get the trunk version installed on this version of ubuntu, next time i’m on site i will defiantly try a debian cli.

    I’ll post anymore updates as soon as i can. Again, thanks for the info and i’ll let you know how it goes. Thanks again!


  • Moderator

    @mccabem

    • FOG installs more cleanly on Debian (honestly, more cleanly on every other distro)

    • Using Debian CLI only, your FOG server will boot up much faster since the RAM-hungry GUI isn’t starting.

    • Ubuntu continues to stray further away from Linux norms. Tom explains it best.

    • Everything from installation, low-level management, troubleshooting, and migration with FOG happens at CLI… so a GUI serves absolutely no purpose other than making you feel good.

    • Using a server-based CLI only installation will be more secure, you’ll have less updates to download when you update.

    • Simpler troubleshooting - you don’t have excessive things installed like Libreoffice and other user applications that your FOG server doesn’t need.

    These are just some things I thought of off the top of my head.

    The OS you choose and version of FOG you choose is completely up to you, and we are here to help you with whatever you choose.

    You could stay with Ubuntu, but FOG 1.2.0 does not support the latest Ubuntu or Debian or Fedora or CentOS or RHEL without some finagling, which is why I suggested moving to FOG Trunk.

    You could move just one site to FOG Trunk and a server-based Linux distro and see how it goes. I feel you won’t find it any more difficult, and I’m positive you’ll like the speeds that FOG Trunk offers.



  • @Wayne-Workman We have about 30 sites using fog, all of them are identical as much as possible to make it easier for our people to manage. Is there any benefits when using Debian over Ubuntu? Is it worth changing all of them? Thanks for all the help!


  • Moderator

    @mccabem While you’re in the business of re-building FOG servers, why not jump to FOG Trunk and use Debian instead of Ubuntu?
    https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk

    I don’t say “Debian” lightly… I’m a red-hat kinda guy.



  • @Tom-Elliott

    Ok, so i tried the link you sent and it would never work. It said the link i added to my sources was wrong and wouldn’t allow me to install. SO, i downloaded the v14 of ubuntu desktop, re-formatted the server, and when i try to install the 1.2.0 version of FOG, it errors out of Mysql install.

    Capture.PNG

    I got a copy of this log, see attached foginstall.log

    I have to leave to head back home, but let me know what you guys think. I can remotely manage this server, i just won’t be able to test the pxe until i come back on site. Let me know what you think on why this is failing. I always stuck with 10.04 because it was stable and i never had much of a issue using it until now :(

    Thanks again for all the help!


  • Senior Developer

    @mccabem

    You probably need to install php-mysqlnd yourself as Ubuntu 10.04 is very old now. I don’t think it was a native part of their package listings.

    Here’s a link that should help.
    http://stackoverflow.com/questions/3407823/mysqlnd-driver-in-php-5-3-2-on-ubuntu-10-04


  • Moderator

    @mccabem Two spots, he’s probably wanting copies of any errors in all of the FOG logs.

    FOG Configuration -> Log Viewer - > Apache Error Log.

    You can also issue this on your FOG server:

    tail -n 100 /var/log/messages
    


  • @Tom-Elliott, how do i get these console errors for you? I’m pretty green on linux and i’m using ubuntu 10.4 desktop version.



  • Ok, I tried to upgrade the version of FOG to trunk as you suggested @cml. I got an error at PHP5-Mysqlnd. See the image attached.
    Capture.PNG
    I also tried to upgrade the undionly.kpxe with the exact instructions, everything looked like it went well but when i booted to FOG it failed at “booting to default.ipxe” and just sat there, did not reboot or anything.



  • This post is deleted!

  • Senior Developer

    The other bit, is if you can see what the error is (My guess is Console Errors), it should help tremendously in giving a suitable fix.


  • Moderator

    I had the same issues with one particular model that is now working fine, so this may be solved by upgrading to trunk.

    You can also try upgrading your undionly.kpxe file to the trunk version.

    cd /tftpboot/
    mv undionly.kpxe undionly.kpxe.bak
    wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/undionly.kpxe
    


  • @mccabem Which pxe file are you passing to your machines? Undionly.kpxe?



  • Yes, the one in the picture is a brand new Latitude 5550. I’m having this same issue with a 5 year old dell, that never had issues before this upgrade. Do you have a link to this fog trunk you are talking about? For so many years fog just worked out of the box, actually trouble shooting issues is new to me lol

    edit:
    I just checked the working compatibility list and my new model is in fact not on that list, but my older 6500 is. Odd


  • Moderator

    That looks like a really new Dell laptop in the above picture… It’s most likely a compatibility issue… you might need to move to FOG Trunk to image those newer laptops…



  • Thanks for the Reply Wayne! I’ll defiantly try the kkpxe option! I’m not sure if this has anything to do with UFI or Secure boot, as my Latitudes 6500 are having the same issues, and they are old enough those options are not in the BIOS. I thought maybe me using my database from 0.32 could have been the problem, so i started over from scratch and it still is doing this… It’s a real hair puller :( Any more suggestions would be greatly appreciated, but i’ll try that kkpxe option next time i am on site. Thanks again!


  • Moderator

    Be sure that secure boot is turned off, legacy ROM support is turned on, BIOS mode is on, (u)EFI mode is off… etc…

    Also, you might want to try undionly.kkpxe It is more reliable for weird BIOS setups.

    Additionally, if you wanted to try FOG with (u)EFI booting, you’d need to pick out an .efi file from the /tftpboot directory. The ones in the root of /tftpboot are 64bit, there is an i386 (don’t quote me) folder in there that contains 32bit boot files.

    Also, check our working hardware / problematic hardware lists… tons of info in there.

    https://wiki.fogproject.org/wiki/index.php/WorkingDevices
    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices


Log in to reply
 

412
Online

39210
Users

10856
Topics

103343
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.