Download Task Failed



  • Total Newb to both Ubuntu and Fog.

    Inherited a Fog system from the previous person. I create an image, attach to a host, and uploaded. After this, not only does the Fog server report 0.00 ib as size on server but if I try to download to a new host, I get the message “Download task failed to create for xxxxxxxxxxxx with image yyyyyyy. To setup download task, you must first upload an image.”

    As far as I know, I did the upload. It took almost two hours and finished without any messages.

    I thought that this may be a problem with the Fog server so I removed the hard drive from the server, replace with a new, reloaded Ubuntu 14.04 LTS (desktop), and reinstalled Fog 1.2.0 using YouTube videos for guidance. I get the exact same error so now I’m thinking that my process for uploading the image is incorrect. I have noticed that if I create an image called yyyyyyy, the image on disk under the /images/dev folder is under a folder with the MAC address of the computer that was uploaded. It looks like images created by the previous person have a folder name the same as the image name.

    Does anyone have any ideas? The previous person is not available for me to call and I have a lot of computers to image.

    Thanks in advance.


  • Senior Developer

    @fsu1tm I sent you a message in chat as I am sure we can help fix this issue for you. It’s relatively simple to work out.

    The FOG_STORAGENODE_MYSQLUSER and FOG_STORAGENODE_MYSQLPASS are for storage nodes to link to a central fog server.

    Hopefully this helps explain that. These are not what you would want to put in your main server, though I suppose it wouldn’t hurt them either.



  • Interesting. I ran “sudo service mysql status” and it responded that mysql was running but I went ahead and did “sudo service mysql restart”. I then did the FOG restarts. Each of those replies looked like (depending on process):

    *Restarting FOG Comupter Imaging Solution: FOGScheduler
    start-stop-daemon: warning: failed to kill 1152: no such process

    But now I can get into FOG and it’s not taking me directly to Database Schema Update/Installer so that is good.

    I then tried to upload an image but the client is getting a TFTP Timeout error and rebooting. I gues that I am still stuck on the credentials.

    When I log into the machine - username = fog, password = xxxxx
    When I log into FOG via FireFox - username = fog, password = password
    When I check, FOG_TFTP_FTP_USERNAME = fog, FOG_TFTP_FTP_PASSWORD = xxxxx
    When I check, FOG_STORAGENODE_MYSQLUSER = fogstorage
    When I check, FOG_STORAGENODE_MYSQLPASS = fs87054970106

    xxxxx is not my real password but the others are. The TFTP password does match the machine login password.

    It’s interesting that when MySQL was installed during the FOG install that I used xxxxx as the MySQL password but the
    FOG_STORAGENODE_MYSQLPASS is something totally different. Does this matter?

    I can FTP from my Win7 computer into the FOG machine using: username = fog, password = xxxxx

    Not sure where things are going wrong now.


  • Senior Developer

    Well,

    Ubuntu has issues with mysql. Particularly anything 12 and greater seems to be hugely a problem from my experience.

    The quickest way to see if things are running would be:
    sudo service mysql status

    If it’s dead, you’ll restart it with:
    sudo service mysql restart

    Also, if it’s dead, you’ll need to restart the fog services (after mysql is restarted):

    sudo service FOGMulticastManager restart
    sudo service FOGScheduler restart
    sudo service FOGImageReplicator restart
    

    If you’re on SVN you’ll also probably need to add:
    sudo service FOGSnapinReplicator restart

    To help prevent this in the future, follow these steps as needed/particularly the rc.local steps.
    https://github.com/fogproject/fogproject/issues/1



  • I have not but I just restarted the server and made no changes to MySQL. Sorry, Newb here, but how would I check to see if it’s actually running?


  • Senior Developer

    Have you checked to ensure mysql was actually running?



  • I can’t even get into Fog Config -> Fog Settings -> Fog Storage Nodes. When I got to Fog management, it takes me directly to Database Schema Installer/Updater.



  • No. I set the MySQL password when setting up FOG.


  • Moderator

    You changed your MySQL password?

    You’ll also need to update that user/pass inside FOG Config -> Fog Settings -> Fog Storage Nodes



  • OK. Found the two sections within FOG for TFTP password and Storage Management password. I made sure that both of those were set to the same password (user was already set the same) as the local Ubuntu fog user and the password that I used when setting up MySQL. I saved both settings, closed FOG and rebooted the server. I reopened FOG and verified the password held and it did. I then went to Storage Management to verify the password held there. As soon as I clicked on Storage Management, I got a message that my database schema was out of date and that I needed to click the button to update. I clicked the button and now get a lot of MySQL errors about can’t create tables, etc. On the PLUS side, I can now log into Ubuntu FTP from another workstation. What do I do about these MySQL errors that are returned through the FOG interface?

    Thanks again.


  • Moderator

    @fsu1tm In the Troubleshoot FTP article below, in the credentials section, it tells you exactly what needs to match, and exactly where it’s set.

    Let us know if you need help.



  • I completely reinstalled Ubuntu and Fog again following the Wiki. I’m pretty sure that it’s a credentials issue. At least according to the document provided by ch3i. I now cannot FTP into the Ubuntu server. A couple of questions:

    1. The default username and password for the fog interface is fog/password. This is not the same password that I entered when installing Ubuntu and MySQL. How do I change the Fog password? Could this be affecting FTP?

    2. Where do I find Storage Management to check credentials there? Sorry but real newb to Ubuntu and Fog.

    Thanks.


  • Moderator

    Apologies for the vagueness…

    We always want you to try to help yourself first… and if you need assistance along the way with anything, we’ll do our best to help. So, if you need help, just ask.


  • Moderator

    Look at the “credentials” section in that article.


  • Moderator

    @fsu1tm

    In your FOG web ui, in FOG Settings, you have :

    • FOG_TFTP_FTP_USERNAME
    • FOG_TFTP_FTP_PASSWORD

    Try to connect to your FOG server via FTP using these credentials.



  • Thank for reply, Ch3i. I checked the function of FTP and it seems to be working. I then found the section in the document you referenced that directly addressees my issue but I’m not sure how to address “Way 1” or “Way 2” as I have no /opt/fog/.fogsettings file and I’m not sure about a “storage node”. I have only one fog server.

    The installation setup by the previous person seems to have worked before (at least I’m told). I don’t know of any changes to the server that would have made it stop working.

    Any more ideas?


  • Moderator

    @fsu1tm

    Hi,

    Here : https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP
    Find “Common problems and fixes”.

    Regards,
    Ch3i.


Log in to reply
 

399
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.