Multiple TFTP servers multi subnet fog 1.2.0



  • Afternoon fellow Fog users…

    I’m in the process of updating our multi site office to using Fog 1.2.0. I have 1 main site running a normal node and storage node on one subnet and 7 remote sites all on different subnets running storage nodes.

    I would like to use the main server in head office to house all the host and image definitions and be the command and control centre but have images stored on the remote storage nodes so the image files pull over the LAN not the WAN. Up til now I’ve been running standalone servers at each site but this means tweaking the image so it has the “local” fog server address in C:\Program Files (x86)\FOG\etc\config.ini

    I have already configured this part but think I need to enable TFTP service on all the remote nodes due different subnets. I’ve followed this post from the wiki:

    My issue is this step under 1.x.x heading…

    Edit the main

    /opt/fog-setup/fog_version/bin/.install.sh
    

    script. Locate the section titled # Storage Node installation. Insert the following line after configureFTP; and save the script:

    configureTFTPandPXE;
    

    On my Ubuntu and Centos boxes I have downloded the installer to /opt/fog_1.2.0 so I’d expect the above path to be

    /opt/fog_1.2.0/bin
    

    The script there is actually installfog.sh not install.sh and if I try editing that file it shows:

    #!/bin/sh
    
    script /var/log/foginstall.log -c ./.install.sh
    
    

    I can find the 2nd script mentioned in instructions ok:

    /opt/fog-setup/fog_version/lib/ubuntu/config.sh
    

    So either the instructions I’m reading are out of date or wrong or (more likely) I’m completely misunderstanding something. I’ve searched the current forum for Multiple TFTP Server but not found any hits.

    My question therefore is: Are there updated instructions for this under Fog 1.2.0? And I guess my other question is, is this still the best method for multiple site setup? Any other gotchas I should be aware of? I read somewhere WOL doesn’t work, is that correct?

    regards, Kiweegie.

    p.s. loving the new forum layout and Fog in general…



  • @Sebastian-Roth

    sry haven`t found this thread before.

    Thx for this.

    My workaround works only randomly, i think rc.local is the best way.


  • Developer



  • Okay i kicked the 3 FOG Service manually out of the runlevels from rc.0 to rcS and let them join again with
    "update-rc.d fogscript defaults " and it works.

    With “top” i can see the Service running now after startup.

    See someone a problem in this workaround?

    Seems FOG Multisite\Multisubnet don`t work on ubuntu 14.04 without some troubles… ;-)



  • @robin-masters

    okay i check this out - the 3 FOG Services dont start at startup with Ubuntu 14.04.
    Have to stop and start it again after the reboot… then it works?

    Any Ideas?



  • @george1421

    Hey thanks for this explanation!

    Okay, chkconfig is not a package of ubuntu but rcconf and it shows me that the FOG scripts are set to autostart.

    I also find links of the scripts correctly under “/etc/rc1.d” to “/etc/rc5.d”.

    But when i reboot the system and try to restart the FOGImageReplicator script with “/etc/init.d/FOGImageReplicator restart” it appears:

    root@image-server:/etc/init.d# /etc/init.d/FOGImageReplicator restart
     * Restarting FOG Computer Imaging Solution: FOGImageReplicator                                            start-stop-daemon: warning: failed to kill 1465: No such process
                                                                                                        [ OK ]
    

    Seems it is a problem with the service script and ubuntu. The script /opt/fog/Service/fogmain … works.

    If i stop the script with “/etc/init.d/FOGImageReplicator stop” and start it again with “/etc/init.d/FOGImageReplicator start” … it works… strange.


  • Moderator

    The FOGImageReplicator is run as a service not a cron job. Look in the /etc/init.d directory for the service descriptor. (next is going to be a rhel based command) Run the chkconfig FOGImageReplicator --list to show you if the image replicator service is set to auto start. Under debian based systems chkconfig may not be installed by default.



  • @Wayne-Workman

    Okay there is one last question… eventually… ;-)

    The sync works only if i start the FOGImageReplicator script manually is there no crontab in the install script? (I think this was the problem at the beginning not the path to WEBROOT)

    How do FOG cronjobs? - where can i find the Jobs?



  • @Wayne-Workman

    Okay i have reinstalled the storage node and add the storage node in the webinterface of the master node again and nothing happens.
    No changes in log files and so on, seems nothing works.

    Seems /opt/fog/etc/config.php was wrong for ubuntu 14.04 with Apache 2.4.7.
    (The folder exists but it`s not the standard webroot of the Apache)

    change this from

    <?php
    define( "WEBROOT", "/var/www/fog" );
    ?>
    

    to

    <?php
    define( "WEBROOT", "/var/www/html/fog" );
    ?>
    

    On MasterNode and StorageNode.

    If i start the FOGImagereplicator script it works now…



  • @Wayne-Workman

    Hey thx for answering.

    The issue with the storage pie chart on the dashboard is solved. The MySQL bind address of the Master Node was set to localhost, so no incoming connection from the storagenode was possible.

    Not a unimportant fact because in ubuntu 14.04 mysql-server bind-address is set on localhost by default.
    (a reminder in the wiki would be nice - for ubuntu don`t know how it is in redhat)

    But the sync of the images still don`t work. Have wait for 16h.
    In /images/ folder of the StorageNode are only the standard files (.mntcheck) and folder (dev and postdownloadscripts)

    I will reinstall the storagenode and see what happens…


  • Moderator

    @Wayne-Workman said:

    @robin-masters You’ve asked multiple questions, I think one of them was directed towards the storage pie chart on the dash board. That’s based on FTP. You need to have the correct FTP credentials set for the storage node. You might look through this article that is written just for FOG FTP Troubleshooting: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    I stand corrected, the storage pie chart on the dashboard is not FTP based, but could you look at the web-root setting for this storage node and ensure it’s correct? Can you post a screenshot of this area?


  • Moderator

    @robin-masters You’ve asked multiple questions, I think one of them was directed towards the storage pie chart on the dash board. That’s based on FTP. You need to have the correct FTP credentials set for the storage node. You might look through this article that is written just for FOG FTP Troubleshooting: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP



  • Greetings,

    one question to this issue.
    Configuration:
    master node fog 1.2.0 with ubuntu 14.04 in subnet 1
    storage node fog 1.2.0 with ubuntu 14.04 in subnet 2 (with own dnsmasq configuration)

    Both are in one storage Group.

    Connecting to both via nsf, tftp, ftp is possible from both subnets.
    I followed the instructions from here for ubuntu:

    https://wiki.fogproject.org/wiki/index.php/Multiple_TFTP_servers#Adding_the_Node_to_the_Management_Portal

    I think it`s all fine but in the FOG Management Dashboard appears “Failed to connect to.” if i choose my new storage node. The Log Show old entrys.

    [10-15-15 6:51:03 am]  * I am the only member, no need to copy anything!.
    [10-15-15 7:01:03 am]  * Starting Image Replication.
    [10-15-15 7:01:03 am]  * We are group ID: #1
    [10-15-15 7:01:03 am]  * We have node ID: #1
    [10-15-15 7:01:03 am]  * I am the only member, no need to copy anything!.
    
    

    at the beginning (after install of fog)

    [10-14-15 2:50:58 pm]  * Starting FOG Image Replicator Service
    [10-14-15 2:51:03 pm]  * Checking for new tasks every 600 seconds.
    [10-14-15 2:51:03 pm]  * Starting service loop.
    [10-14-15 2:51:03 pm]  * Starting Image Replication.
    

    I set the correct storage node password an so on… have no ideas anymore.

    First question… what protocols are necessary for a connection from fog master Server to his storage node?
    NSF, TFTP; FTP … mysql too?

    Why i sea only old logs? The last entry are from 20.oct.2015 actually we have 03.nov.2015 and the Server is running? (today i make a restard of the master)
    Can i start the sync with a command?



  • @Tom-Elliott HI Tom, I’m nearly there but something is still not quite right…

    I want to have a set of images (but not all) replicate from my main server to my remote sites. To that end I’ve got the following set up.

    Site1 = Main server and one Storage Node
    Sites2-8 - Storage Node at each site

    Site1 has 2 storage groups, default and replication
    Main server (DefaultMember) points to the default storage group
    Storage node site1 points to the replication storage group and is set as the Master node for that storage group
    Remote sites Storage nodes also point to the replication storage group

    Within each storage node I’ve configured the Management Username and Management Password with the credentials provided in the storage node setup proces. Also double checked these were correct as shown in

    /opt/fog/.fogsettings
    

    But replication fails to kick in. If I swapped it around so everything pointed to the default storage group I could see that replication started off. Image was initially scp’d to the Site1 storage node so there is an image there to copy. And I’ve updated the Image itself in management interface to link to the right storage group.

    Added to this, now when I try and kick off a regular image task from main server I get this error

    It’s likely something very simple I’ve overlooked…

    Any pointers?

    cheers, Kiweegie


  • Moderator

    @Kiweegie said:

    @Tom-Elliott aha - that makes more sense, was actually the “other” boxes which should have been providing creds but were not, sorted now.

    one last question, is is possible to get a login set up for the wiki as most how-tos online seem to be linked back there… I can open new thread for that if preferred.

    thanks again for the help Tom, greatly appreciated.

    regards, Kiweegie.

    You don’t need credentials to view the WiKi, only to edit it. There’s a therad somewhere around here (searching with the new software is difficult), but currently searching is disabled. You can ask for permission in there, normally.

    But for now, I suppose this thread is fine to ask in.



  • @Tom-Elliott aha - that makes more sense, was actually the “other” boxes which should have been providing creds but were not, sorted now.

    one last question, is is possible to get a login set up for the wiki as most how-tos online seem to be linked back there… I can open new thread for that if preferred.

    thanks again for the help Tom, greatly appreciated.

    regards, Kiweegie.


  • Senior Developer

    @Kiweegie The username and password that’s presented to you is so you can add the nodes to the fog server.

    The username/password there should be for connecting/communicating with that particular node.



  • Tom I’ve upgraded to trunk on all boxes - oddly on 2 of them it has added in fog username and password at this part of the install.

        What mysql connection type would you like? (MYSQLI_ASYNC)
             MYSQLI_STORE_RESULT is normal
             MYSQLI_ASYNC is what is Defaulted and recommended
              Any value not equal to MYSQLI_ASYNC and not blank will use store result
      * Setting password for FOG User...OK
      * New password set for:
          username: fog
          password: ********
    

    I’m presuming this is not right as the other ones just run the first part, ask for the fogstorage password then continue on. I’ve tried wiping /opt folder and starting a fresh install but both still doing this. Ones an Ubuntu14.04 box the other is Centos 6.4.

    I could reinstall the OS and start again but I’d really prefer not to if possible.

    Once I’m done and have working is it worth your/others while for me to post detailed steps back here for visibility?

    ta.


  • Senior Developer

    It’s actually one of the things I love most about the new forums. Pretty easy to see a new post/thread/chat and respond in a relatively timely manner.



  • Wow. That was… fast.

    Understood Tom, will try that now.

    cheers!


Log in to reply
 

352
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.