Unable to Successfully PXE Boot to a FOG Menu on a Microsoft Surface Pro 3

  • FOG Version 1.2.0 on CentOS 6.6

    PXE Boot works as expected for BIOS based machines.

    I’m trying to just PXE boot to the FOG Menu on my Surface Pro 3 (Secure Boot is Disabled). I have seen quite a few posts about getting it to work and have tried what is suggested, but so far no joy.

    I have my DHCP on a Windows Server 2003 Domain Controller with Option 66 and 67 set (when I test the Surface, I change 67 to one of the .efi filenames - normally it is on undionly.kpxe).

    This is what I see when attempting to PXE boot:

    Checking Media Presence…
    Media Present…
    Start PXE over IPv4.

    Downloading NBP file…

    Succeed to download NBP file.
    iPXE 1.0.0+ (5ecd) – Open Source Network Boot Firmware – http://ipxe.org
    Configuring (net0 xx:xx:xx:xx:xx:xx)… ok
    tftp://<FOG IP>/default,ipxe
    http://<FOG IP>/fog/service/ipxe/boot.php… ok
    http://<FOG IP>/fog/service/ipxe/bg.png… ok
    Could not use picture: Exec format error (http://ipxe.org/2e008081)
    Could not boot: Exec format error (http://ipxe.org/2e008081)
    Could not boot: Exec format error (http://ipxe.org/2e008081)
    Failed to get IP, Booting back to bios

    (<FOG IP> is my FOG Server IP address, so I really don’t understand the last line)…

    Then it attempts PXE over IPv6 (supposed to fail) - then goes on into the Windows boot.

    Thank you!!!

  • @Wayne - I just tested out using snp.efi and that solution seems to have worked! I am uploading an image of our surface pro 3 as I write this.

  • @crosser The guy below in this thread reports success with smp.efi but then he said that stopped working…

    Seeing that you’ve tried ipxe.efi, perhaps give smp.efi a shot?

  • I too, have a related issue with our Surface Pro 3. I was able to successfully register the host, but when I actually wanted to upload an image of my surface pro 3, it failed on the following part:

    Mounting File System…failed.

    I ran the “touch” commands on my storage location and checked my /etc/exports file. Everything is in order. Also, I tried uploading an image from a regular HP Desktop (Windows 7) and was successful (using the undionly.kpxe).

    But when I switched it over to ipxe.efi for my surface pro 3, again, I can register and attach an upload task to it, but it’ll eventually fail again on the “Mounting File System” part…

    Any advice would be appreciated.

    EDIT: I’m running FOG SVN 3537

  • @micadam

    What how-to?

    Could you please write up something detailed and step by step, and assume a total noob is reading it? Something like this would make a great WiKi article.

  • New update, It stopped working, but I found the new way to make it work, I’ll update my HOW-TO soon.
    now, i’m using ipxe.efi.

  • On my setup with surface pro 3, I must specify another boot file on ten DHCP.
    I set: snp.efi

    And when I’m imaging, I usually only use partition 4, which is the windows partition on surface pro 3.

    I did a rough tutorial here with what I did:

  • Moderator

    @JtM said:

    Thank you for your quick response!

    I am a pretty new Linux and FOG user. What do you mean by ‘Trunk’? What source should I use to obtain the suggested Upgrade?


    EDIT : Prefer > https://wiki.fogproject.org/wiki/index.php/SVN

  • Thank you for your quick response!

    I am a pretty new Linux and FOG user. What do you mean by ‘Trunk’? What source should I use to obtain the suggested Upgrade?

  • Senior Developer

    Please upgrade fog to Trunk so you can actually see the menu. EFI does not like console fb and this has been fixed for quite some time. Also the iPXE handling methods also will naturally drop to a proper menu for systems (legacy and uefi) that have problems in general with console_fb.

Log in to reply