Deployment/FTP not working


  • Senior Developer

    Hey all,

    Just trying to inform you.

    I made a change to the installation that tries to set the fog username/password for you so it can be displayed during a node/system install.

    This change is enforcing a password reset for the Linux System’s FOG User. You will probably have a few issues initially getting anything ftp related to work.

    There are two ways you can fix this:

    Way 1 (probably more work but ultimately allows you to edit your own info) :
    The fix is to open up the /opt/fog/.fogsettings file and search for the storageftppass= line.

    This line is what the new FOG User password is set too. You can change it to whatever you like. Edit this file to make the password set to whatever you want it to be so future updates don’t break it.

    Save the file and on terminal enter sudo passwd fog

    Set the password to whatever you want it to be, mostly likely what is currently stored in the storage node anyway.

    Way 2 (Probably the simplest way)
    Copy the value in the /opt/fog/.fogsettings storageftppass= line and edit your storage node to use this new password. You will also likely need to edit the FOG Configuration->FOG Settings->TFTP Server->TFTP_FTP_PASSWORD with this new password as well.

    This should help you out.


  • Moderator


Log in to reply
 

385
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.