Fog 3396 FOGImageReplicator startup failed



  • I just updated from .32 to 3389 (I think that was the version, it’s also the port number for RDP, so I may be wrong)
    I use Debian 7.8 currently. After the update the FOGImageReplicator wouldn’t start on the DefaultMember or any storage nodes. Updated to 3396 after via git on all machines and re-ran ./installfog.sh. The Defaultmember now runs FOGImageReplicator but none of the storage nodes do. The helpful error message after running “service FOGImageReplicator start” is “failed!”. I can’t find why in the logs I’ve been looking in. Any hints?



  • I just decided to make the one that is working the master. The other two will still accept images and deploy them.

    I’m not good at debugging init scripts. It seems that the init script claims a PID, but the PID never shows up in top on the ones that aren’t working. This is also evidenced when I do a stop of the FOGImageReplicator script, I get an error that says can’t kill PID 3325 (or whatever the PID is). If I do a stop again it says OK. So something isn’t firing right, but it’s not that big of a deal to me since one is working.

    Thanks for all your work on this. Much improved over the last 6th months.



  • OK, thanks.

    Yes they have worked in the past. And I can still pull images from them, it’s just that replication isn’t working.


  • Moderator

    If you’re doing a bone-cold fresh installation (OS and all), it’s perfectly fine to go straight to the latest revision.

    I’ll assume the secondary storage nodes have worked in the past? No network changes?



  • Thanks for your help.

    Wayne: Would you recommend I blow away the storage nodes and start with 1.2.0 then go to 3396? I’m assuming you mean the storage node passwords, not the mysql passwords. I didn’t change any passwords, but maybe the huge jumps caused issues with the password

    Junkhacker: They are all on 3396, all debian 7.8. The DefaultMember and primary Storage Node are VMs. my replicated storage nodes are physical machines. None of the storage nodes start the script successfully only the DefaultMember.


  • Developer

    are your fog server and storage nodes running the same versions of fog?


  • Moderator

    .32 to 3389 is a huge jump…

    I’d strongly suggest going from .32 to 1.2.0 first, and then to 3389 if you’re willing.

    Double Check your credentials for your storage nodes.


Log in to reply
 

436
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.