SOLVED Configuration Save - r3333

  • Built a new FOG server today on Fedora 21 server.

    I had a exported db from r3333, and so I installed r3333 onto the new build.

    I tried to import using that previously exported db, and it does not work. None of the settings are restored, nor any of the hosts/groups/images either.

    I don’t know if it’s the export or the import that’s broken but one of them doesn’t work…

  • Tom patched this up just now. Something about background processes… I have no idea.

    It’s fixed in the latest revision.

  • Tom suggested trying a manual import, so I set about doing that. This worked - which suggests something doesn’t work with “Configuration Save - Export”, or I just have something jacked up somewhere… idk…

    But, here’s what I did:

    I installed Samba and shared my [B]/images[/B] directory and copied my .sql backup to there. (you could use TFTP or FTP to get the file there, I just wanted Samba anyways.)

    Ran this:
    [CODE]mysql fog < /images/fog_backup.sql[/CODE]

    Now all is normal. Yay!

    Just gotta copy over my images now.

  • Fedora 21 server - fully updated with the standard updates. SVN is installed, and FOG is installed, thats it.

    Old FOG server is Fedora 21 Workstation. It’s updated as of two weeks ago.

    Apache errors attached.


  • This post is deleted!

  • The “Host Export/Import” does work…

    But I’d like to just export/import everything… gah.

    I might just steal the entire database from the old build and stick it on the new one.

  • I rolled the old FOG server up to r3389 and did a Configuration Save export again, and bumped up the new server to r3389 and did a Configuration Save import and this did not work either.

  • The file I tried to import is 1.06MB so I assume the export part works.