[SOLVED] Like a good puzzle? sign in problems with fog



  • Dear All,

    I booted my physical fog server today, and am having some weird problems.

    Every time I go to perform an operation I have to sign in again. I’ve checked the date, and it’s fine, used different browsers, but the problem persists.I made a quick video of it here

    [media=youtube]FyWMCcmYY-k[/media]

    What’s strange is it only happens when I connect to it across the internet, if it’s on a local Lan it’s fine. I’ve added the server as a trusted site.

    Unfortunatley I will have to re image my room when I’m away, so the internet access is a big deal to me.

    Even more puzzelling is it used to work!

    Can anyone help me, as I’m in deep “do do” if it doesnt start working.

    Thanks

    Julian



  • Brilliant Tom.

    Your quite right. The internet link I use to connect to the Fog server, on a seperate link, has just been upgraded to fibre. I checked the NAT pool, and there were several IPs that were being used as the NAT address. so effectivly I could have one of 5 IP’s hitting the Fog server. So your right, the fog server was getting multipe requests from different IP’s with the same session. I changed the NAT to just one IP, and the problem has gone away. Well untill tomorrow when the Fog server’s 2 internet links also get upgraded, but that shouldn’t be a problem now.

    Thanks you all so much for your help, it’s really apprechiated, and I am grateful. It also reminded me to do a backup, which takes a few days, but I need to do it.

    Now this is resolved, how do I make it a “Solved” problem and easily found to the next poor chap who changes his network?

    Thanks once again, and have a good day to all those that helped.

    Yours

    Julian


  • Moderator

    I highly recommend Tom’s advice.

    Be very, very sure to put your configuration save in a safe spot. Maybe even back it up in two different locations.


  • Testers

    I forgot about the mountcheck file create it with this command.
    [FONT=Calibri]sudo touch /images/.mntcheck[/FONT]


  • Senior Developer

    It’s possible exporting is just going to replicate the issue but I don’t think it’s an issue with fog at all…directly. You state it’s only occurring when you connect to fog from an internet source. This leads me to believe either you’re accessing fog using private browsing of some sort where the session identifier is constantly changing every so many seconds. I don’t think normal private browsing would be the cause of this directly but maybe a constantly changing IP address request source such as a proxy system redetecting a vpn connection? I don’t know the problem but it certainly sounds like it is environmental more than fog directly. What you could try just as a test is export the database and delete the fog database itself from cli or phpmyadmin. Go back to fog and have it start fresh. You have a backup so for now you should be safe. G through the same steps you have to get the problem. Does all happen the same? Do things seem to be working? Granted at that point you have no hosts or images yet. Get the individual tables you need and reimport them. Does the system still work?


  • Testers

    Reset permissions and ownership with the following commands.
    sudo chown -R fog.root /images
    sudo chmod 777 -R /images



  • Hi All

    Quick question, I’m going to cp the /images directory to a USB disk, then copy it back over after reinstalling.

    Is there anything else I need to do?

    Thanks

    Julian



  • Hi Tom,

    If I export the configuration database, am I not going to export the problem and then reimport it?

    Depending on your answer, the next step will be either a total reinstall and restoration of the images from backup, or the same, but import the configuration afterwards

    What would you suggest?

    Thanks

    Julian


  • Senior Developer

    if you export the database (FOG Configuration -> Configuration Save), you now have a copy of FOG on your system. The actual physical images need to be backed up separately.

    Re-installing/upgrading FOG will not delete any of your images or database settings. There are changes to the database, but the data is typically moved around rather than “lost”.



  • Hi Tom,

    Thanks for the suggestion, I reinstalled the fog 1.20 server, I even found the original CD, rebooted it, but unfortunatley it’s still asking for logins.

    The install has the images on the same disk as Unbuntu & Fog. I was beginning to think about a totally fresh install, but I’m paranoid of losing the images.

    When I did the install it read the settings and said “install with these values”. If I said no, and reinstalled overwriting the database etc, at the end I could manually add the images back. It’s a lot of work, there are over 110 images to add! I don’t want to do this, but as a last resort if I have to I will.

    Is there a the log file that might help out, or is there anything else you could suggest?

    Thanks

    Julian


  • Senior Developer

    No it will not. It will not delete anything out of the database.



  • Thanks Wayne, but won’t that destroy my images, not the actual files, but the image objects pointing to the files? I’m a little dubious about it.

    What are your thoughts?

    Thanks

    Julian


  • Moderator

    Tom probably has something in mind,

    but in the mean time, you could also try to re-run the installer for 1.2.0.



  • Hi. Tom, it’s running on unbutu 14.04.01 LTS.

    Any suggestions?

    Thanks

    Julian


  • Senior Developer

    I’m just guessing but need verification. You’re using Ubuntu or Debian as the OS for serving fog on?



  • Thanks for you suggestion Wayne. The version is 1.20. I’ve changed the fog_inactivity_timeout to it’s maximum value of 23, and changed the fog_regenerate_timeout to it’s maximum of 23. I moved the slider all the way to the right. I also tested it with fog_always_logged_in set. I rebooted the fog server to make sure.
    Unfortunately it still acts as before. What I can’t understand is that it used to work fine.
    All that’s changed is I’ve added quite a few images. The disk is 76% full. I use a local disk not nfs.
    Aside, as it connects to the web, I turn it off when it’s not needed.

    Do you have any other suggestions I could try?

    Thanks

    Julian


  • Moderator

    Sounds like your inactivity timeout is set really short.

    I know in the latest developmental versions, it’s an editable value through the web interface. But, you didn’t say what version you’re using…

    If you can’t change it via the web interface, there’s a setting in the DB you can change for it , maybe (again, no idea what version you’re using).


Log in to reply
 

1.3k
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.