WDS and FOG



  • Nice power point.

    Why not zip that up and stick it in a thread?? Wouldn’t want it to disappear.


  • Moderator

    I can’t contain myself anymore. Working on this instead of other things I am supposed to.

    [URL=‘https://dl.dropboxusercontent.com/u/7798420/Creating a legacy %2B EFI PXE boot server using pxelinux.pptx’]This is relevant[/URL]



  • [quote=“need2, post: 46467, member: 21891”]Did that let it coexist with WDS, or just replace WDS without taking down the WDS server?

    EDIT: Upon actually using my seeing organs and reading the page, it looks like it would just give you a menu that would allow you to select what, if any, network boot environment you want to use. However it doesn’t look like it has any way of handling if there is a WDS job or FOG job, and automatically going to said system.

    AHHA! But that WOULD potentially allow, with further modification, a Windows Server environment to properly get UEFI devices and BIOS devices to boot off of FOG![/quote]

    BOOM!

    Now then, let’s take this to the next level.

    I’m going to be all over this tomorrow.


  • Moderator

    Did that let it coexist with WDS, or just replace WDS without taking down the WDS server?

    EDIT: Upon actually using my seeing organs and reading the page, it looks like it would just give you a menu that would allow you to select what, if any, network boot environment you want to use. However it doesn’t look like it has any way of handling if there is a WDS job or FOG job, and automatically going to said system.

    AHHA! But that WOULD potentially allow, with further modification, a Windows Server environment to properly get UEFI devices and BIOS devices to boot off of FOG!



  • Hey here is what I changed and had to do to my network to get it to work

    changed from the web page directions
    APPEND (FOGSERVERIP)::undionly.kpxe

    turned off/remove the DHCP on FOG
    sudo apt-get remove dhcp3-server or dhcp-server

    Added options to Windows DHCP server
    Server options added
    066 Boot server Host name- (FOGSERVERIP)
    067 Bootfile Name- undionly.kpxe

    Hope this helps anyone trying to do this in the future and my thanks to all who looked and to those who responded to my plea for help… My thanks.


  • Senior Developer

    Also in the SVN versions of fog I’ve re-added the config directory and the default file all you would need to do is update that file


  • Developer

    Another option is to use advanced menu options to point to your WDS server and add it as a boot menu item.

    That is effectively what you are doing when you use pxelinux.0 with the default file.

    OR

    If you can figure out how to use DNSMASQ, it has a boot menu as well, you could use it to boot to WDS or FOG. This might be a bit more difficult because AFAIK you can only have one dhcp-boot option.

    But in case you decide to use DNSMASQ the line you will need is:

    [code]dhcp-boot=boot%5Cx64%5Cpxeboot.com,x.x.x.x[/code]
    Where x.x.x.x is the ip address of your WDS server.

    The %5 is a backslash, you have to encode the path using a backslash will cause issues.

    There is a chance you will need to edit other files in order to accomplish this, but according to the man pages, they added in the ability to serve multiple TFTP servers on a single ip address or host name, you may want to look into it.



  • I tried a similar article a while back… I guess that article was crap because this one looks a lot better.

    Try replacing pxelinux.0 with undionly.kpxe

    that file is located in /tftpboot on your FOG server. However, I believe after that’s loaded, it chains to default.ipxe so you may/may not need that too.

    You might or might not be able to just skip undionly.kpxe and just use default.ipxe I don’t know.

    If you get it working, please do tell how.


Log in to reply
 

594
Online

6.3k
Users

13.7k
Topics

129.2k
Posts