Dell Venue Pro 8 PXE boot issues



  • Hello,

    I am running FOG 1.2.0. I am able to successfully deploy to several different types of machine and I have the DHCP options set in my windows DHCP server to point to the undionly.kpxe file in the tftp server.

    When I tried to PXE boot my dell venue pro 8 (32 bit UEFI), it “succeeded to download NBP”, then continues on to the next boot device.

    On the server side, in syslog I see some “client does not accept options” messages.

    I tried the suggestions that I have seen around the internet of moving the efi files into /tftpboot/ and restarting the service. I had no luck with any of them when I configured the DHCP server to point at them. Is there anything I can do?

    Thanks for any help you can provide,

    Rob



  • More than likely you need to make a custom 32-bit bootfile for these to work. At the very least it will save you from having mess with bzImage/init.xz.

    [SIZE=13px]Go here:[/SIZE]

    [URL=‘https://rom-o-matic.eu/’][SIZE=13px]https://rom-o-matic.eu[/SIZE][/URL]

    [SIZE=13px]Advanced - EFI PXE Bootstrap 32-bit[/SIZE]

    [SIZE=13px]Check these boxes:[/SIZE]

    [URL=‘http://www.ipxe.org/buildcfg/PARAM_CMD’][SIZE=13px][FONT=Arial][COLOR=#000000]PARAM_CMD[/COLOR][/FONT][/SIZE][/URL][FONT=Arial][SIZE=13px][COLOR=#000000], Form parameter commands [/COLOR][/SIZE][/FONT]
    [URL=‘http://www.ipxe.org/buildcfg/CONSOLE_CMD’][SIZE=13px][FONT=Arial][COLOR=#000000]CONSOLE_CMD[/COLOR][/FONT][/SIZE][/URL][FONT=Arial][SIZE=13px][COLOR=#000000], Console command [/COLOR][/SIZE][/FONT]
    [URL=‘http://www.ipxe.org/buildcfg/CPUID_SETTINGS’][SIZE=13px][FONT=Arial][COLOR=#000000]CPUID_SETTINGS[/COLOR][/FONT][/SIZE][/URL][FONT=Arial][SIZE=13px][COLOR=#000000], CPUID settings[/COLOR][/SIZE][/FONT]

    [SIZE=13px]And paste this script in the script box (Replace x.x.x.x with your FOG server’s IP or hostname):[/SIZE]

    [SIZE=13px]#!ipxe[/SIZE]

    [SIZE=13px]dhcp[/SIZE]
    [SIZE=13px]cpuid --ext 29 && set arch i386 ||[/SIZE]
    [SIZE=13px]params[/SIZE]
    [SIZE=13px]param mac0 ${net0/mac}[/SIZE]
    [SIZE=13px]param arch ${arch}[/SIZE]
    [SIZE=13px]param product ${product}[/SIZE]
    [SIZE=13px]param manufacturer ${product}[/SIZE]
    [SIZE=13px]param ipxever ${version}[/SIZE]
    [SIZE=13px]param filename ${filename}[/SIZE]
    [SIZE=13px]isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme[/SIZE]
    [SIZE=13px]isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme[/SIZE]
    [SIZE=13px]:bootme[/SIZE]
    [SIZE=13px]chain [/SIZE][URL=‘http://x.x.x.x/fog/service/ipxe/boot.php##params’][SIZE=13px]http://x.x.x.x/fog/service/ipxe/boot.php##params[/SIZE][/URL]

    [SIZE=13px]Click Proceed, and voila! Copy the new EFI bootfile to your /tftpboot folder and give it a whirl![/SIZE]



  • As for Partclone, it could never find the hard disk to start the image upload task.

    Same thing for inventory…FOG was unable to fill in the hard disk field on all of them…



  • [quote=“rball01, post: 46645, member: 29220”]Were you able to successfully register the host, or did you use manual registration?[/quote]

    Here’s how I pulled inventory on 517 Asus T100TA’s…

    I did 10 at a time. I had 10 USB–>LAN adapters, all labeled 01-10. I had a list of the MAC addresses for each adapter.

    I then added each tablet to my FOG hosts with my desired hostnames and their corresponding MAC addresses.

    Then I had to set their Host Primary Disk to /dev/mmcblk0. Then I had to create a new group with all 10 of them in it. Then I could finally start the inventory task.

    Mind you, I also had to disable Secure Boot on every one first, then let them start inventory. I always got some kernel panics too, and had to reboot them until they finally started the task. Sometimes any device could take four reboots before the kernel stopped panicking lol :(

    Pain in my ass is an understatement lol…



  • From what we can tell, the problem we are having now is that the USB NIC (SABRENT NT-USB2.0) is not being loaded correctly when FOG is starting. We tried downloading the newest linux driver for it and dropping in to a custom kernel build, but it didn’t seem to help.

    Similar to this thread, but with a different model:
    [url]http://fogproject.org/forum/threads/realtek-8153-usb-network-adapter.10302/[/url]

    We will try Tom’s kernels and see if they help at all, but if anyone has any suggestions on this USB NIC, they are appreciated.

    Thanks - Rob

    The good news is that when we try to do the host inventory, even though we can’t actually get it registered, it does tell us the disk is being recognized



  • [quote=“d4rk3, post: 46641, member: 23583”]For the record, the ONLY way I was ever able to hit the Partclone screen/pull inventory was by setting the Host Primary Disk to:

    /dev/mmcblk0

    I tried /dev/mmcblk, mmcblk, mmcblk0, etc and that’s the only one that’s ever worked for me.

    Hopefully this can help save you some time/headaches :)[/quote]

    Were you able to successfully register the host, or did you use manual registration?



  • For the record, the ONLY way I was ever able to hit the Partclone screen/pull inventory was by setting the Host Primary Disk to:

    /dev/mmcblk0

    I tried /dev/mmcblk, mmcblk, mmcblk0, etc and that’s the only one that’s ever worked for me.

    Hopefully this can help save you some time/headaches :)



  • This should help…

    [url="/_imported_xf_attachments/1/1949_Host Primary Disk.png?:"]Host Primary Disk.png[/url]



  • It looks like the issue is now very similar to this one:

    [url]http://fogproject.org/forum/threads/uploading-an-image-from-partition-layout-dev-mmcblk0.11783/[/url]

    I don’t want to cross post on both, so I will ask, how do I set the “Host Primary Disk” to mmcblk? That’s probably the next step to try in getting this thing going.

    Edit I was thinking about this too hard, was just told its a menu option. We will give it a shot.

    In the meantime, I’ll try the kernels that Tom had linked in that thread to see if there is any difference. We have tried to build a custom kernel with all the mmc options checked, but did not seem to change anything.



  • Hi Wayne,

    Most of the steps we’ve taken are on the first page of the thread, in summary:

    Used the latest Trunk/SVN - fixed the loading issue with bg.png
    Pointed Windows Server DHCP options at ipxe.efi - got us to the FOG menu
    Replaced the original versions of of init.xz and bzimage with the 32 bit versions (deleted and renamed) - stopped the menu from looping back to itself and appeared to actually load FOG

    At this point the roadblock is that we get to host registration (as mentioned above), the errors are thrown, and FOG reports no Hard disk found

    This may or may not be related to the issue that if we choose Host Information - the USB port seems to have stopped functioning and we lose keyboard/network access

    We are downloading the latest trunk now (looks like it was just updated) to see if that affects anything


  • Moderator

    So where is the road-block now?

    Can you explain everything you’ve done to get this far? Just for future reference to others (and me).



  • IME the loss of USB devices is caused by turning off Legacy USB in the BIOS.



  • We deleted init.xz and bzimage and renamed init_32.xz and bzimage_32 to them in /var/www/fog/service/ipxe

    This got us a little further

    We got to the Host Information menu, but then we lose all USB functionality, including the ethernet dongle and keyboard, so we can’t get any further on that screen either.
    [ATTACH]1929[/ATTACH]

    When we select Host Registration we get some errors and it appears to fail to find a storage device, errors pictures are attached:
    [ATTACH]1928[/ATTACH]

    Thanks for all your assistance

    [url="/_imported_xf_attachments/1/1928_20150427_131348.jpg?:"]20150427_131348.jpg[/url][url="/_imported_xf_attachments/1/1929_20150427_131404.jpg?:"]20150427_131404.jpg[/url]



  • If it helps we were able to boot into Ubuntu Linux 64 bit Desktop on the Venue Pro 8 by following this article

    [url]http://www.jfwhome.com/2014/03/07/perfect-ubuntu-or-other-linux-on-the-asus-transformer-book-t100/[/url]

    and changing the resolution from [SIZE=15px][FONT=Monaco][COLOR=#656565]1368x768e to 800x1280e[/COLOR][/FONT][/SIZE]



  • Good morning, here is the video capture of the FOG menu behavior. Sorry it is sideways, not sure what the phone was doing. Wasn’t able to upload the MOV file, so you will have to download and change extension to MOV.

    Thanks,
    Rob

    [url="/_imported_xf_attachments/1/1926_IMG_0595.txt?:"]IMG_0595.txt[/url]



  • Thanks, I will get a video capture first thing Monday morning and upload. I really appreciate the help, and I love FOG btw, killer product


  • Senior Developer

    rball01,

    Please, if you can post a video feel free. It really is more helpful to know the full scope instead of just throwing out ideas.



  • Thanks Wayne, I think the issue is with bzimage and/or init.xz since I am seeing the FOG menu, but to be honest I don’t know what they are or if they are 32 bit

    I think my ipxe issues may have been solved in the current trunk

    I am hoping Tom will have a suggestion on where i can look for clues, I can post a video if it helps

    Thanks again for your suggestions and help


  • Moderator

    This might be a tough road to go down, but I think you ought to try to build your own files for 32 bit. You will probably need help from both the iPXE people, and the FOG Project’s own Tom and Uncle Frank.

    There are instructions in the WiKi and in the Forum for building the files, but I’m not sure about x86. I’ve only built x64 and I struggled a bit with it. We have updated the WiKi and forum to reflect what had to be done to get it to work on Fedora/Ubuntu. I’ve also heard things about requiring a 32 bit system to compile 32 bit software in Linux… maybe I’m wrong… I have no idea.

    Here are some links that I’ve found that may help:

    [url]http://fogproject.org/wiki/index.php/Building_undionly.kpxe[/url]
    [url]http://fogproject.org/forum/threads/build-ipxe-from-source.10152/#post-24197[/url]
    [url]http://fogproject.org/forum/threads/dell-7010-lenovo-l530-with-uefi-enabled-wont-network-boot.12727/#post-45357[/url]



  • We see the menu, but the different options are just looping back to the menu as described above


Log in to reply
 

371
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.