Encrypted ADPass not auto-populating ?



  • Maybe it’s just me, but normally when I click on the “Join Domain after image task”, the credentials and encrypted password get auto-populated…

    For me, only the username and domain are populating. Not the password string.

    r3277 Fedora 21



  • [QUOTE]This isn’t highly documented as it’s relatively new. In an attempt to allow legacy and new client’s to operate with a single version of FOG, I created a Field for the New Client (FOG_AD_DEFAULT_PASSWORD) and the legacy client (FOG_AD_DEFAULT_PASSWORD_LEGACY).[/QUOTE]

    Perfect explanation - I ran into this issue today, wasn’t aware of the new legacy field. All is working fine now.



  • This was the case.

    But, I did not have the “FOG Configuration->FOG Settings->FOG Service->FOG_NEW_CLIENT” checkbox checked.
    However, the newer revision of FOG still cleared out my old AD password for the legacy client, and had put something inside the new password field.


  • Senior Developer

    All,

    This isn’t highly documented as it’s relatively new. In an attempt to allow legacy and new client’s to operate with a single version of FOG, I created a Field for the New Client (FOG_AD_DEFAULT_PASSWORD) and the legacy client (FOG_AD_DEFAULT_PASSWORD_LEGACY).

    In FOG Configuration->FOG Settings->Active Directory Defaults you’ll see these fields. THE FOG_AD_DEFAULT_PASSWORD field will self AES encrypt the password you put in. It randomly creates an AES Key and stores the encrypted form of the password in this field. The FOG_AD_DEFAULT_PASSWORD_LEGACY field will not do any encryption. Under FOG Configuration->FOG Settings->FOG Service->FOG_NEW_CLIENT is a checkbox. This setting is what tells FOG which of the PASSWORD fields it needs to use. It’s very simplistic. If this is checked, it will setup up AD Passwords From the AES Encrypted field. Otherwise, it will use the legacy field. Hopefully this helps.


  • Senior Developer

    Are you using new or legacy client?



  • I’ve confirmed that when I clear out all the fields and then tick the checkbox, it just adds in the username and domain name.


  • Senior Developer

    It will only auto populate if all the fields are blank.


Log in to reply
 

467
Online

40.3k
Users

11.3k
Topics

108.2k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.