PXE reboot



  • I have installed FOG and successfully managed to image some machines and deploy those images to other machines and that part works great!

    Once the image is either taken or deployed the restart causes the machine to PXE boot as expected. However, after the machine boots into FOG, as there are no active tasks it should boot from the hard disk as this is the next option in the boot order that I set up in the BIOS. The problem is that the machine instead of continuing down the boot order to the hard disk, keeps trying to PXE boot until there is a failure reported and the system reaches a ‘grub rescue’ command line.

    How can I prevent PXE cycling over itself and get the machine to boot to the second boot option which is the hard disk?

    Thanks in advance for your help



  • Ok lol, sorry

    Yes, the machine I am using to image is an Ubuntu Desktop 14.04 and machine that is being imaged is an Ubuntu Server


  • Senior Developer

    All the stuff asking for the install/error logs, is just a part of my signature, they appear beneath all of my posts.


  • Senior Developer

    The operating system that’s on the systems to be imaged (receiving the image?) are ubuntu?



  • [INDENT]Linux - Ubuntu[/INDENT]



  • Apache error logs

    error.log.txt


  • Moderator

    ""



  • lol sorry, Ubuntu Server 14.04



  • I found the motherboard details if that helps: ASMB-823-00A1E


  • Moderator

    @danielc137, post: 45547, member: 29365 said:

    They are Advantech servers.

    I cant see anything written on them for more information

    What [U][B]OPERATING SYSTEM[/B][/U] are the computers running, the ones you [U]wish to [B]IMAGE[/B][/U]?

    [U][B]NOT[/B][/U] what FOG is running on!

    Which one?
    ""



  • They are Advantech servers.

    I cant see anything written on them for more information


  • Senior Developer

    What is is on the systems you’re trying to image



  • hi,

    FOG Version 1.2.0
    OS Ubuntu 14.04

    Installation Details
    …#######:. …,#,… .::##::.
    .:###### .:;####:…;#;…
    …##… …##;,;##::::.##…
    ,# …##…##:::## …::
    ## .::###,##. . ##.::#.:######::.
    …##:::###::…#. … .#…#. #…#:::.
    …:####:… …##…##::## … #
    # . …##:,;##;:::#: … ##…
    .# . .:;####;::::.##:::;#:…
    # …:;###…

    ###########################################

    FOG

    Free Computer Imaging Solution

    http://www.fogproject.org/

    Developers:

    Chuck Syperski

    Jian Zhang

    Peter Gilchrist

    Tom Elliott

    GNU GPL Version 3

    ###########################################

    Version: 1.2.0 Installer/Updater

    What version of Linux would you like to run the installation for?

          1) Redhat Based Linux (Redhat, CentOS, Mageia)
          2) Debian Based Linux (Debian, Ubuntu, Kubuntu, Edubuntu)
    

    Choice: http://www.fogproject.org/wiki/index.php?title=InstallationModes

    What type of installation would you like to do? http://fogproject.org/?q=cryptocurrency

    Would you like to donate computer resources to the FOG Project? http://www.fogproject.org/wiki
    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 192.168.90.83
    DHCP router Address: 192.168.90.254
    DHCP DNS Address: 192.168.90.10
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0
    Donate: 0

         DHCP will NOT be setup but you must setup your
         current DHCP server to use FOG for PXE services.
    
         On a Linux DHCP server you must set:
             next-server
    
         On a Windows DHCP server you must set:
             option 066 & 067
    
                   Option 066 is the IP of the FOG Server: (e.g. 192.168.90.83)
                   Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)
    

    Are you sure you wish to continue (Y/N) Y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Installing package: apache2

    • Installing package: php5

    • Installing package: php5-json

    • Installing package: php5-gd

    • Installing package: php5-cli

    • Installing package: php5-mysql

    • Installing package: php5-curl

    • Installing package: mysql-server

      We are about to install MySQL Server on
      this server, if MySQL isn’t installed already
      you will be prompted for a root password.

      Press enter to acknowledge this message.
      Reading package lists…
      Building dependency tree…
      Reading state information…
      mysql-server is already the newest version.
      0 upgraded, 0 newly installed, 0 to remove and 382 not upgraded.

    • Installing package: mysql-client

    • Installing package: tftpd-hpa

    • Installing package: tftp-hpa

    • Installing package: nfs-kernel-server

    • Installing package: vsftpd

    • Installing package: net-tools

    • Installing package: wget

    • Installing package: xinetd

    • Installing package: sysv-rc-conf

    • Installing package: tar

    • Installing package: gzip

    • Installing package: build-essential

    • Installing package: cpp

    • Installing package: gcc

    • Installing package: g++

    • Installing package: m4

    • Installing package: htmldoc

    • Installing package: lftp

    • Installing package: openssh-server

    • Installing package: php-gettext

    • Installing package: clamav-freshclam

    Confirming package installation.

    • Checking package: apache2…OK

      • Checking package: php5…OK
      • Checking package: php5-json…OK
      • Checking package: php5-gd…OK
      • Checking package: php5-cli…OK
      • Checking package: php5-mysql…OK
      • Checking package: php5-curl…OK
      • Checking package: mysql-server…OK
      • Checking package: mysql-client…OK
      • Checking package: tftpd-hpa…OK
      • Checking package: tftp-hpa…OK
      • Checking package: nfs-kernel-server…OK
      • Checking package: vsftpd…OK
      • Checking package: net-tools…OK
      • Checking package: wget…OK
      • Checking package: xinetd…OK
      • Checking package: sysv-rc-conf…OK
      • Checking package: tar…OK
      • Checking package: gzip…OK
      • Checking package: build-essential…OK
      • Checking package: cpp…OK
      • Checking package: gcc…OK
      • Checking package: g++…OK
      • Checking package: m4…OK
      • Checking package: htmldoc…OK
      • Checking package: lftp…OK
      • Checking package: openssh-server…OK
      • Checking package: php-gettext…OK
      • Checking package: clamav-freshclam…OK

      Configuring services.

      • Setting up and starting MySql…OK

      • Backing up user reports…OK

      • Did you leave the mysql password blank during install? (Y/n) N

      • Please enter your mysql password:

      • Please re-enter your mysql password:

      • Setting up and starting Apache Web Server…OK
        You still need to install/update your database schema.
        This can be done by opening a web browser and going to:

        http://192.168.90.83/fog/management
        Press http://192.168.90.83/fog/management

        Default User:
        Username: fog
        Password: password

    Script done on IDT 12:46:09 2015


  • Senior Developer

    Um,

    What OS is installed on these systems?



  • I have tried all the options available, unfortunately none boot the system to ubuntu. The Sanboot option after repeated attempts remains as above. The other options “exit” and “grub” send the machine to a grub rescue command line. I need to restart manually and change the boot order in BIOS to load Ubuntu.

    Is there a way to send it to the second boot option?


  • Moderator

    In FOG configuration (Web GUI), under iPXE boot menu, play around with the “Exit to Hard Drive Type”.
    Default is Sanboot.



  • hey, thank for the response.

    I changes the settings and the system no longer cycles round in PXE. However it still doesn’t load Ubuntu. After it prints…
    /default.ipxe. . . ok
    /fog/service/ipxe/boot.php. . . ok
    ’Booting from SAN device 0X88’

    and then nothing happens. I cant even restart with ctrl+alt+del


  • Moderator

    Hi,

    You can use it : http://fogproject.org/forum/threads/ubuntu-14-xx-how-not-to-have-fog-start-automatically-when-server-starts.12741/#post-45418

    If there is no task iPXE return to boot on hard disk.

    Regards,
    Ch3i.


Log in to reply
 

351
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.