Ubuntu 14.xx - How not to have Fog start automatically when server starts



  • I know this is probably the opposite of what everyone else asks for and wants… but here is the scenario.

    Before:
    I was using Fog V0.3x on Ubuntu 12.xx which was on a dual-boot box. This box was only booted into Ubuntu when we wanted to use Fog. Otherwise it was turned off or booted into the other, dual-boot, O/S. In effect then, Fog was only running when I was actively, explicitly, using Fog.

    Now:
    I’m trying to migrate to Fog V1.2.0 on Ubuntu 14.xx. This box is not dual-boot, and we use it for other things besides Fog, so it is always booted in Ubuntu and “on”. The problem is, when this box is powered on, all the computer lab computers see it on the network and then they will hook to the PXE menu when they are starting up. I don’t want ordinary users to get to that menu etc. So, is there a way I can explicitly shutdown Fog and/or tell Fog not to automatically startup when that Ubuntu box boots? I only want Fog to run when I am explicitly using Fog…and other times, I don’t want it running.

    Thanks



  • On second thought, I will use the NO MENU option since that seems to also fix the issue that none of the EXIT TO HARD DISK TYPE values work for me…but NO MENU boots just fine.



  • Thanks. I will use the “Hidden Menu” option.

    In the past, we just resolved this through user training. When we weren’t running FOG (99.9% of the time), users just knew to hit ESC during the client BIOS search for PXE…and then they’d boot into some Pacific Northwest USA O/S. Even if they didn’t hit ESC, then after about 30 seconds it would give-up and go to the local HDD to boot.


  • Moderator

    [quote=“Tom Elliott, post: 45432, member: 7271”]It may be longer, but only minor. And you don’t have to disable dhcp settings, and you can still tell systems to image as needed.[/quote]

    Hi,

    I know, but in my case PXE is very long (10 sec to get a DHCP address), I think I have a problem in my inter-vlan configuration :p

    Regards,
    Ch3i.


  • Senior Developer

    It may be longer, but only minor. And you don’t have to disable dhcp settings, and you can still tell systems to image as needed.


  • Moderator

    Hi,

    With the “No Menu” option computers boot in PXE and after iPXE boot to hard drive : it’s longer than no PXE.

    Regards,
    Ch3i.


  • Moderator

    [quote=“Tom Elliott, post: 45412, member: 7271”]You can also use no menu or hidden menu on the fog GUI. No menu means it will not display a menu and only have other systems boot to fog if there’s a task to be performed. Hidden menu will allow you to press the key combination followed by entering the fog GUI user and password to see the menu.[/quote]

    [IMG]http://s12.postimg.org/o48kji7rx/Disable_Boot_Menu.png[/IMG]


  • Senior Developer

    You can also use no menu or hidden menu on the fog GUI. No menu means it will not display a menu and only have other systems boot to fog if there’s a task to be performed. Hidden menu will allow you to press the key combination followed by entering the fog GUI user and password to see the menu.


  • Moderator

    Hi,

    You can disable PXE settings in your DHCP.

    Regards,
    Ch3i.


  • Developer

    All your clients are setup to request booting via PXE (or FOG would not work). If you shut down FOG you will run into waiting and timeout issues. If you are lucky the clients will then boot from local HD but I don’t like this very much.

    This is kind of connected to your other post about clients not booting from the local drive after timeout. If you get this working you can just tick the “No Menu” option there and none of your users will see the menu again. Still, scheduling a task will make the clients run that task… everything’s fine.


Log in to reply
 

440
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.