Odd pending host issues



  • I’m having some really weird issues with the latest SVN (3225). Sometimes when a host that has been imaged reboots it will want to show up in the pending hosts section of FOG, but when I look at the pending hosts section there is nothing there. So I look at the database and notice that the machine and MAC address is a hostID of 0. In order to correct this I change the hostID to the next sequential number that FOG hasn’t used yet. That allows the host to show up in the pending hosts section so I can approve it. This shouldn’t be happening however. Every host is manually entered before it’s imaged so there is no reason for it to show up in the pending hosts section. This happens on random machines. I also have host registration turned off so it shouldn’t add hosts unless they are done manually. I haven’t found any apache error codes that could reflect why this is happening. They are hard enough to find since this issue is random.


  • Moderator

    @Junkhacker Didn’t even notice that.


  • Developer

    @Wayne-Workman said in Odd pending host issues:

    @x23piracy Yes, update again. Patches are pushed many, many times a day. The senior developer has already said in this thread that he thinks he’s fixed the issue. So to get the patch, you must update.

    actually, Tom’s comment and the original problem listed in the thread are probably unrelated since x23piracy is resurrecting a year old thread…


  • Moderator

    @x23piracy Yes, update again. Patches are pushed many, many times a day. The senior developer has already said in this thread that he thinks he’s fixed the issue. So to get the patch, you must update.



  • @Wayne-Workman said in Odd pending host issues:

    Upgrade to Trunk

    Do you mean this? https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk
    I cannot find any occurance of pending.

    What do you mean with Update? Update trunk again?

    Regards X23


  • Moderator

    @x23piracy Update. Instructions on that can be found in the “Upgrade to Trunk” wiki article. In fogproject wiki, not sourceforge wiki.



  • Hi,

    i have exactly the same issue.

    alt text
    then after the link on here:

    alt text
    empty…

    Maybe it has started while i was testing sysprepping with a virtual box vm where i often captured and redeployed with same macs.
    For some reason i resetted encryption data for this hosts via mysql in the shell.

    Last night i installed fog service on my productive machine and in the webif today i could see that there is a pending host but when i click on it i see an empty list.

    How can i solve this?

    Regards X23


  • Senior Developer

    I think I’ve narrowed down exactly what’s happening.

    It’s not “random” though it certainly feels like it is. I did fix the random deletion of the individual host but I wasn’t aware previous hosts added were having the same problem, until I looked much deeper into it last night. I don’t know what it was, but I did get to make a lot more refined and from what I’ve been able to test (after verifying the problem) I’ve not been able to replicate it any more. 3230 should hopefully make this a non-issue anymore. Hopefully.



  • Now this seems to happen to almost every new host that is added. It seems to never get a proper hostID in the data base so I’m constantly having to go into the database and give it a proper hostID.



  • These are the latest errors in apache that I have been getting. I’m not sure if it relates to this issue at all however.

    [SIZE=13px][COLOR=#555555][Thu Apr 09 07:21:43.517543 2015] [core:notice] [pid 31337] AH00051: child pid 23791 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Thu Apr 09 07:23:49.614748 2015] [:error] [pid 24012] [client 172.26.9.29:49197] PHP Warning: current() expects parameter 1 to be array, string given in /var/www/fog/lib/fog/Image.class.php on line 212
    [Thu Apr 09 07:23:49.614826 2015] [:error] [pid 24012] [client 172.26.9.29:49197] PHP Fatal error: Call to a member function getOptimalStorageNode() on a non-object in /var/www/fog/lib/fog/Host.class.php on line 277
    [Thu Apr 09 07:25:00.840813 2015] [:error] [pid 23911] [client 172.26.9.29:64162] PHP Warning: current() expects parameter 1 to be array, string given in /var/www/fog/lib/fog/Image.class.php on line 212
    [Thu Apr 09 07:25:00.840877 2015] [:error] [pid 23911] [client 172.26.9.29:64162] PHP Fatal error: Call to a member function getOptimalStorageNode() on a non-object in /var/www/fog/lib/fog/Host.class.php on line 277
    [Thu Apr 09 07:26:11.952242 2015] [:error] [pid 24175] [client 172.26.9.29:64180] PHP Warning: current() expects parameter 1 to be array, string given in /var/www/fog/lib/fog/Image.class.php on line 212[/COLOR][/SIZE]


Log in to reply
 

378
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.