TFTP didn't update web interface did?



  • Just updated Fog fron version .32 to 1.2.0 trying to get an optiplex 7020 working. The TFTP boot registration still shows version .32. The web interface is updated and the database schema update worked. An older PC still will complete the registration, so it is at least still working.


  • Developer

    updates use the settings you chose the first time you ran the setup and reuses the same password



  • I ran the install again, now I have successfully registered my newest PC. Thank you for all the help. I think maybe I had pressed enter during the script install the first time before updating the database schema. Is there a way to keep the database password in the config file when doing an upgrade?

    foginstall.txt


  • Developer

    please re-run the installer, as Tom suggested. it is apparent that the installer did not complete it’s operations, which include downloading the appropriate files to /tftpboot and generating the default.ipxe file



  • after downloading the kpxe file from fog I now get tftp://192.168.4.2/default.ipxe… no such file or directory

    ls -al /tftpboot
    total 372
    drwxr-xr-x 5 fog root 4096 Apr 10 08:24 .
    drwxr-xr-x 27 root root 4096 Sep 17 2014 …
    -rw-r–r-- 1 fog root 828 May 24 2012 boot.txt
    drwxr-xr-x 5 fog root 4096 Feb 16 2011 fog
    -rw-r–r-- 1 fog root 25340 May 24 2012 memdisk
    -rw-r–r-- 1 fog root 0 Sep 5 2012 pelinux.0
    -rw-r–r-- 1 fog root 16794 May 24 2012 pxelinux.0
    drwxr-xr-x 2 fog root 4096 Feb 19 17:47 pxelinux.cfg
    drwxr-xr-x 2 fog root 4096 Feb 16 2011 tftpboot
    lrwxrwxrwx 1 root root 13 Apr 9 16:16 undionly.0 -> undionly.kpxe
    -rw-r–r-- 1 root root 88772 Apr 7 06:41 undionly.kpxe
    -rw-r–r-- 1 root root 61815 Apr 9 16:00 undionly.kpxe.source
    -rw-r–r-- 1 fog root 147728 May 24 2012 vesamenu.c32


  • Developer

    Better get the latest ipxe binary provided by FOG: https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/undionly.kpxe

    Please post the output of ‘ls -al /tftpboot’



  • junkhacker - only the files from before the upgrade( time stamped 5/25/13 I think) were in my tftpboot directory until uncle frank had me create the link and I downloaded the kpxe file from ipex.


  • Senior Developer

    Can you rerun the FOG installation and once it completes, post the /var/log/installfog.log



  • I do not have the undionly.kpxe file in the tftpboot directory. Doing the above command made a file but the kpxe file is missing for it to point to. I downloaded the undionly.kpxe file from ipxe changed my dhcpd.conf file to point at the undionly.0 now it boots from tftp but does not load the menu.


  • Developer

    @Shep, post: 45256, member: 29292 said:

    It is Ubuntu 12.04 I have restarted the service still get the same thing. Where is the new boot file supposed to be. I am thinking it isn’t in the directory since it at least boots to the menu if I change the dhcp.conf to boot pxelinux.0

    can you please list the contents of your /tftpboot directory?


  • Developer

    Bootfile is usually called undionly.kpxe (because this is working with most hardware) and resides in /tftpboot(/undionly.kpxe).

    If pxelinux.0 is working for you I guess we have another example of a “wanna be very smart” kind of switch between client and FOG server. Please try this: Change back your dhcpd.conf file AND

    sudo ln -s undionly.kpxe /tftpboot/undionly.0
    ls -al /tftpboot
    


  • It is Ubuntu 12.04 I have restarted the service still get the same thing. Where is the new boot file supposed to be. I am thinking it isn’t in the directory since it at least boots to the menu if I change the dhcp.conf to boot pxelinux.0


  • Developer

    What OS is this Fog server on? If its Ubuntu you may need to restart the tftp service.



  • root@FOG:~# netstat -antup |grep -e ‘:67’ -e ':69’
    udp 0 0 0.0.0.0:67 0.0.0.0:* 22074/dhcpd
    udp 0 0 0.0.0.0:69 0.0.0.0:* 24033/in.tftpd
    I attached the pic, what config files do you want and where are they?

    error.jpg


  • Developer

    Can you give us a pic of the TFTP failure?


  • Developer

    See if DHCP and TFTP services are running properly:

    sudo netstat -antup | grep -e ':67' -e ':69'
    udp        0      0 0.0.0.0:67              0.0.0.0:*                           3773/dhcpd
    udp        0      0 0.0.0.0:69              0.0.0.0:*                           1897/in.tftpd
    

    If you don’t see both something is wrong. Maybe post your configs. And let us know about error messages if you see any.



  • Ok changed my dhcpd.conf files now tftp does not work at all. Get selected boot device failed? Just finished going through the upgrade documentation. Thanks for the link


  • Developer

    Just to chime in here. Since you didn’t read the upgrade information I have supplied the link here.
    http://fogproject.org/wiki/index.php/Upgrade_to_1.x.x

    You really should read this as it pertains to changes needed to make the newer version of FOG to work correctly.



  • DHCP Server is internal to the FOG machine. I have to admit I did not read the documentation for the upgrade so option 67 sounds like a good place to start. Fog is installed on ubuntu 12.04.


  • Senior Developer

    I think someone forgot to set option 67 to point to the proper file.


Log in to reply
 

341
Online

38729
Users

10555
Topics

99925
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.