Adding Windows 7.iso to iPXE boot menu. Getting No space left on device error.

  • Hello guys! I am currently trying to edit the iPXE menu to include a copy of Windows 7. I have the iso stored here var/www/fog/service/ipxe/iso/Windows7Master.iso

    My Advanced Boot Configuration file
    item --gap – ---------------- iPXE boot menu ----------------
    item WIN7PE64BIT Boot Windows 7 Master 64 bit iso
    item shell ipxe shell
    choose target && goto ${target}
    initrd http://${fog-ip}/fog/service/ipxe/iso/Windows7Master.iso ||
    echo failed to load iso if it stops here
    chain memdisk iso raw ||
    echo failed to chain memdisk if it stops here
    boot ||
    echo failed to boot here if it stops here
    goto MENU
    shell ||
    goto MENU

    When I try and boot to the ISO I get a No space left on device ([url][/url]) . This error would normally tell me that the computer does not have enough RAM to handle the image but a) I am on a laptop with 8Gb and b) the image is only 3.6 GB.

    I tried multiple different solutions and nothing really helped. I was using a thread from a couple months ago for reference (the config is almost identical at this point). I would link to it but I cannot seem to find it right now.

    Thanks in advance for any help

  • According to the page that you have linked, you can run

    sanboot [url]http://<ip>/fog/service/ipxe/isos/<filename>.iso[/url]

  • Junkhacker sorry for not being specific. I currently am not at work so I do not remember the exact version but it was up to date as of Saturday. I can get you more specific info tomorrow if needed. As for how far the download gets, as far as I am aware it does not even start. I get the No Space Left on Device error and then immediately the echo that I coded in. As far as my naked eye can see a download of the iso to the computer does not happen.

  • Developer

    saying you’re on “trunk” doesn’t give us specific enough information about what version you’re on. the trunk version can change multiple times in a day, and for all we know, you could be on a 2 month old version. it would still be “trunk.”
    how far does the download progress before it fails? have you tried it on more than one computer?

  • Also,

    Check back here from time to time, it’s highly likely that other members can smash this problem pretty quickly.

  • It could be that those are for .32, both were last modified in 2011…

    I’ve also just searched the forums quickly without any hits for “iso” or “ISO”

    I personally have never put an ISO into the FOG boot menu, but I plan to… I’m currently putting together a Fedora 21 core server (no GUI) and I’m going to probably put FOG on it today, simply for the purposes of learning more about it and helping here on the forums.

    In the mean time, you might find these helpful:

    Also, if you figure it out, please let us know what you did… The WiKi pages on this need updated.

  • Just gave both those wiki articles a shot and it seems like I took a couple steps back honestly.

  • Thanks for the quick response Wayne. I am currently on FOG Trunk and Ubuntu 14.04. I took a quick look at those two wiki links and was under the impression they would not work for anything after .32. If that is not the case I will give them a shot when I get back into the office Tuesday.

  • What version/revision of FOG?
    What’s the Linux distro and version?

    Also, take a look at this: [url][/url]

    From just glancing through that WiKi page, I would THINK that you’re ISO is in the wrong spot.

    Although this WiKi page is about Parted Magic, it might help you figure this out:

    Let us know, we’re here to help.