Computer Group Limits



  • I just upgraded to .32 and I was curious if there is a computer group limit now. In .28 I was able to have a group of over 1000 computers. Now I Cannot, is it possible to increase this, or is there something wrong with my install?


  • Senior Developer

    I’ve made these suggestions in 1.x.x where it should find hosts and use whatever mac is attached so long as it is registered to the host as an additional MAC. Hopefully people are finding this a nice addition.



  • Great idea.



  • What we could do is actually put in for a feature request to allow FOG to use any MAC address associated with a PC. That way, it wouldn’t matter if the wireless, bluetooth, additional NIC’s are set as the primary, it would default to whatever interface is currently accessing FOG.



  • I’m guessing you are correct, when they export they are in no specific order that I can tell so I would no be surprised if a wlan car or even a bluetooth adapter ended up first on the list.

    Unless you think it’s worth looking at getting this changed, I will look at getting this moved out of the bugs, and putting a edit in the first comment about importing from OCS.



  • It might not like it on importing it, but once imported, it doesn’t really matter how many MAC’s you have. Actually, one of the features to FOG is adding multiple MAC’s to a single machine. However, where you might be running into issues is the primary MAC. I’m going off of memory at this point, however, I think you can only run commands (imaging, run tasks etc) with the primary MAC for that machine. So if you’re doing a batch import on laptops for instance, the primary MAC could be wireless which could be causing issues.



  • I may have made some progress.
    i was doing a mysql dump from OCS-NG and importing that.

    I don’t think FOG likes the fact that some machines have upwards of 3 MACs and so it’s causing issues.

    I found the OCS import plugin located here: [URL=‘http://sourceforge.net/tracker/index.php?func=detail&aid=3184712&group_id=201099&atid=976201’]OCS Plugin[/URL]

    I am now using that to import machines in, and groups are working fine.

    Again I’m not really sure why this works and that doesn’t, and i’m not sure how to test it.



  • Yeah, that’s fine.



  • Thanks for the update!
    Can I contact your privately To try and narrow down what I am doing differently to cause this?



  • I just created a new group and had all the computers move to it without any issues. It added over 8600 PC’s over without any issues.



  • Interesting.

    I have tried it on two different freshly installed fog boxes with simply importing Mac and hostname.

    Can you try to create a new group with all your machines in it and let me know if it works?

    I can create a group with more than 1000, i just have to add them in small amounts.



  • Yes, we pulled an SCCM report of all active PC’s with MAC addresses and then did the host import.



  • How were your computers entered into FOG?

    By Host Import?



  • I have fog .32 running on Ubuntu 10.04 and my largest group I have has 8400 computers in it.



  • Another update:

    On .32 when creating a group but you do not choose a new group or an existing group the error:
    [B][COLOR=#2c2c2c][SIZE=10px][FONT=arial]Please select or create a new group![/FONT][/SIZE][/COLOR][/B]

    Does not appear anymore like it does in my 0.29 install.
    [SIZE=1][FONT=arial][COLOR=#2c2c2c][B][/B][/COLOR][/FONT][/SIZE]



  • So i took my old fog box Version 0.28 ubuntu 10.04 and I am able to create a group of 1030 machines fine.
    These machines were all registered with the fog service.

    If I export this and the do a host import into a freshly installed .32 fog install on Ubuntu 10.04 I am only able to create a hostgroup with around 980 host. But I can then add host 10 at a time until i reach 1030-1040.

    Is there hard coded limit somewhere I can change?



  • Clean install on another machine, Ubuntu 10.04 FOG .32 [CENTER][FONT=Ubuntu][COLOR=#333333]1197[/COLOR][/FONT][/CENTER][CENTER][FONT=Ubuntu][COLOR=#333333] imported via host import csv.[/COLOR][/FONT][/CENTER]

    [CENTER][FONT=Ubuntu][COLOR=#333333]Cannot create a group with all 1197 machines, just wanted to provide ab it more info here.[/COLOR][/FONT][/CENTER]



  • Thank you. I’m thinking about trying a re-install just to be sure it’s not that.



  • I’m going to suggest that this get moved to the dev forums. :) I don’t have an answer but they should be able to help.

    thanks!



  • anyone have some input on this? I am able to create a group that is 940 computers in size but not over that it seems


 

397
Online

41.5k
Users

12.0k
Topics

113.5k
Posts