Firefox/cache issue



  • I just upgraded from 0.33 (or 0.32, I forgot) to 1.2.0.

    I experienced odd issues with Firefox: from Host Management if I tried to search on a computer, I got an error.
    If I clicked all hosts and then a host, I saw the details of the host correctly… great.
    However in that individual host XYZ screen if I then clicked ‘Basic Tasks’ (to deploy something) nothing happened… the browser scrolled down a bit but that’s it… no screen change… no Download/Upload things to click.
    When I tried Internet explorer it had no such issues.

    Turned out that after I clear the browser cache, it all works (again) :).

    Now why would that be needed? Are there files shipped in fog 1.2.0 that are older than what I had in 0.32/0.33? And thus the “newer” but actually “older” file is still cached? Or something similar / else?
    There must, after all, be some reason for it to hold the cache incorrectly… caching isn’t that dumb.
    (Firefox 36, and I did restart several times - for other reasons - so it’s not session related)

    I suggest to find the cause and fix it in some way. Not for me… I’m fine now, but for those others that upgrade.

    Just a suggestion :)


  • Testers


  • Senior Developer

    This isn’t something that I can fix. This is specific to your browser (notice the keyword of your) in this sentence. Your local system has stored a “cache” of what it expects to find for the page. If you clear cache this fixes it, or if you tell the page to do a “hard refresh” it should fix the issue as well. My installation scripts have no way of knowing what items your browser has cached on it.


Log in to reply
 

487
Online

39003
Users

10718
Topics

101766
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.