Optiplex 3020 TFTP Issue



  • Hello All,

    We’ve been using FOG fairly successfully for a while now until the past two days where we cannot get some fresh Dell Optiplex 3020’s to get to PXE boot. We’ve tried many different things, but the 3020’s we tried all time out at:

    tftp://10.1.0.1/default.ipxe…Connection Timed Out

    (Doing this from memory, so that may not be the exact wording on the error)

    I should point out that 10.1.0.1 is not the IP for our FOG server, but rather it is the router for our network, which does not do DHCP, nor is it specified anywhere in the FOG configs that I’ve checked. FOG is also working just fine with all other computers including a new Dell Latitude laptop we got last week.

    [B]System Details:[/B]
    FOG version - 1.2.0 Rev 2993
    OS - Ubuntu 12.04 LTS desktop
    This is a virtual machine running on VMWare ESX 5.5 Update 2 with 4 GB memory and 100GB disk space allocated
    DHCP - DNSMASQ, using undionly.kpxe
    FOG kernel - I tried 3.19.2, 3.19.1, and 3.18.2 (? can’t remember the exact numbering for the kernel below 3.19.1)

    [B]Optiplex 3020[/B]:
    OS - Windows 7 64-bit
    BIOS - A06 (Also tried A05 and A07)
    Secure boot - disabled
    UEFI - disabled

    I tired to update/downgrade the BIOS on the computer, we tried plugging directly into the switch, I’ve tried several different kernels and I tried to update to the latest revision (3186 I think?), but the install hung at “Downloading New FOG Client”, so I had to revert back to a snapshot I took yesterday. I’ve started and restarted services to the end of the Earth and I’ve hunted through every config file I could think of, with no luck.

    I will not be able to test with the workstations until tomorrow, but I can remote into the server and try to grab some information if needed. I also am open to the fact that this could just be a hardware issue with the batch of desktops we got, so I’ll just have to work around that if that turns out to be the case.

    Thanks very much for any help!



  • @Jack-S. i think for the bios drivers update with your Dell OptiPlex 3020, you can get it from here: https://www.driverdr.com/dell-drivers/dell-optiplex-3020-drivers-free-download


  • Moderator

    [quote=“Uncle Frank, post: 45121, member: 28116”]Sucessful…??[/quote]

    Nope… :-(

    So, I’m sort of taking extreme measures for testing… I’ve set up a FOG server at home using dnsmasq, still haven’t got that completely working yet…

    And I’m in the process of setting up another FOG server at work, isolated on it’s very own little 100Mb switch, disconnected from everything. I plan to run DHCP on that FOG machine.

    So, literally, I WILL have every type of setup at my disposal to try to get this working with.

    I’ve tried snp.efi snponly.efi ipxe.efi and a few others so far… and a custom one that Tom had me try as well.
    This is really the wrong thread for this…

    I might make one if I continue to have bad luck.


  • Developer

    [quote=“Wayne Workman, post: 45073, member: 28155”]Tom was working on it today a little for me.
    At work, we have Dell 7010 models which UEFI can be enabled or disabled for. I’ve been having the blues trying to get them to boot with ipxe.efi[/quote]
    Sucessful…??


  • Moderator

    Tom was working on it today a little for me.
    At work, we have Dell 7010 models which UEFI can be enabled or disabled for. I’ve been having the blues trying to get them to boot with ipxe.efi


  • Developer

    @Tom, has ipxe changed since 1.2.0?? I really wonder if this is a FOG issue or mainly related to the ProxyDHCP setup…



  • Thanks for tip! I don’t have much time right now to be able to test as thoroughly as I’d like, but maybe in a few weeks I can throw this at our intern and have him work on it


  • Moderator

    This post is deleted!

  • Developer

    instead of using the normal [CODE]svn update[/CODE]
    you can use [CODE]svn update -r2948[/CODE] would bring you to revision 2948



  • What’s the best way to update to previously released svns? I only know how to get the latest release


  • Moderator

    huh…

    Please do us a favor… please…

    [B]Keep your working snapshot[/B]

    And update FOG by like 10 revisions at a time… test each one with MemTest, perhaps.
    So, 2920 then 2930, then 2940… find out where it breaks…

    Then revert to your working snapshot… and take the last range you used and update one at a time… Figure out EXACTLY where it breaks. This will allow the developers to fix this issue for you and everyone else.



  • Well today I tired to update to the latest svn 3200, but after the script ran nothing changed as everything said I was still on 2993 even after a server reboot (wish I would’ve had the foresight to grab the logs). Then on a whim I decided to revert the VM back to a snapshot I had before I updated to svn 2993, so it was just native FOG 1.2.0 and now everything works!


  • Moderator



  • [quote=“Uncle Frank, post: 44907, member: 28116”]So maybe you turn off FOG DHCP (‘service dnsmasq stop’) for a moment any configure your Windows DHCP server with DHCP options 066 and 067 ([url]http://www.fogproject.org/wiki/index.php/Windows_DHCP_Server[/url]). I don’t know much about this but Wayne does! I guess he can tell you all about it!![/quote]

    Oooo man looks like I lied, DHCP is handed out by our router now 10.1.0.1 and that I don’t have access to. Although that may start to explain some issues


  • Developer

    [quote=“Jack S., post: 44905, member: 29223”]Windows is running DHCP in our environment and yes I can get access to it[/quote]
    So maybe you turn off FOG DHCP (‘service dnsmasq stop’) for a moment any configure your Windows DHCP server with DHCP options 066 and 067 ([url]http://www.fogproject.org/wiki/index.php/Windows_DHCP_Server[/url]). I don’t know much about this but Wayne does! I guess he can tell you all about it!!



  • [quote=“Wayne Workman, post: 44901, member: 28155”]What is running DHCP in your environment? Do you have access to it?[/quote]
    Windows is running DHCP in our environment and yes I can get access to it

    [quote=“Uncle Frank, post: 44902, member: 28116”]

    Could you please provide more infos on what happens before this! Take a picture with your camera or type it from the screen. We need to know what messages exactly you see on the screen before this error comes up…

    Maybe the Optiplex 3020 is a bit buggy when it comes to iPXE and Proxy DHCP??[/quote]

    Thanks for going through those dump files! It is really hard to tell what comes up on the screen before the error since it goes by so quickly, but it looks like the OptiPlex initially pulls the correct information like you said.

    It looks like the screen says the IP of the PC, the FOG server IP, subnet mask, default gateway of 10.1.0.1 and then it flashes to iPXE initializing devices…ok. Then it goes to tftp://10.1.0.1/default.ipxe…Connection timed out ([url]http://ipxe.org/4c126035[/url]) Selected boot device failed.

    The PCs that work have the same information but they pull tftp://10.1.0.53/default.ipxe


  • Developer

    [quote=“Jack S., post: 44806, member: 29223”]I should point out that 10.1.0.1 is not the IP for our FOG server, but rather it is the router for our network, which does not do DHCP, nor is it specified anywhere in the FOG configs that I’ve checked.[/quote]

    The packet dumps tell a completely different story… I see two answers to every DHCP request. One is coming from 10.1.0.53 (next-server and filename are properly set but no IP is being offered!) and another one is coming from 10.1.0.1 (IP is being offered but no PXE options!). [B]Looks like Proxy DHCP setup to me![/B]

    From what I can see it’s working for some of your devices so I guess it’s setup kind of properly. Question remains, why do Optiplex 3020 fail to find the correct TFTP server. [I]Well, in fact it does find the correct TFTP server on the first run[/I] when the PC comes up and the NIC itself requests an IP and loads undionly.kpxe from the TFTP. I see that this works great in both cases!! But after that. On working devices the iPXE binary (undionly.kpxe) requests another IP and loads default.ipxe, fine! On the failing device I don’t see another DHCP request, weird!

    [quote=“Jack S., post: 44806, member: 29223”]tftp://10.1.0.1/default.ipxe…Connection Timed Out[/quote]
    Could you please provide more infos on what happens before this! Take a picture with your camera or type it from the screen. We need to know what messages exactly you see on the screen before this error comes up…

    Maybe the Optiplex 3020 is a bit buggy when it comes to iPXE and Proxy DHCP??


  • Moderator

    What is running DHCP in your environment? Do you have access to it?



  • Okay, so bad news: using a cable straight from a wall jack into the computer made no difference. The OptiPlex 3020 still tries to grab default.ipxe from 10.1.0.1 instead of 10.1.0.53. Even worse news: I just tried to image a Dell OptiPlex 380 and while it could boot the FOG menu (using the same wall jack as the OptiPlex 3020), PartClone did not start and it just sat at a black screen for about 10 minutes. I also tried to create a task through the FOG web console and the task just sat at “Queued” even if I tried to force it to start. I’ve restored the FOG VM to a what I thought was a stable configuration before we even tried to mess with the 3020’s, but it looks like I need to go back further.



  • [quote=“Tom Elliott, post: 44855, member: 7271”]So the Cisco VoIP phone is an indicator to me. The TFTP requests that VoIP phones require for their configuration is a know potential problem. What’s more concerning is the crappy 8 port switch with this VoIP phone is only seeming to affect the 3020s. Does this somewhat match what you’re seeing? Is there a way to find out what the VoIP system is looking at for their configuration?[/quote]

    The VoIP system gets its configuration information from a separate subnet. All end devices (PCs, laptops, servers) are on 10.x.x.x while the VoIP system is on 172.16.x.x. What gets even weirder is we’ve been able to FOG without issue for months now through the VoIP phones built in switch. Now not all desks have the 8-port switch to worry about, so maybe tomorrow I’ll try a port straight from the wall and see where that gets us.


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.