Images in /images/dev



  • using revision 3183 on Debian 7.8 XFCE (Wheezy)

    not sure if this is a bug since I’ve had the problem with all revisions

    for some reason all of my images are stored in /images/dev/[mac address of host] and they’re never moved out

    I increased the FOG_FTP_TIMEOUT to 200

    here are the last errors in the apache2 log:

    [Mon Mar 30 20:52:54 2015] [notice] caught SIGTERM, shutting down
    PHP Warning: Module ‘mysqlnd’ already loaded in Unknown on line 0

    [Mon Mar 30 20:52:56 2015] [notice] Apache/2.2.22 (Debian) PHP/5.4.39-0+deb7u1 c
    onfigured – resuming normal operations

    [Mon Mar 30 21:42:49 2015] [error] [client 192.168.1.50] PHP Warning: in_array(
    ) expects parameter 2 to be array, null given in /var/www/fog/lib/pages/ImageMan
    agementPage.class.php on line 482, referer: [url]http://192.168.1.50/fog/management/i[/url]
    ndex.php?node=image&sub=add

    and here’s the last part of the install log where some errors showed up:

    PHP Warning: Module ‘mysqlnd’ already loaded in Unknown on line 0
    PHP Warning: Module ‘mysqlnd’ already loaded in Unknown on line 0
    PHP Warning: Module ‘mysqlnd’ already loaded in Unknown on line 0
    OK

    • Copying back any custom hook files…OK

    • Copying back any custom report files…OK
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:

      [url]http://192.168.1.50/fog/management[/url]

    Press [Enter] key when database is updated/installed.

    • Setting up storage…OK
    • Setting up and starting DHCP Server…OK
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…

    after the init scipts part, I saw the word ‘terminated’ appear



  • Thank you very much! I think that’s it - an ftp password issue. I set the user password and the password in the fog configuration to the same thing and my latest test upload put everything in /images/testimage.



  • maurice@fog-server:~$ iptables -L
    bash: iptables: command not found
    maurice@fog-server:~$ sudo iptables -L
    [sudo] password for maurice:
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    from a web browser, I do get a message asking for user name and password, but it isn’t fog and password, so I’ll have to check into that.

    thanks


  • Moderator

    Is your firewall off?

    iptables -L
    [url]https://wiki.debian.org/iptables[/url]

    What happens when you use a web browser and try to go to:

    [url]ftp://x.x.x.x[/url]

    with the x’s being the FOG server IP, of course.

    It should ask for credentials. You SHOULD be able to use the Debian Fog user. So, username should be fog, or Fog, or FOG (don’t remember)… and whatever password is set for it…

    Maybe make sure that your storage management stuff is configured, look at your Node settings, make sure the right path, username, and password are there.

    Also, if you need to, just change the Fog user’s password, and then update the password inside the storage node.

    Let us know.


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.