Fog server not wokring over PXE



  • My internal network:

    Server IP: 192.168.1.107
    Mask: 255.255.255.0
    GW: 192.168.1.1

    Server OS base:
    Distributor ID: Debian
    Description - Debian GNU/Linux 7.8 (wheezy)
    Release: 7.8
    Codename: wheezy

    And no, its not a network error as ive done some deployment in the past on the same network with same devices. Also server is on VirtualBOX. Windows FW is disabled.

    During install:
    gave 192.168.1.107 as server IP
    gave 192.168.1.1 as router IP
    No to DNS option
    No to DHCP

    After install i can acces web based admin page. But when another PC boots via network it gets error:

    [IMG]http://www.upload.ee/image/4598515/nonaq.png[/IMG]

    After installing dnsmasq i get this error:

    [IMG]http://www.upload.ee/image/4598521/masq.png[/IMG]

    How can i fix this?


  • Moderator

    It’s not a router.

    It’s a router, switch, DHCP, DNS, Access point Combination device…

    and real world organizations with over 10 clients don’t use such limited consumer grade devices within their core network infrastructure. They would use an enterprise level solution (like Cisco Small Business devices, or server 2008, 2012.) that allows configuring 066 and 067.

    What I recommend for you is not necessarily what I’d recommend for others.


  • Developer

    What kind of switch (maybe more than one) is installed between FOG server and clients?

    Some “intelligent” switches mess around with PXE information in DHCP packets. So far I have only seen undionly.kpxe -> undionly.0 but maybe yours is doing undionly.kpxe -> pxelinux.0

    Checkout wireshark/tcpdump if you are really keen and want to see what exactly is going on here. But you should also be fine with what you just did… sometimes renaming or linking the boot file is the only solution if you can’t change your switch configuration!



  • Got it to work finally without DHCP installed on fog server… yay!!!

    This solution worked:
    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]

    I still got file pxelinux.0 not found error, which is odd cuz

    The boot filename.

    dhcp-boot=undionly.kpxe,192.168.1.107

    so just did this

    mv /tftpboot/undionly.kpxe /tftpboot/pxelinux.0


  • Developer

    AFAIK PXE boot without Options 066 and 067 is not possible. In fact those two options ARE PXE. You can’t play tennis without some kind of racket, can you?
    You might want to look into Proxy DHCP if you want to stick to your TP-Link router.
    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]
    [url]https://help.ubuntu.com/community/UbuntuLTSP/ProxyDHCP[/url]



  • This device has very limited options to configure DHCP. No option 66 or 67. Its very easy to blame TP-Link router and recommend to run DHCP on fog server, but in the real world such luxury is often not available. Yes, i did try to run DHCP on fog server and everything worked but that’s not what im really after. Also Windows Server 2012 R2 WDS PXE works fine with same TP-Link device. Ive also read that this particular problem has some ppl look for other solutions for their deployment problems. Really sad if true :(


  • Moderator

    Here’s more info on DHCP options: [url]http://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xhtml[/url]

    Just for your learning purposes.


  • Moderator

    I’m not sure what your skill level is but, you did ask how to configure 066 & 067.

    Just open a web browser and go to you’re TP-Link’s internally facing interface address.
    For you, that would be [B]192.168.1.1[/B]

    It should ask for credentials at some point. You can probably Google search the default username/password for that device and find it within a minute or two.

    Past that, you just need to look around in there. No two are really laid out the same so you just need to be familiar with the terminology. Look into the DHCP stuff. See if you can configure options 066, or 067. They may not be labeled with numbers.

    If you can’t figure it out, it’s probably best to turn off DHCP (just figure out how to turn just DHCP off), then set it up on the FOG server.

    You’ll need to know about IP ranges, subnet masks, your DNS server, your gateway…
    Just a stab at what those are for you:

    Range: 192.168.1.2 - 192.168.1.254
    Subnet mask: 255.255.255.0
    DNS: 192.168.1.1
    Gateway: 192.168.1.1


  • Moderator

    If that TP-Link device that is currently running DHCP can’t set options 066 & 067, then you might be best to turn off that service (not the device, just the service) and set up DHCP on your FOG server.

    Is this FOG setup just for learning? I’m assuming so because of the device that’s handing out DHCP.
    If that’s the case, you can simply turn DHCP off for that device, set up FOG /w DHCP for learning purposes, and then turn DHCP on for that device later when you’re done (or continue using FOG’s DHCP).

    I think that’s going to be your golden ticket, honestly. Consumer grade DHCP devices usually aren’t up-to-snuff for advanced stuff; hence Consumer Grade.



  • TP-LINK
    Firmware Version: 3.12.20 Build 120523 Rel.38790n
    Hardware Version: MR3220 v1 00000000

    But had same problems with Mikrotik RB951Ui-2HnD aswell


  • Senior Developer

    What are you using for a DHCP server?



  • Can you post your installation log? It’s here: [SIZE=12px]/var/log/foginstall.log[/SIZE]

    [INDENT=1][COLOR=#0000ff][SIZE=12px] Base Linux: Debian[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Detected Linux Distribution: Debian[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Installation Type: Normal Server[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Server IP Address: 192.168.1.107[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] DHCP router Address: 192.168.1.1[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] DHCP DNS Address:[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Interface: eth0[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Using FOG DHCP: 0[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Internationalization: 0[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Donate: 0[/SIZE][/COLOR][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] DHCP will NOT be setup but you must setup your[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] current DHCP server to use FOG for PXE services.[/SIZE][/COLOR][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] On a Linux DHCP server you must set:[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] next-server[/SIZE][/COLOR][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] On a Windows DHCP server you must set:[/SIZE][/COLOR][/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] option 066 & 067[/SIZE][/COLOR][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Option 066 is the IP of the FOG Server: (e.g. 192.168.1.107)[/SIZE][/COLOR][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][COLOR=#0000ff][SIZE=12px] Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)[/SIZE][/COLOR][/INDENT]

    Maybe doublecheck your /tftpboot permissions?
    [CODE]ls -ld /tftpboot[/CODE]

    [INDENT=1][SIZE=2][COLOR=#0000ff] ls -ld /tftpboot[/COLOR][/SIZE][/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]drwxr-xr-x 2 fog root 4096 Mar 28 13:39 /tftpboot[/COLOR][/SIZE][/INDENT]
    [INDENT=1] [/INDENT]
    Maybe check your firewall?
    [CODE]iptables -L[/CODE]

    [INDENT=1][SIZE=2][COLOR=#0000ff]iptables -L[/COLOR][/SIZE][/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]Chain INPUT (policy ACCEPT)[/COLOR][/SIZE][/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]target prot opt source destination[/COLOR][/SIZE][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]Chain FORWARD (policy ACCEPT)[/COLOR][/SIZE][/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]target prot opt source destination[/COLOR][/SIZE][/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]Chain OUTPUT (policy ACCEPT)[/COLOR][/SIZE][/INDENT]
    [INDENT=1][SIZE=2][COLOR=#0000ff]target prot opt source destination[/COLOR][/SIZE][/INDENT]

    Also, if you’re not using FOG as a DHCP server, then you must configure options 066 and 067 on your actual DHCP server (this will make your life a whole lot easier). 066 is normally the IP address of the FOG server, 067 is the bootfile name you want to use. Generally, undionly.kpxe will be you’re winner for systems made 6 months ago and greater. For newer systems shipping with win8 and UEFI type bios, you would use ipxe.efi for option 067.

    Where can i configure those options?


  • Moderator

    What version/revision of FOG?

    Can you post your installation log? It’s here: [SIZE=12px] [/SIZE][SIZE=12px]/var/log/foginstall.log[/SIZE]

    Maybe doublecheck your /tftpboot permissions?
    [CODE]ls -ld /tftpboot[/CODE]

    Maybe check your firewall?
    [CODE]iptables -L[/CODE]

    Also, if you’re not using FOG as a DHCP server, then you must configure options 066 and 067 on your actual DHCP server (this will make your life a whole lot easier). 066 is normally the IP address of the FOG server, 067 is the bootfile name you want to use. Generally, undionly.kpxe will be you’re winner for systems made 6 months ago and greater. For newer systems shipping with win8 and UEFI type bios, you would use ipxe.efi for option 067.

    #LetsMakeScripts



  • /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"
    tftpd-hpa file looks like this


Log in to reply
 

489
Online

38965
Users

10708
Topics

101618
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.