Just upgraded to 1.2.0 and iPXE gives operation not permitted



  • We have been using FOG for imaging and wanted to explore the other things it can do. We also were having issues with Dell Optiplex 9020’s failing to upload images.

    Runing Ubuntu 10.04
    Was working fine other than Optiplex 9020 on version .32
    Now any system we try to boot into FOG gives the PXE Operation not permitted.

    I have looked through the forums all morning and did find [url]http://fogproject.org/forum/threads/stuck-at-boot-php-operation-not-permitted.10706/[/url] but the solution in it did not resolve the issue.

    Any help would be great!!!



  • That worked!!!

    Thanks you guys are great and now begins the process of exploring the features we are not using yet and convincing my bosses that we should be.

    This is an awesome tool thanks for making it, updating it and helping those of us new to linux and FOG.


  • Developer

    At first I thought access rights seem ok. But luckily I didn’t trust my eyes and starting setting rights on my system just to make sure I didn’t miss something. And there it is…
    [CODE]sudo ls -al /var/www/fog/service/ipxe
    total 34188
    drwx------ 2 fog www-data 4096 2015-03-26 11:54 .
    …[/CODE]
    The directory itself is not accessible by the webserver. AFAIK all those files and the directory should be owned by www-data and execution rights are not needed:
    [CODE]sudo chown -R www-data /var/www/fog/service/ipxe
    sudo chmod 755 /var/www/fog/service/ipxe
    sudo chmod 644 /var/www/fog/service/ipxe/*[/CODE]
    Boot up the client and see if things work!



  • Here is the output:

    [EMAIL]root@fog-server[/EMAIL]:~# sudo ls -al /var/www/fog/service/ipxe
    total 34188
    drwx------ 2 fog www-data 4096 2015-03-26 11:54 .
    drwx------ 3 www-data www-data 4096 2015-03-26 11:54 …
    -rwxr-xr-x 1 fog www-data 1105 2015-03-26 11:54 advanced.php
    -rwxr-xr-x 1 fog www-data 44908 2015-03-26 11:54 bg.png
    -rwxr-xr-x 1 fog www-data 756 2015-03-26 11:54 boot.php
    -rwxr-xr-x 1 fog www-data 6169392 2015-03-26 11:54 bzImage
    -rwxr-xr-x 1 fog www-data 6170512 2015-03-26 11:54 bzImage32
    -rwxr-xr-x 1 fog www-data 234697 2015-03-26 11:54 grub.exe
    -rwxr-xr-x 1 fog www-data 9577456 2015-03-26 11:54 init_32.xz
    -rwxr-xr-x 1 fog www-data 10914208 2015-03-26 11:54 init.xz
    -rwxr-xr-x 1 fog www-data 25340 2015-03-26 11:54 memdisk
    -rwxr-xr-x 1 fog www-data 1839104 2015-03-26 11:54 memtest.bin


  • Developer

    Please don’t reinstall yet. We better find out what’s wrong and then you can still decide. Better to learn and know what was wrong than having a clean new install working but no idea about why (well, at least that’s how I see things).

    From what I can see in the error.log I am pretty sure it’s access rights on that file. Not sure how that could happen… Please post the output of the following command run on the FOG server:
    [CODE]sudo ls -alZ /var/www/fog/service/ipxe[/CODE]



  • Attached is snippets from the apache error and access logs. I don’t see any activity from Friday March 27th, which is when we did the upgrade. I am thinking maybe the issue is with the networking setup on the machine? Do you guys have any ideas? I was thinking about just backing up our data, upgrading to a newer distro (that you guys have listed as stable) and redoing the install of the latest FOG version.

    [url="/_imported_xf_attachments/1/1832_Apache Logs.txt?:"]Apache Logs.txt[/url]



  • We only use it for FOG. Since it is completely on it’s own network I will look at the apache logs on Monday when I get back into the office. I doesn’t connect to the internet at all.


  • Developer

    Anything in the apache log files?? See Tom’s signature on where to find those. And please check apache’s access.log too! See if this files is really being requested.

    Do you use this webserver for other things too (virtual host setup) or is only FOG installed on this system??



  • PHP version 5.3.2
    mysql 5.1.7





  • I am not sure and niether is the other Tech in the office. How can I check? Sorry I am newer to Linux.


  • Senior Developer

    What version of ph do you have?



  • The first command came back “disabled”, so I skipped the second command.

    The third command gave me some output but I still get the Permission denied on the url from earlier and the same error when trying to boot the system to image it.



  • Here is the install log.

    I will try the commands Wayne suggested.

    [url="/_imported_xf_attachments/1/1819_foginstall.txt?:"]foginstall.txt[/url]



  • Maybe just double check to be sure? See if this command will run:
    [CODE]sudo ufw status verbose[/CODE]

    And, if that works, you could do something similar to turn the firewall off (if it’s on):
    [CODE]sudo ufw disable[/CODE]

    If those commands don’t work, you can use the iptables command:
    [CODE]sudo iptables -L[/CODE]

    Resources used:
    [url]http://www.howtogeek.com/115116/how-to-configure-ubuntus-built-in-firewall/[/url]
    [url]https://help.ubuntu.com/community/IptablesHowTo[/url]

    #LetsMakeScripts


  • Developer

    lets get a copy of your install log



  • No there is no firewall. 10.04 is what it was set up on previous to me getting here and taking it over.
    The system is self contained, it cannot reach the outside world nor any other part of the company network, so they did not put a Firewall in.


  • Senior Developer

    Is there a firewall? 10.04 is very old.



  • When I go there I get permission denied. I did see this in the thread I mentioned in my original post and ran the two commands below, but I guess I forgot to check after running them.

    sudo chown -R www-data:www-data /var/www/fog
    sudo chown -R fog:www-data /var/www/fog/service/ipxe


  • Developer

    what do you see if you go to [url]http://172.25.100.80/fog/service/ipxe/boot.php[/url] in a web browser?


 

404
Online

41.8k
Users

12.3k
Topics

116.0k
Posts