Updating to 1.3.0



  • Hello,
    I had installed version 1.2.0 and wanted to try the new client so I downloaded the code from github (3GB) and started the installer. It worked find until i had to update my database scheme. For what i see in the webpage (/fog/management) after clicking the button to start the update, it doesn’t get the scheme version and tries to apply everything from the beginning, but every sql command fails with empty error message.
    The error_log files registers always the same:
    [CODE][Thu Mar 26 17:47:10 2015] [error] [client 84.88.146.79] PHP Warning: mysqli::query() expects parameter 2 to be long, string given in /var/www/html/fog/lib/db/MySQL.class.php on line 120, referer: http://adfc-img.udg.edu/fog/management/index.php?node=schemaupdater[/CODE]
    I have applied the rest of scheme creating a sql file and updated the scheme version on the database but everytime i try to login it redirects to the management page.
    If i try to start the services by had i receive the same error:
    [CODE][root@adfc-img httpd]# service FOGMulticastManager start
    S’està iniciant el FOGMulticastManager: [ FET ]
    [root@adfc-img httpd]# PHP Warning: mysqli::query() expects parameter 2 to be long, string given in /var/www/html/fog/lib/db/MySQL.class.php on line 120[/CODE]
    I have php 5.5 and mysql 5.
    Can anyone help me with this error?



  • After following the code, the problem was that to use mysqli async queries i need to install php-mysqlnd package instead of php-mysql.



  • Yes, the previous version (1.2.0) was working fine


  • Developer

    Using terminal or ssh can you login to your mysql database?

    [CODE]mysql -u root <-p password> fog[/CODE]


Log in to reply
 

480
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.