Updating to SVN 3121... Setting up and starting TFTP and PXE Servers...Failed!



  • Hello Friends,

    Trying to upgrade from 1.2.0 to SVN 3121. Here is my install log.

    Also: I’m running DNSMASQ with my current setup if that makes a difference. (I replaced the IPs with names, some of it is publicly addressable)

    Thank you for any information you can assist with.


    Here are the settings FOG will use:
    Base Linux: Debian
    Detected Linux Distribution: Debian
    Installation Type: Normal Server
    Server IP Address: myfogserverip
    DHCP router Address: myrouter
    DHCP DNS Address: mydnsserver
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0
    Image Storage Location:
    Donate: 0

         DHCP will NOT be setup but you must setup your
         current DHCP server to use FOG for PXE services.
    
         On a Linux DHCP server you must set:
             next-server
    
         On a Windows DHCP server you must set:
             option 066 & 067
    

    Option 066 is the IP of the FOG Server: (e.g. myfogserverip)
    Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)

    Are you sure you wish to continue (Y/N)
    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Packages to be installed: apache2 php5 php5-json php5-gd php5-cli php5-curl mysql-server mysql-client tftpd-hpa tftp-hpa nfs-kernel-server vsftpd net-tools wget xinetd sysv-rc-conf tar gzip build-essential cpp gcc g++ m4 htmldoc lftp openssh-server php-gettext php5-mcrypt php5-mysqlnd

    • Skipping package: apache2 (Already installed)

    • Skipping package: php5 (Already installed)

    • Skipping package: php5-common (Already installed)

    • Skipping package: php5-gd (Already installed)

    • Skipping package: php5-cli (Already installed)

    • Skipping package: php5-curl (Already installed)

    • Skipping package: mysql-server (Already installed)

    • Skipping package: mysql-client (Already installed)

    • Skipping package: tftpd-hpa (Already installed)

    • Skipping package: tftp-hpa (Already installed)

    • Skipping package: nfs-kernel-server (Already installed)

    • Skipping package: vsftpd (Already installed)

    • Skipping package: net-tools (Already installed)

    • Skipping package: wget (Already installed)

    • Skipping package: xinetd (Already installed)

    • Skipping package: sysv-rc-conf (Already installed)

    • Skipping package: tar (Already installed)

    • Skipping package: gzip (Already installed)

    • Skipping package: build-essential (Already installed)

    • Skipping package: cpp (Already installed)

    • Skipping package: gcc (Already installed)

    • Skipping package: g++ (Already installed)

    • Skipping package: m4 (Already installed)

    • Skipping package: htmldoc (Already installed)

    • Skipping package: lftp (Already installed)

    • Skipping package: openssh-server (Already installed)

    • Skipping package: php-gettext (Already installed)
      dpkg-query: no packages found matching php5-mcrypt

    • Installing package: php5-mcrypt

    • Installing package: php5-mysqlnd

    Confirming package installation.

    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-json…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK
    • Checking package: php5-mcrypt…OK
    • Checking package: php5-mysqlnd…OK

    Configuring services.

     What is the storage location for your images directory? (/images)   * Setting up and starting MySql...OK
    
    • Backing up user reports…OK

    • Setting up and starting Apache Web Server…OK

    • Changing permissions on apache log files…OK

    • Downloading kernels and inits…OK

    • Copying back any custom hook files.

    • Copying back any custom report files.
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:

      [url]http://myfogserverip/fog/management[/url]

    Press [Enter] key when database is updated/installed.

    • Setting up storage…OK
    • Setting up and starting DHCP Server…Skipped
    • Setting up and starting TFTP and PXE Servers…Failed!


  • I’d just like to state that this issue has been solved.

    In summary, the installer will fail if you use DNSMASQ’s built-in tftp server instead of tftpd-hpa.

    Thank you for all of your help!

    Please close



  • Debian version 7.8


  • Moderator

    Out of pure curiosity, what version of Debian are you using?



  • So I have figured out some of my issue. It does actually have to do with DNSMASQ.

    When I first configured my fog server, I had decided to use the “enable-tftp” on the ltsp.conf file in /etc/dnsmasq.d. After symlinking the file for undionly.0, PXE worked great and I never upgraded from 1.2.0.

    Until the surface pro 3 came along! Obviously I have a network with mixed devices and I can’t hand out just one boot file anymore. I can change the bootfile on a per host basis on my dhcp server, so I have done that for testing purposes.

    Commenting out with #enable-tftp allowed for tftpd-hpa to listen on port 69 once again. Ran the upgrade to subversion and successfully ran an installer. I’m now at 3510. The problem is that the only way I can push a bootfile is by once again enabling tftp from the DNSMASQ service and stopping tftpd-hpa. Both cannot listen on the same port, they error out.

    I need dhcp to point my surface pros to snp.efi in order for it to work, but I believe the only way that is going to successfully work is with tftpd-hpa. But the only way I can receive a bootfile seems to be with DNSMASQ.

    Do you have any guidance?

    Thanks again for all of your help.



  • [quote=“Wayne Workman, post: 44102, member: 28155”]Just to back up for a moment (using the KISS method), if you go to the web GUI (you can still get to it, right?) and go to FOG settings, and go to the spot in there for TFTP settings, what do you see? Is it all correct?

    What is inside of here?
    [CODE]/etc/inetd.conf[/CODE]

    Also, try adding this line to /etc/default/tftpd-hpa
    [CODE]RUN_DAEMON=“yes”[/CODE]

    First, backup what you have like this:
    [CODE]sudo cp /etc/default/tftpd-hpa /etc/default/tftpd-hpa_backup[/CODE]

    You could add the “run daemon” line with an ECHO command, or you could use a graphical text editor. I think Debian comes with something called nedit. It’s up to you.

    The ECHO command would be like this:
    (make careful note of the beginning & ending single quotes, and the double quotes around yes)
    [CODE]sudo echo ‘RUN_DAEMON=“yes”’ >> /etc/default/tftpd-hpa [/CODE]

    When you’re done, it should look like this:
    [CODE]

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"
    RUN_DAEMON=“yes”
    [/CODE]

    Use the CAT command to confirm:
    [CODE]sudo cat /etc/default/tftpd-hpa[/CODE]

    Then restart the service with:
    [CODE]service tftpd-hpa restart[/CODE]

    Let us know what it says. If it makes it worse, you can just remove the line, or restore the backup…[/quote]

    I finally got time to work on this again. Here’s a few observations. The same issue still exists in svn 3389.

    inetd.conf does not exist.

    I tried adding the RUN_DAEMON=“yes” with no success.

    Here’s a quick look at my services. This is currently running 1.2.0, pre-install of the SVN. Is there any way to skip over the tftp and pxe install on the update?

    service --status-all
    [ ? ] FOGImageReplicator
    [ ? ] FOGMulticastManager
    [ ? ] FOGScheduler
    [ + ] acpid
    [ ? ] alsa-utils
    [ - ] anacron
    [ + ] apache2
    [ + ] atd
    [ + ] avahi-daemon
    [ ? ] binfmt-support
    [ + ] bluetooth
    [ - ] bootlogs
    [ ? ] bootmisc.sh
    [ ? ] checkfs.sh
    [ ? ] checkroot-bootclean.sh
    [ - ] checkroot.sh
    [ + ] clamav-freshclam
    [ - ] console-setup
    [ + ] cron
    [ + ] dbus
    [ + ] dnsmasq
    [ + ] exim4
    [ + ] gdm3
    [ ? ] hdparm
    [ - ] hostname.sh
    [ ? ] hwclock.sh
    [ ? ] initiscsi
    [ - ] kbd
    [ - ] keyboard-setup
    [ ? ] killprocs
    [ ? ] kmod
    [ - ] lvm2
    [ - ] minissdpd
    [ - ] motd
    [ ? ] mountall-bootclean.sh
    [ ? ] mountall.sh
    [ ? ] mountdevsubfs.sh
    [ ? ] mountkernfs.sh
    [ ? ] mountnfs-bootclean.sh
    [ ? ] mountnfs.sh
    [ ? ] mpt-statusd
    [ ? ] mtab.sh
    [ ? ] mysql
    [ + ] network-manager
    [ ? ] networking
    [ + ] nfs-common
    [ + ] nfs-kernel-server
    [ + ] open-iscsi
    [ ? ] pppd-dns
    [ - ] procps
    [ + ] pulseaudio
    [ ? ] rc.local
    [ - ] rmnologin
    [ + ] rpcbind
    [ - ] rsync
    [ + ] rsyslog
    [ + ] saned
    [ ? ] sendsigs
    [ ? ] speech-dispatcher
    [ + ] ssh
    [ - ] sudo
    [ - ] tftpd-hpa
    [ + ] udev
    [ ? ] udev-mtab
    [ ? ] umountfs
    [ ? ] umountiscsi.sh
    [ ? ] umountnfs.sh
    [ ? ] umountroot
    [ - ] unattended-upgrades
    [ - ] urandom
    [ + ] vmware-tools
    [ + ] vsftpd
    [ - ] x11-common
    [ ? ] xinetd


  • Moderator

    Yeah, do what Uncle Frank said. The guy is a hero.


  • Developer

    From what I can see the config posted by Jeremy is perfectly fine. Maybe there is an old zombie of tftpd still running and listening on the port.
    [CODE]sudo netstat -antup | grep “:69”[/CODE]
    Kill any process you see before trying to start (service tftpd-hpa start) it again.

    If this does not help or if you don’t have any zombie processes you might try starting it in “debug mode”:
    [CODE]sudo /usr/sbin/in.tftpd --foreground -vvv -s /tftpboot[/CODE]

    Then try tftp from another console:
    [CODE]tftp 127.0.0.1
    tftp> get default.ipxe
    tftp>[/CODE]

    You should see something like this in the logs:
    [CODE]sudo tail /var/log/daemon.log

    … in.tftpd[26418]: RRQ from 127.0.0.1 filename default.ipxe[/CODE]


  • Moderator

    [quote=“Jeremy Bailey, post: 44101, member: 12244”]That’s actually what was there.[/quote]

    Just to back up for a moment (using the KISS method), if you go to the web GUI (you can still get to it, right?) and go to FOG settings, and go to the spot in there for TFTP settings, what do you see? Is it all correct?

    What is inside of here?
    [CODE]/etc/inetd.conf[/CODE]

    Also, try adding this line to /etc/default/tftpd-hpa
    [CODE]RUN_DAEMON=“yes”[/CODE]

    First, backup what you have like this:
    [CODE]sudo cp /etc/default/tftpd-hpa /etc/default/tftpd-hpa_backup[/CODE]

    You could add the “run daemon” line with an ECHO command, or you could use a graphical text editor. I think Debian comes with something called nedit. It’s up to you.

    The ECHO command would be like this:
    (make careful note of the beginning & ending single quotes, and the double quotes around yes)
    [CODE]sudo echo ‘RUN_DAEMON=“yes”’ >> /etc/default/tftpd-hpa [/CODE]

    When you’re done, it should look like this:
    [CODE]

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"
    RUN_DAEMON=“yes”
    [/CODE]

    Use the CAT command to confirm:
    [CODE]sudo cat /etc/default/tftpd-hpa[/CODE]

    Then restart the service with:
    [CODE]service tftpd-hpa restart[/CODE]

    Let us know what it says. If it makes it worse, you can just remove the line, or restore the backup…



  • That’s actually what was there.


  • Moderator

    [quote=“Jeremy Bailey, post: 44099, member: 12244”]/etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"[/quote]

    Simple question, did you edit the IP address to 0.0.0.0 just to hide it, or is that actually what was there?



  • [quote=“Wayne Workman, post: 44096, member: 28155”]TFTP shouldn’t have a dependency on dnsmasq in order to run. (someone correct me if I’m wrong?)

    Have you tried to restart TFTP?

    What’s in the config file?[/quote]

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“0.0.0.0:69"
    TFTP_OPTIONS=”-s"



  • [quote=“Berend de Boer, post: 44097, member: 28367”]What if you start it? “service tftpd-hpa start”[/quote]

    [CODE]root@fogserver:~# service tftpd-hpa start
    Starting HPA’s tftpd: in.tftpdroot@fogserver:~# service tftpd-hpa status
    in.tftpd is not running … failed!
    [/CODE]



  • [quote=“Jeremy Bailey, post: 44095, member: 12244”][FAIL] in.tftp is not running … failed![/quote]

    What if you start it? “service tftpd-hpa start”


  • Moderator

    TFTP shouldn’t have a dependency on dnsmasq in order to run. (someone correct me if I’m wrong?)

    Have you tried to restart TFTP?

    What’s in the config file?



  • [FAIL] in.tftp is not running … failed!

    apt-get install tftpd-hpa shows i have the latest version installed already.

    I am using dnsmasq. Is there something special I need to do with a dnsmasq fog upgrade?



  • Thank you, Wayne. I will have a look at it tomorrow.

    Best,

    Jeremy


  • Moderator

    This is the TFTP config file.

    [CODE]cat /etc/default/tftpd-hpa[/CODE]

    Here are some related TFTP commands, the STATUS one should be especially telling.

    [CODE]service tftpd-hpa status
    service tftpd-hpa stop
    service tftpd-hpa start
    service tftpd-hpa restart
    service tftpd-hpa force-reload[/CODE]

    Check what’s allowed in/out of your firewall:

    [CODE]iptables -L[/CODE]

    Let us know what you find, people that hang around here are willing to help.

    Here are the resources I used:

    [url]http://www.cyberciti.biz/faq/install-configure-tftp-server-ubuntu-debian-howto/[/url]
    [url]https://wiki.debian.org/DebianFirewall[/url]


  • Moderator

    This post is deleted!

Log in to reply
 

405
Online

38970
Users

10712
Topics

101666
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.