Extended partition image not uploading/downloading properly



  • So in the the latest version of for 1.02 I was able to successfully upload and deploy an image with multiple partitions including an extended linux partition that had a partition for root(/) /home and swap. It also has the first partition for windows and a partition after the extended partition for shared space.

    I was testing an updated version of this image on the latest svn and ran into a problem. It looked like it uploaded fine and all the data was there. But when I download the image, to an identical computer model even, it gets to the first partition of the extended (sda5 within sda2) and it says that it isn’t a partclone image and just skips it. All the other partitions download perfectly fine. But linux is pretty useless without the root partition that has all the installation on it and what not.

    For funzies I did try formatting the partition that doesn’t get downloaded and copying the conents of that partition from the original image, and I had to change the uuid of the partition to match the old one in the grub config, which did get the grub boot screen to pop up but it didn’t actually boot all the way into linux, it does still get to windows through grub, so that’s good.

    So I’m wondering if anyone has any thoughts on this.

    Oh, and I kept this updated one separate from the old extended partition image and that one still downloads fine, but I’d rather like to not have to update everything on windows and linux again you know.

    Thanks,
    -JJ


  • Developer

    As far as I remember we changed a couple of things with extended partitions in SVN a few weeks ago. Switching between SVN an older versions could cause trouble I suppose…

    Please run a debug session on the client you use to upload the image from, run the following command and copy paste all the output (including warnings and errors) you see:
    [CODE]sfdisk -d[/CODE]


  • Moderator

    Hi,

    I had several issues with partitioning in multiboot configuration. Finally I solved it using a “standard” partitioning in ms dos partition table, using sda4 as the extended and no partition after.

    Now I used it :

    [CODE]/dev/sda1 – windows boot (ntfs)
    /dev/sda2 – windows system (ntfs)
    /dev/sda3 – linux / (ext4)
    /dev/sda4 – extended (-)
    /dev/sda5 – swap (-)
    /dev/sda6 – DATA (ntfs)[/CODE]

    Or that :
    [CODE]/dev/sda1 – windows boot (ntfs)
    /dev/sda2 – windows system (ntfs)
    /dev/sda3 – linux / (ext4)
    /dev/sda4 – extended (-)
    /dev/sda5 – swap (-)
    /dev/sda6 – DATA WIN (ntfs)
    /dev/sda7 – DATA LINUX (ext4)[/CODE]

    In the fstab I disabled the UUID and used names.

    Regards,
    Ch3i.


Log in to reply
 

361
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.