Fog 0.32 upgrade on Red Hat 5.6

  • So, Here’s what I’ve done:

    Started with our existing server which is Red Hat running 0.30. I believe what I needed to do was to first upgrade PHP to 5.3 (done), download and extract fog 0.32 (done) and make the changes to as described in the installation guide for installing it on CentOS. I did do all that, ran the install script with the following results:

    Here are the settings FOG will use:
    Distro: Redhat
    Installation Type: Normal Server
    Server IP Address:
    DHCP router Address:
    DHCP DNS Address:
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0

    Are you sure you wish to continue (Y/N) y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Skipping package: httpd (Already Installed)
    • Installing package: php53
    • Installing package: php53-gd
    • Installing package: php53-cli
    • Skipping package: mysql (Already Installed)
    • Skipping package: mysql-server (Already Installed)
    • Installing package: php53-mysql
    • Skipping package: tftp-server (Already Installed)
    • Skipping package: nfs-utils (Already Installed)
    • Skipping package: vsftpd (Already Installed)
    • Skipping package: net-tools (Already Installed)
    • Skipping package: wget (Already Installed)
    • Skipping package: xinetd (Already Installed)
    • Skipping package: tar (Already Installed)
    • Skipping package: gzip (Already Installed)
    • Skipping package: make (Already Installed)
    • Skipping package: m4 (Already Installed)
    • Skipping package: gcc (Already Installed)
    • Skipping package: gcc-c++ (Already Installed)
    • Skipping package: htmldoc (Already Installed)
    • Skipping package: perl (Already Installed)
    • Skipping package: perl-Crypt-PasswdMD5 (Already Installed)
    • Skipping package: lftp (Already Installed)
    • Skipping package: clamav (Already Installed)

    Confirming package installation.

    • Checking package: httpd…OK
    • Checking package: php53…Failed!

    I log into my fog server now and it’s still saying version 0.30. This is obviously a learning experience for me so any guidance is greatly appreciated.

    Thanks to all who take time to offer suggestions,


  • [quote=“Blackout, post: 2155, member: 1”]To fix the timezone issue, edit your php.ini and set the ‘date.timezone’ variable.

    The installer does not use ‘php -v’ to check the version, it queries RPM.
    Run this for me and post the output:
    [code]rpm -q php53[/code][/quote]
    Odd, on my base server php -v sez I have version 5.1. If I do an rpm-q php51, it said not installed, BUT if I try rpm -q php it correctly identifies 5.1 as the version. i also noticed that the wiki doc states in the CentOS install that it was tested with 0.30. Has any testing been done with 0.32 and CentOS or am I performing that function. 🙂

  • The plot thickens. it says PHP53 not installed. One of the admins here suggested uninstalling the current PHP first. Or maybe uninstalling and downloading the package from instead of using RPM. Thanks for your post

    Well, I do have a snapshot of this VM in case I need to go back, but I did proceed with commenting out the command referenced above and rerun All seemed to go well. i can log in, added / edited hosts, but when I deploy an image, the recipient does boot off the Fog server and loads but seems to hang at a line saying:

    kernel_thread_helper. It seems hung at this point. I assume this is not normal? I’ll let it sit a bit to see if it works it’s way past this.

    Due to an immediate need, I restored the VM from the snap shot. So, I get to do it all over again. Seems the php upgrade is the key to my upgrade issues. Can anyone offer up a repository or methodology for upgrading php such that my server will pass the test?

  • Developer

    To fix the timezone issue, edit your php.ini and set the ‘date.timezone’ variable.

    The installer does not use ‘php -v’ to check the version, it queries RPM.
    Run this for me and post the output:
    [code]rpm -q php53[/code]

  • if anyone felt a cosmic disturbance in the force, it’s me. i edited (confession . . I really didn’t have a clue what I was doing) and commented out the line stating confirmPackageInstallation, reran the install and it seems to have successfully completed. The only issue I’ve run into so far is after a reboot, a warning is flooding my concole concerning this line in /opt/fog/service/common/functions.php: return date(“m-d-y g:i:s a”) The warning states that it is not safe to rely on the system’s timezone settings. You are required to use date.timezone setting or the date_default_timezone_set() function. If you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. Help?

  • The saga continues . . . as a test: Brand new VM running Centos 62. Edited the per the wiki doc, installed a newer repo than the one in the doc and it still chokes on checking package: php53 …Failed! Seems like I’m making a very basic and simple mistake. Below is the text from

    Yum packages to install

    packages=“httpd php5.3 php5.3-gd php5.3-cli mysql mysql-server php-mysql dhcp tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ htmldoc perl perl-Crypt-PasswdMD5 lftp clamav”;
    storageNodePackages=“httpd php5.3 php-cli mysql php-mysql nfs-utils vsftpd xinetd tar gzip make m4 gcc gcc-c++ lftp”; langPackages=“iso-codes”; dhcpname=“dhcp”;

    when I do php -v it comes up as version 5.33 should all thos references be 5.33? Should it be 5.3 or just 53?

    Thanks again to all who view this and reply.

  • Centos 6 and up has PHP 5.3 built in if im not mistaken, its the early OS thats you have to modify the PHP version

  • When I installed FOG 0.32 on my CentOS 6.2 server I installed php53 first and did not make any changes to Everything passed for me.

  • I see (says the blind man). Looks like the php 53 check failed and the install aborted. Oddly, php -v on the server says 5.3.