• Hi,

    I’ve captured a image from a computer containing windows server 2008 R2 SP1. I’ve used Windows 7 as a operation system in the image management and as image type I have Single Disk - Resizable and as partitions, everything. The computer has a raid 5 and 3 partitions. Sda1 is 100mb for windows system, sda2 is 100GB and hosts the windows installation and sda3 is 1.8Tb. It looks like FOG is not resizing the partitions as it should. When I’ve tried to capture a windows 7 computer the 100Gb disk witch contains only 15Gb with data is resized to around 16Gb when the partclone is starting. When I try to capture the windows server 2008 computer the resizing is skipped (It looks that way because the resizing takes a lot more time on a windows 7 computer. In the server computer it takes less than 1 second). The problem then is that the disk sda3 which is 1.8Tb and only contains 10 empty folders (So, very little data!!!) takes forever to capture. The partition image also gets to be around 20GB.

    Also when deploying a image again containing windows 2008 Server the computer does not recognize the operating system. So when trying to boot a message appear saying “Missing operating system”.

    Is there not a way to resize the file system on a server like there is on a windows 7 computer?

    I’m using a developer branch downloaded 05.03.2015.

  • The kernel does now have support but only basic support of raid though I’m not sure if the init has the dmraid and/or mdadm utilities.

  • Moderator

    Well, that’s an interesting piece of hardware I reckon!! Reading the specs I found this:
    [QUOTE]HW RAID functionality not supported by Linux. Use SW RAID functionality provided in the Red Hat Operating system instead.[/QUOTE]
    Just guessing here but I think you installed linux using software RAID on those two disks! What do you see if you bootup that client (the one you uploaded the image from) and run the following command:
    [CODE]sudo cat /proc/mdstat[/CODE]

    I guess you’ll see RAID related information… software RAID. If PING was able to capture a backup from a software RAID FOG should be able to. AFAIK the kernel used is not compiled with RAID support included so you need to compile your own kernel to make this work! On top of that you might have to modify FOG a little bit to make it detect your RAID array when it comes up…

    Start here: [url]http://fogproject.org/wiki/index.php?title=Building_a_Custom_Kernel[/url]

  • Sorry for the delay on this post. Been testing different things. Thanks for the tips Tom 🙂

    The problem has changed a bit, the issue is not the windows it self. As Tom suggested, setting the image up with windows 7 makes fog resizing as it should, the problem is fake raid. The computer used is a new HP Z440 (also tested on Z420) and I have 2 x 2Tb disks inside. In bios I’ve using raid as sata mode and I’m setting up a raid 1 in the raid settup (pressing ctrl + i before windows boot). This makes a fake raid handled by the bios. When trying to capture a image of this computer fog is recognizing the disks as 2 deperate disks and not a raid. The raid has 3 partitions. This is my test and results:

    First I tried to use image type “single disk - resizable” with partition “everything”. Fog started to capture the computer and everything looked fine. Only 1 disk was backed up with 3 partitions. I assumed this was because fog did recognize the raid, but when trying to deploy the same image to the computer again (I had deleted all data on the hard drives and rebuilt the raid to raid 1) the raid was degraded and only one of the disks contained data. So fog had degraded the raid and written the image to only one disk.

    In my second attempt I used as image type “Multiple partition image - all disks” with partiton “everything”. The computer was setup the same way as on my first attempt. This time fog did take a image from both disks, so the image foldes had a d1p1, d1p2, d1p3 d2p1, d2p2 and a d2p3 file. When trying to deploy the image again after cleaning the hard drives and rebuild the raid again fog only deployed the image to one harddive and this harddrive was kicked out of the raid to a non-raid disk. So rebuilding it was not longer an option.

    I surfed around and found a way to use partimage to see if this could solve my problem. We have earlier used PING which uses partimage and this tool handled raid very well. I enabled IMG_FORMAT_FLAG_IN_GUI option from FOG Configuration->FOG Settings->General Settings after reading a post in this forum. Now I could choose between partclone and partimage. I used partimage in the image setup and tried to capture a image. But partclone was used to capture the image and not partimage.

    So my question will be is there any way to capture and deploy a computer with raid 1 or raid 10 (we are going to use raid 10 in the future)? This has to be done without degrading or destroying the raid.

  • I think putting the os as windows 7 and resize able this would already work, unless you’re doing efi based setup.

  • I’m making a image because we are going to deploy the same server image configuration on a number of computers over a 1-2 year period of time. So I make a default setup of the server then we deploy this image to another server and in 90% of the time we are finished with setting up the server. Only computer names and ip addresses must be added. This is why I must take a image of a computer running server 2008 after syspreped it.

    Any ideas on how to get fog to resize the partitions?

  • I’m new here, my answers will be simple until I learn more stuff about FOG…

    Are you just trying to back up your server, or are you processing several servers at once in order to put them into production?

    Why not use Windows Server Backup? It works great. You can choose the “Backup once…” option. And, this utility was [I]designed[/I] to do complete and total backups of Windows Server. You can then use this to restore to any other windows server running the same version - regardless of hardware.

    FOG was not intended for this use.

    Others might have a better answer…