Can't login to management after saving FOG settings



  • New FOG 1.2 install on Ubuntu workstation 12.04. Have successfully created and deployed images to a test machine.

    After entering my active directory information in the FOG configuration page and saving the changes I was immediately taken back to the sign in page. I re-entered my credentials but the page just refreshed back to the sign in page - no error message or anything. If I intentionally enter wrong credentials it gives me the “Invalid Login” message.

    This happened to me once before when I first setup this FOG server a couple of weeks ago. That time I was changing DNS settings in the FOG configuration pages IIRC. I searched for a solution but was never able to fix it. Since I wasn’t very far along at that time I ended up re-installing.

    I’ve got a lot more invested in it this time and don’t want to re-install. Any ideas?


  • Developer

    Alright, I call this solved (eventhough it really isn’t). We’d be very happy to hear if someone can reproduce this so we are able to fix it. For everyone running into this: see post #39 in this thread on how to solve the issue yourself!


  • Moderator

    So,

    Does anyone care to install Ubuntu 12.04 and apply no updates, then install phpmyadmin and webmin, and then jack around with TFTP and AD passwords?

    NOT ME. I is happily Fedora going. :-)

    I’ll catch the next Fedora bug we find ;-)



  • [quote=“Mark Pickard, post: 44113, member: 609”]I hate to try to break a working server but since it’s a vm I guess it’s not a big deal - just take a snapshot before I do it. So…for the greater good…I’m off to try to crash my server. :)[/quote]

    Installed phpmyadmin and webmin on my working vm after taking a snapshot. Signed in to both to confirm that they’re working. In the FOG web interface I went to FOG Configuration | Active Directory Defaults (this is one of the areas that made it stop working before). I made some changes and then clicked the Save Changes button…and of course it works without any problem. Went down to the TFTP section (which was where it crashed the very first time) and made some changes. Hit the Save Changes button - no problem.

    Couple of observations:
    1.) This vm Ubuntu install (12.04) has current updates installed. My first two that crashed did not.
    2.) Don’t know if the order of install makes any difference (phpmyadmin before webmin or vice versa).

    Gotta love seemingly unrepeatable bugs. :-(



  • [quote=“Uncle Frank, post: 44104, member: 28116”]Thanks for reporting back although I am not happy that at least two people had an issue with this but we are unable to find out why! I have phpmyadmin installed on all my FOG servers so I suspect it to not be the problem. And I’d really wonder if webmin plays a role in this either. But could you still install webmin just to make sure??[/quote]

    I hate to try to break a working server but since it’s a vm I guess it’s not a big deal - just take a snapshot before I do it. So…for the greater good…I’m off to try to crash my server. :-)


  • Developer

    Thanks for reporting back although I am not happy that at least two people had an issue with this but we are unable to find out why! I have phpmyadmin installed on all my FOG servers so I suspect it to not be the problem. And I’d really wonder if webmin plays a role in this either. But could you still install webmin just to make sure??



  • [quote=“Uncle Frank, post: 43753, member: 28116”]Make sure you always have phpmyadmin installed and you’ll be back in the game…

    Can you reproduce this again?? Install phpmyadmin (if not installed already), make changes to your settings till you get locked off. Let yourself in again and try again… We need to reproduce the error to be able to fin a fix![/quote]

    I’ve been using my new setup in the vm without any problems. Have made several changes to the settings without issue. So no, I haven’t been able to reproduce it. :-( But, two things I did not install on the new vm were phpmyadmin and webmin - didn’t need them since I can easily access the server directly through VMware. Don’t know if one of them is maybe the culprit.


  • Senior Developer

    [quote=“Digital Dog, post: 43811, member: 28953”]I appreciate the feedback, however, as you said, I have to remain productive at work. I have been without an imaging server for 3 days now and the customers aren’t going to continue to wait. I have made changes via the web GUI without any issues so far. In order to try to determine which changes are causing the problem, I am saving after each change instead of waiting to save once all changes are done. It’s tedious, but it might help isolate the problem. I will re-post if I experience it again. Thank you all for you assistance.[/quote]

    That shouldn’t really matter. The reason is for all of the save buttons on that page, it saves all entries. The button’s only there to help you know where you last made changes at.



  • [quote=“Wayne Workman, post: 43803, member: 28155”]We need to troubleshoot EXACTLY what change in the web GUI is causing this… wiping/reinstalling (while I understand you need to remain productive at work) does not help us do that.[/quote]

    I appreciate the feedback, however, as you said, I have to remain productive at work. I have been without an imaging server for 3 days now and the customers aren’t going to continue to wait. I have made changes via the web GUI without any issues so far. In order to try to determine which changes are causing the problem, I am saving after each change instead of waiting to save once all changes are done. It’s tedious, but it might help isolate the problem. I will re-post if I experience it again. Thank you all for you assistance.


  • Moderator

    We need to troubleshoot EXACTLY what change in the web GUI is causing this… wiping/reinstalling (while I understand you need to remain productive at work) does not help us do that.



  • [quote=“Tom Elliott, post: 43772, member: 7271”]remove the [/code[ part of the command that was a typo on my side[/quote]

    I made the changes, but it did not resolve the issue. I finally just wiped the server and started over. I’m back in the management portal, but am concerned to make any changes. Does anyone know which items are causing this problem?


  • Senior Developer

    remove the [/code[ part of the command that was a typo on my side



  • [quote=“Tom Elliott, post: 43762, member: 7271”]So you set a password for your mysql?

    Change the code to:
    [code]mysql -u root -p fog[/code[

    Enter the password set for the mysql user. Once in:

    [code]
    update globalSettings set settingValue=‘1’ where settingKey=‘FOG_INACTIVITY_TIMEOUT’;
    exit;[/code][/quote]

    Ok Tom, I’m clearly typing something incorrectly. Received "Unknown database ‘fog[/code[’ I’ve tried several different ways of typing it but no luck.


  • Senior Developer

    So you set a password for your mysql?

    Change the code to:
    [code]mysql -u root -p fog[/code]

    Enter the password set for the mysql user. Once in:

    [code]
    update globalSettings set settingValue=‘1’ where settingKey=‘FOG_INACTIVITY_TIMEOUT’;
    exit;[/code]



  • [quote=“Tom Elliott, post: 43757, member: 7271”][code]mysql -u root fog
    update globalSettings set settingValue=‘1’ where settingKey=‘FOG_INACTIVITY_TIMEOUT’;
    exit;
    [/code][/quote]

    Tom,
    I’m getting a message “Access denied for user ‘root’ @ ‘localhost’ (using password: NO)”.


  • Senior Developer

    [code]mysql -u root fog
    update globalSettings set settingValue=‘1’ where settingKey=‘FOG_INACTIVITY_TIMEOUT’;
    exit;
    [/code]



  • I’m having the same problem. I just finished setting up my first FOG server. I made some changes through the web interface, and now I am unable to log back in. I’ve read the thread, but am uncertain what I need to do. As some of you who helped me earlier know, I’ve only been working with Ubuntu for the past couple of days. I have zero understanding of MySQL. If you can provide some guidance perhaps my situation can help you find a fix. Thanks again.


  • Developer

    [quote=“Mark Pickard, post: 43751, member: 609”]… and how do I make sure it doesn’t happen on my latest VM install?[/quote]
    Make sure you always have phpmyadmin installed and you’ll be back in the game…

    Can you reproduce this again?? Install phpmyadmin (if not installed already), make changes to your settings till you get locked off. Let yourself in again and try again… We need to reproduce the error to be able to fin a fix!


  • Senior Developer

    No idea why it changed to FOG. It’s on a slider so it should only allow the values within the range bar. I’ve added some checkers to the elements for ensuring it’s only ever going to be a numeric value though.



  • [quote=“Uncle Frank, post: 43740, member: 28116”]Alright, I think I found it! It’s one single setting in the ‘globalSettings’ table…

    Go to phpmyadmin, select ‘fog’ database, then ‘globalSettings’, find the value with ID ‘106’ and name ‘FOG_INACTIVITY_TIMEOUT’. I guess it is set to ‘fog’ (at least it was in the dump). Change it to ‘1’ (one) and you should be able to login again…

    The rest is up to Tom I am afraid as I don’t know the web interface enough to see where this could happen. You said that it happended twice when you changed settings… Maybe Tom has an idea!?

    But I am still wondering why this is only happening to you?! So many people out there using it and I’ve never seen anyone reporting this. How come??[/quote]

    That’s it! Bonus points for Uncle Frank!! Changed the FOG_INACTIVITY_TIMEOUT value to a 1 and got right in.

    Yes, both times this has happened (on two separate installations) I was changing settings on the FOG configuration page at /fog/management/index.php?node=about&sub=settings. Once it was AD settings and the other it was TFTP settings. As soon as I hit the “Save Changes” button it booted me back to the sign in page and from that point I could never sign back in. Previous to that I had changed other settings without any problems. And on my latest install (in a VM) I’ve been changing settings without issue too.

    Uncle Frank, thanks for the help and for sticking with me on this.

    Tom, any idea why this happened and how do I make sure it doesn’t happen on my latest VM install?


Log in to reply
 

517
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.