Problem with 'permission denied' after FOG server restart



  • Hello again, I have been using FOG for about a month or so with great success. I have uploaded about 30 different images to the server without a problem…until now.

    I restarted the FOG server to install an internal back-up drive. I received the TFTP timeout, but then remembered to restart tftpd-hpa which resolved that issue.

    I was able to register a new host, but now receive “Permission Denied” on the host when attempting to mount the /images folder on the server.

    Most issues I see with this are when people move their /images folder to a different location. I have not made any changes other than the drive (which I have not mounted) and the restart.

    I have tried a few fixes with no luck.

    So far I have made sure the firewall is turned off, and /etc/exports looks like this…

    /images *(ro_sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

    This is on Ubuntu 14.04 with FOG 1.2.0

    Again, this has been running well until the restart. Being so new to this, is there anything else I should check that a restart may have done?

    Thank you again for your help!

    [url="/_imported_xf_attachments/1/1716_IMAG2053.jpg?:"]IMAG2053.jpg[/url]



  • Thanks Tom! That did it!

    I had database issues with the restart, though. It wanted me to update the database (as during initial installation) and when I clicked it, I received a long list of errors due to the database already being there. I followed some of the fixes on modifying the config.class.php and .fogsettings with no luck. I re-installed FOG which required me to do some dnsmasq changes as well. FOG is working again, but I’ll continue to restart and try more fixes.

    Thanks again!!!


  • Senior Developer

    Before restart,

    Make sure the port=0 is not commented otherwise dnsmasq tries to act as the dns provider which is likely what is your internet problem.



  • I have finished the re-install and so far so good! I am both capturing and deploying images, even the laptop I initially noticed the problem with is taking the restored-from-back-up image.

    I am currently restoring the rest of the images and will test more tomorrow. I will even restart the FOG server and hope this doesn’t happen again! Haha!

    At this time, I think all of the ‘fixes’ for me trying to get the original TFTP timeout issue resolved (before I tried dnsmasq) may be the cause for this. With my inexperience with Linux I was trying what worked for others without actually knowing what I was changing.

    The only issue I seem to have now is after I installed dnsmasq, I can no longer browse the internet. It’s a dns issue, for sure, as I can ping IPs, just not names. This also was happening before I re-installed. I’ll work that issue out with the dnsmasq peeps.

    I will update after the re-start!



  • Ahh, my fault, sorry, I was typing with my head over my shoulders. Here is an actual copy/paste of the etc/exports

    /images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

    I too, don’t like re-installing as we never find out the cause. However, another install would help my experience doing so, and doing a fresh setup knowing I will need to use dnsmasq would be good for me as well.

    I’ve got a back-up of all the created images anway, which makes it even less of a hassle.

    I certainly appreciate all of the awesome help you’ve provided!

    I will update after I get the install complete.


  • Senior Developer

    The fsid isn’t always needed, but some OS’s require it as a “priority” ordering of sorts. It doesn’t hurt TO have them, but it also doesn’t hurt to not have them.


  • Developer

    Hmmmm. I personally don’t like reinstalling just for gods sake. Might fix it but you’ll never know why… If that’s ok with you give it a go!

    But before that please check your /etc/exports again. I am very sorry to say this but I checked the code from your very fist post character by character just now. Yours looks like this (is that correct???):
    [CODE]/images *(ro_sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)[/CODE]

    But on my system it looks like this:
    [CODE]/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2)[/CODE]

    See the differences?? ‘ro_sync’ should definitely be ‘ro,sync’ and I guess those ‘fsid’ parameters at the end are there for a reason too!



  • It is a head scratcher, for sure! Do you think a re-install is in order at this point?


  • Developer

    Looks pretty good! I just don’t understand why you don’t see this when connecting with NFS…



  • Hmm, I seem to have some issue with getting the info posted. I cannot attach the plain text file, and when I try to post as I have been posting, it says it is spam. :/

    Here is the output of what I am able to get by the spam filter. It basically continues down listing each of the images similar to the “VEIGoldenImage” and “VEIUbuntu1404x647010” files below.

    @VEI-FOG:~# ls -alR /images
    /images:
    total 92
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 .
    drwxr-xr-x 25 root root 4096 Feb 10 11:04 …
    drwxrwxrwx 2 root root 4096 Mar 5 11:07 dev
    -rwxrwxrwx 1 root root 0 Feb 25 16:36 .mntcheck
    drwxrwxrwx 2 root root 4096 Feb 10 11:04 postdownloadscripts
    drwxrwxrwx 2 root root 4096 Feb 19 15:25 PRC04
    drwxrwxrwx 2 root root 4096 Feb 18 17:08 VEIGoldenImage
    drwxrwxrwx 2 root root 4096 Mar 5 10:38 VEIUbuntu1404x647010
    drwxrwxrwx 2 root root 4096 Feb 12 14:21 VEIWin75520Laptop
    drwxrwxrwx 2 root root 4096 Feb 11 14:41 Win76430
    drwxrwxrwx 2 root root 4096 Feb 12 14:08 Win7Accounting
    drwxrwxrwx 2 root root 4096 Feb 16 16:47 Win7Acer4620Laptop
    drwxrwxrwx 2 root root 4096 Feb 13 11:20 Win7BaseImage
    drwxrwxrwx 2 root root 4096 Feb 13 12:07 Win7CivilDesigner
    drwxrwxrwx 2 root root 4096 Feb 12 15:32 Win7CivilEngineer
    drwxrwxrwx 2 root root 4096 Feb 16 17:09 Win7CostControls
    drwxrwxrwx 2 root root 4096 Feb 12 15:38 Win7IEwCAD
    drwxrwxrwx 2 root root 4096 Feb 12 15:28 Win7InstrumentElectrical
    drwxrwxrwx 2 root root 4096 Feb 16 14:12 Win7Mechanical
    drwxrwxrwx 2 root root 4096 Feb 18 15:10 Win7PipingwCAD
    drwxrwxrwx 2 root root 4096 Feb 12 15:25 Win7Process
    drwxrwxrwx 2 root root 4096 Feb 12 15:49 Win7ProjectControls
    drwxrwxrwx 2 root root 4096 Mar 5 10:55 Win7TestImage
    drwxrwxrwx 2 root root 4096 Feb 19 09:06 Win7ZboxAcer

    /images/dev:
    total 8
    drwxrwxrwx 2 root root 4096 Mar 5 11:07 .
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 …
    -rwxrwxrwx 1 root root 0 Feb 25 16:38 .mntcheck

    /images/postdownloadscripts:
    total 12
    drwxrwxrwx 2 root root 4096 Feb 10 11:04 .
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 …
    -rwxrwxrwx 1 root root 233 Feb 10 11:04 fog.postdownload

    /images/PRC04:
    total 56336000
    drwxrwxrwx 2 root root 4096 Feb 19 15:25 .
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 …
    -rwxrwxrwx 1 root root 512 Feb 19 15:24 d1.mbr
    -rwxrwxrwx 1 root root 78557 Feb 19 15:24 d1p1.img
    -rwxrwxrwx 1 root root 192215879 Feb 19 15:25 d1p2.img
    -rwxrwxrwx 1 root root 57495742045 Feb 19 16:54 d1p3.img

    /images/VEIGoldenImage:
    total 12590772
    drwxrwxrwx 2 root root 4096 Feb 18 17:08 .
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 …
    -rwxrwxrwx 1 root root 1 Feb 18 16:55 d1.fixed_size_partitions
    -rwxrwxrwx 1 root root 0 Feb 18 16:58 d1.has_grub
    -rwxrwxrwx 1 root root 1048576 Feb 18 16:58 d1.mbr
    -rwxrwxrwx 1 root root 259 Feb 18 16:58 d1.minimum.partitions
    -rwxrwxrwx 1 root root 15 Feb 18 16:55 d1.original.fstypes
    -rwxrwxrwx 1 root root 259 Feb 18 16:55 d1.original.partitions
    -rwxrwxrwx 1 root root 0 Feb 18 16:55 d1.original.swapuuids
    -rwxrwxrwx 1 root root 8141788569 Feb 18 17:08 d1p1.img
    -rwxrwxrwx 1 root root 4750076687 Feb 18 16:31 VEIGoldenImage

    /images/VEIUbuntu1404x647010:
    total 1788480
    drwxrwxrwx 2 root root 4096 Mar 5 10:38 .
    drwxrwxrwx 23 root root 4096 Mar 5 11:07 …
    -rwxrwxrwx 1 root root 4 Mar 5 10:34 d1.fixed_size_partitions
    -rwxrwxrwx 1 root root 0 Mar 5 10:34 d1.has_grub
    -rwxrwxrwx 1 root root 1048576 Mar 5 10:34 d1.mbr
    -rwxrwxrwx 1 root root 310 Mar 5 10:34 d1.minimum.partitions
    -rwxrwxrwx 1 root root 48 Mar 5 10:34 d1.original.fstypes
    -rwxrwxrwx 1 root root 310 Mar 5 10:34 d1.original.partitions
    -rwxrwxrwx 1 root root 47 Mar 5 10:38 d1.original.swapuuids
    -rwxrwxrwx 1 root root 1830317087 Mar 5 10:38 d1p1.img
    -rwxrwxrwx 1 root root 551 Mar 5 10:38 d1p2.img


  • Developer

    Seems like there are no images being saved when you upload them. Maybe the are not moved. When you upload an image it’s first saved to /images/dev/<image-name> and moved to /images/<image-name> when it’s finished. Please run this command on the server ‘ls -alR /images’ and post the output.



  • Below are the results of the commands.

    root@VEI-3000D:/home/administrator# sudo mkdir -p /mnt/nfstest && sudo mount -v 10.0.2.250:/images /mnt/nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount.nfs: timeout set for Thu Mar 5 08:41:21 2015
    mount.nfs: trying text-based options ‘vers=4,addr=10.0.2.250,clientaddr=10.0.2.153’

    root@VEI-3000D:/home/administrator# sudo ls -al /mnt/nfstest
    total 12
    drwxrwxrwx 22 root root 4096 Feb 27 09:45 .
    drwxr-xr-x 3 root root 4096 Mar 5 08:37 …
    drwxrwxrwx 2 root root 4096 Feb 19 16:54 dev

    root@VEI-3000D:/home/administrator# sudo umount /mnt/nfstest
    root@VEI-3000D:/home/administrator#

    Oddly enough, I have done some testing and I am able to capture images via FOG. However, I receive the ‘permissions denied’ error any time I try to deploy an image using various workstations and images. Any ideas on why this is happening?

    Thanks again!


  • Developer

    Are you sure you still get the same error when booting into FOG??

    From what I can see NFS seems to be alright. But please run another test:
    [CODE]sudo mkdir -p /mnt/nfstest && sudo mount -v 10.0.2.250:/images /mnt/nfstest
    sudo ls -al /mnt/nfstest
    sudo umount /mnt/nfstest[/CODE]



  • My fog servers IP is 10.0.2.250

    Yes! There is now a difference with those commands. They seem to be working now! (I did have to install nfs-common on the workstation).

    root@VEI-3000D:/home/administrator# sudo mkdir -p /mnt/nfstest && mount -v 10.0.2.250:/images /mnt/nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount.nfs: timeout set for Wed Mar 4 11:14:44 2015
    mount.nfs: trying text-based options ‘vers=4,addr=10.0.2.250,clientaddr=10.0.2.153’

    root@VEI-3000D:/home/administrator# sudo umount /mnt/nfstest

    root@VEI-3000D:/home/administrator# sudo mount -v 10.0.2.250:/images/dev /mnt/nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount.nfs: timeout set for Wed Mar 4 11:15:30 2015
    mount.nfs: trying text-based options ‘vers=4,addr=10.0.2.250,clientaddr=10.0.2.153’

    root@VEI-3000D:/home/administrator# sudo umount /mnt/nfstest && rmdir /mnt/nfstest
    root@VEI-3000D:/home/administrator#


  • Senior Developer

    It’s a default to set /images or whatever value you type in.



  • [quote=“Uncle Frank, post: 42937, member: 28116”]Who would’ve thought that it were wrong entries in /etc/exports… Sounds a bit like you hit the wrong keys when installing FOG. When the installer asked for the path you gave ‘y’ for ‘yes’ maybe…[/quote]

    Well I actually just used the script I had posted in these forums that I made when .33b was still the dev.
    I guess something changed in the installer for the images path not defaulting to /images with a y?


  • Developer

    Was probably pretty late when I wrote this post… My fault, shoud be like this:
    [CODE]mkdir -p /mnt/nfstest && mount -v 10.0.2.250:/images /mnt/nfstest
    umount /mnt/nfstest
    mount -v 10.0.2.250:/images/dev /mnt/nfstest
    umount /mnt/nfstest && rmdir /mnt/nfstest[/CODE]
    Can you see the difference? By the way… what is the IP address of your FOG server?

    [B]And please make sure that ‘nfs-common’ (debian/ubuntu) or ‘nfs-utils’ and ‘nfs-utils-lib’ (centos) packages are installed before you try this!![/B]



  • Alright, from a workstation on the same subnet I tried the commands you listed…here are the results.

    root@VEI-3000D:~# sudo mkdir -p /mnt/nfstest && mount -v 10.0.2.250:/images /nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount: mount point /nfstest does not exist

    root@VEI-3000D:~# sudo umount /nfstest
    umount: /nfstest: not found

    root@VEI-3000D:~# sudo mount -v 10.0.2.250:/images/dev /nfstest
    mount: no type was given - I’ll assume nfs because of the colon
    mount: mount point /nfstest does not exist

    root@VEI-3000D:~# umount /nfstest && rmdir /nfstest
    umount: /nfstest: not found

    And, just for further testing to eliminate the folder not being there, I tried to mount to the /images folder.

    root@VEI-3000D:~# sudo mount -v 10.0.2.250:/images
    mount: can’t find 10.0.2.250:/images in /etc/fstab or /etc/mtab
    root@VEI-3000D:~#

    Thank you again for your help!!!


  • Developer

    Who would’ve thought that it were wrong entries in /etc/exports… Sounds a bit like you hit the wrong keys when installing FOG. When the installer asked for the path you gave ‘y’ for ‘yes’ maybe…



  • Well I feel dumb,
    I just had to edit the etc/exports file after updating to say
    /images …
    and
    /images/dev…
    instead of
    y…
    and
    y/dev…

    Not sure why it changed itself to y as the images directory, it looks like everything is working now. Thanks again for all your help.

    Thanks,
    -JJ


Log in to reply
 

397
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.