Latitude 3540 Freezes During Upload



  • I have a latitude 3540 that is running on Win 7 and the server is running on Ubunto. We are running FOG .32 and every time I try to upload an image it freezes. We have restarted the server a few times with thinking that either an image was “stuck” or something else was processing and causing the issue. We read through many threads and thought it could be a kernel issue but no one has stated how to fix it on Ubunto only on Windows.


  • Developer

    Interesting. Seems like it does not match the md5sum anymore. Not sure which kernel image this is but I downloaded 3.19.1.x and 3.19.0.x and non of the md5sums match! Please rnu this commands too:
    [CODE]$ file -k bzImage

    $ ls -al bzImage
    …[/CODE]



  • Thank you for your help. This is the output:
    [FONT=Times New Roman][COLOR=#000000]administrator@casper:~$ [/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]administrator@casper:~$ tftp 10.10.0.235[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]tftp> get pxelinux.cfg/01-34-17-eb-83-ef-ed[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]tftp> get fog/kernel/bzImage[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]tftp> quit[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]administrator@casper:~$ md5sum bzImage[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]84ec62da9fac76ed9588fce6abd8fb8c bzImage[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]administrator@casper:~$ cat 01-34-17-eb-83-ef-ed[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]# Created by FOG Imaging System[/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000] DEFAULT send[/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000] LABEL send[/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000] kernel fog/kernel/bzImage[/COLOR][/FONT]

    [FONT=Times New Roman][COLOR=#000000] append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.10.26.8 type=up img=SBHSRobotics imgid=78 mac=34:17:eb:83:ef:ed storage=10.10.0.235:/images/dev/ web=10.10.0.235/fog/ ignorepg=1 osid=5 pct=5 imgType=nadministrator@casper:~$ ^C[/COLOR][/FONT]
    [FONT=Times New Roman][COLOR=#000000]administrator@casper:~$ [/COLOR][/FONT]


  • Developer

    Please try the following from a linux client within your subnet:
    [CODE]$ tftp 10.10.0.235
    tftp> get pxelinux.cfg/01-34-17-eb-83-ef-ed
    tftp> get fog/kernel/bzImage
    tftp> quit
    $ md5sum bzImage

    $ cat 01-34-17-eb-83-ef-ed
    …[/CODE]
    Please post the output…


  • Developer

    Do I get this right? You were never ever able to boot FOG (upload or download) on this Latitude 3540? Could you please download ubuntu live cd (or any other live cd really) and try booting this. Just to make sure.

    Others made it work in the past:
    [url]http://fogproject.org/forum/threads/dell-latitude-3540-fails-with-kernel-3-8-8.10224/[/url]
    But there is another thread talking about issues on this model:
    [url]http://fogproject.org/forum/threads/pxe-menu-not-loading-on-latitude-3540.12519/[/url]

    Hope we can get this to work at some point.



  • This is the first part [ATTACH=full]1794[/ATTACH]and this is the second part
    [ATTACH=full]1795[/ATTACH]

    [url="/_imported_xf_attachments/1/1794_Screen%20shot%202015-03-18%20at%2010.22.31%20AM.png?:"]Screen%20shot%202015-03-18%20at%2010.22.31%20AM.png[/url][url="/_imported_xf_attachments/1/1795_Screen%20shot%202015-03-18%20at%2010.25.42%20AM.png?:"]Screen%20shot%202015-03-18%20at%2010.25.42%20AM.png[/url]


  • Senior Developer

    Not to sound crude or anything but I think we need more details than just it didn’t work can you provide a screenshot of trying to boot using one of Lee’s kernels or even a video?



  • Is there anything else you would suggest?



  • We tried both and neither one worked.


  • Senior Developer

    Well I am Tom Elliott.

    When you first tried did you try the Kernel.TomElliott.3.19.0.32 or the Kernel.TomElliott.3.19.0.64

    If either one or the other, can you try the :
    Kernel.TomElliott.3.19.1.32 (if you’re still running 0.32)



  • I’m using the kernel that Tom Elliot suggested. After using that kernel I got the message “Invalid or corrupt kernel image. boot:” Uncle Frank ask about the md5sum and we were just confirming that we did get the same response that he stated above. At the moment we still can’t upload an image and now are more confused than ever. We are not really sure what direction we should be going so any advice would greatly be appreciated.


  • Senior Developer

    I’m confused.

    What has been tried?

    You’re using a different kernel? If so, you shouldn’t be seeing anything about uvesa_fb or more than 8 outputs detected.



  • Should I reconfigure the whole server?



  • yes it does.


  • Developer

    [quote=“Clifford Raymond, post: 43552, member: 28730”]You are correct, I do see the same message. What does it mean when the file is corrupt? Do we have to reconfigure the whole server?[/quote]
    What do you mean by “same message”??? Does the kernel image have the same md5sum??



  • You are correct, I do see the same message. What does it mean when the file is corrupt? Do we have to reconfigure the whole server?


  • Developer

    Sounds a bit like the file is corrupted. md5sum??
    [CODE]$ md5sum Kernel.TomElliott.3.19.0.32
    1c47679f256378dee6a673d20e766d31 Kernel.TomElliott.3.19.0.32[/CODE]

    If you see a different md5sum you should re-download it. If you see the same it might be broken on the server (corrupt upload)…



  • Thank you so much for your help but now I get a message that says “Invalid or corrupt kernel image. boot:” I also made sure that the bzimage was not duplicated. The previous version is saved in different folder on the desktop.


  • Testers

    I generally get the latest ks or kitchen sink version when running .32 but I just saw Tom’s reply go with his for sure.


  • Senior Developer

    As you’re running 0.32,

    I’d recommend getting the new kernel as such:

    [code]sudo wget http://mastacontrola.com/fogboot/kernel/Kernel.TomElliott.3.19.0.32 -O /tftpboot/fog/kernel/bzImage[/code]


 

404
Online

41.8k
Users

12.3k
Topics

116.0k
Posts