Change langage keyboard on boot for password and full inventory



  • Hi,
    i try to install fog (1.2.0) in my enterprise to replace my actually’s deploiement infrastructure.

    I have search with no result how to change the langage (in french) to the boot interface to write lgin and passord or write registred information.

    If anyone can help me. i have try to enter many exemple in Fog setting /general informations/FOG_KEYMAP but without result! (fr_FR.utf.8, fr.kdb. fr-latin9, …)

    Many thanks !

    G.


  • Developer

    Check the following header file in the ipxe source directory: ipxe/src/config/general.h

    You’ll see some lines with ‘define’ there. Some have ‘//’ at the beginning which means that those options are not being compiled into the ipxe binary! Remove those two slashes in front of PARAM_CMD (and possible some other options too):

    [CODE]…
    #define AUTOBOOT_CMD /* Automatic booting /
    #define NVO_CMD /
    Non-volatile option storage commands /
    #define CONFIG_CMD /
    Option configuration console /
    #define IFMGMT_CMD /
    Interface management commands /
    //#define IWMGMT_CMD /
    Wireless interface management commands /
    //#define FCMGMT_CMD /
    Fibre Channel management commands /
    #define ROUTE_CMD /
    Routing table management commands /
    #define IMAGE_CMD /
    Image management commands /
    #define DHCP_CMD /
    DHCP management commands /
    #define SANBOOT_CMD /
    SAN boot commands /
    #define MENU_CMD /
    Menu commands /
    #define LOGIN_CMD /
    Login command /
    #define SYNC_CMD /
    Sync command /
    #define NSLOOKUP_CMD /
    DNS resolving command /
    #define TIME_CMD /
    Time commands /
    #define DIGEST_CMD /
    Image crypto digest commands /
    #define LOTEST_CMD /
    Loopback testing commands /
    #define VLAN_CMD /
    VLAN commands /
    #define PXE_CMD /
    PXE commands /
    #define REBOOT_CMD /
    Reboot command /
    #define POWEROFF_CMD /
    Power off command /
    #define IMAGE_TRUST_CMD /
    Image trust management commands /
    #define PCI_CMD /
    PCI commands /
    #define PARAM_CMD /
    Form parameter commands /
    #define NEIGHBOUR_CMD /
    Neighbour management commands /
    #define PING_CMD /
    Ping command /
    #define CONSOLE_CMD /
    Console command /
    #define IPSTAT_CMD /
    IP statistics commands /
    //#define PROFSTAT_CMD /
    Profiling commands */

    [/CODE]
    Then compile again, copy the new binary to /tftpboot, check file permissions and boot up the client…



  • Thank you, now the compilation is ok.
    But with my new undionly.ipxe file, I have a boot error:

    [url="/_imported_xf_attachments/1/1826_fog.PNG?:"]fog.PNG[/url]


  • Senior Developer

    You building on ubuntu/debian, or Centos?

    Either way, you need install the liblzma package on your system. I think it was done with
    [code]apt-get install liblzma-dev[/code]



  • Hi,

    The command “make bin/{undionly,ipxe}.{,k,kk}pxe EMBED=ipxescript” finish by:

    [HOSTCC] util/zbin
    util/zbin.c:7:18: fatal error: lzma.h: No such file or directory
    #include <lzma.h>

    compilation terminated.
    make: *** [util/zbin] Error 1


  • Moderator

    [quote=“geicos, post: 43844, member: 28277”]Hi,

    I think it is necessary to Building a custom undionly.kpxe file .
    See: [url]http://www.fogproject.org/wiki/index.php/Building_undionly.kpxe[/url]
    Change in config/console.h :
    define KEYBOARD_MAP us
    to
    define KEYBOARD_MAP fr

    But I have a compilation error at the end of the procedure.[/quote]

    Can you post the error?



  • Hi,

    I think it is necessary to Building a custom undionly.kpxe file .
    See: [url]http://www.fogproject.org/wiki/index.php/Building_undionly.kpxe[/url]
    Change in config/console.h :
    define KEYBOARD_MAP us
    to
    define KEYBOARD_MAP fr

    But I have a compilation error at the end of the procedure.


  • Developer

    Hi,
    the setting FOG_KEYMAP is used to tell the kernel to use this keymap. See kernel command line options for more details but in my case simply ‘de’ is working. It’s not perfect as german Umlauts are not working but at least the rest is working great. So in your case you’d have to set FOG_KEYMAP to ‘fr’…

    Not sure if this setting also makes a difference for FOG login and password … anyone has a clue? Or just give it a try.


Log in to reply
 

361
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.