Can't complete the fog install!



  • Hi there,
    i’ve been trying for hours now to install fog 1.2.0 by following the instructions at [url]http://www.fogproject.org/wiki/index.php/Installation_on_Debian_Lenny[/url]
    because my OS is Debian Wheezy.

    I’ve installed MYSQL with and without password and either way I can’t get into the fog management page at the address which the fog install script gave me to use - it just shows “connecting” for a long while then time out.

    I actually installed mysql-server first before fog script ran, and in its conf file /etc/mysql/my.cnf I # out the bind-address, as the only way for the service to start.

    what should I be looking at as solution to getting into fog management? it appears apache and mysql are running ok. … thanks



  • Right, you both confirmed what I’d seen about interface.

    Concerning ip add change, the only file I can’t find is the pxe file. Its not in /tftpboot.

    So to fix this whole thing i edited the .fogsetings file and I ran the fog install script again to set the ip address to my static one, as the last time I had used the automatic ip.

    After that the client could register! Actually, there’s a list of correct things to do in the installation.txt file that I hadn’t read before, about setting static ip before install of fog. Perhaps the user guide should mention that file?

    Thanks guys for this software…. We are donating 100s of computers to villages in the malayan jungle so fog is crucial.



  • Right, you both confirmed what I’d seen about interface.

    Concerning ip add change, the only file I can’t find is the pxe file. Its not in /tftpboot.

    Can I run the fog install script again to set the ip add?



  • Right, you both confirmed what I’d seen about interface.

    Concerning ip add change, the only file I can’t find is the pxe file. Its not in /tftpboot.

    Can I run the fog install script again to set the ip add?


  • Developer

    Yes I think Tom is right. You need to have a look at your network configuration. I’d suggest to have the config ‘/etc/network/interfaces’ like this:
    [CODE]auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.255.0[/CODE]
    You don’t need the gateway statement if you are in an isolated network without connection to the internet. [B]Please make sure you have ‘eth0’ and ‘lo’ configured as some linux services really need that loopback interface!!![/B]
    Reboot your machine and check your network settings:
    [CODE]# ifconfig
    eth0 Link encap:Ethernet Hardware Adresse 00:1f:16:0c:32:50
    inet Adresse:192.168.1.1 Maske:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1

    lo Link encap:Lokale Schleife
    inet Adresse:127.0.0.1 Maske:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metrik:1
    …[/CODE]


  • Senior Developer

    my only guess, as you’re 127.0.0.1 is always Loop back.

    It’s also known as localhost.

    You setting the auto lo to auto eth0 is incorrect.

    All auto lo does is start the loopback interface.

    you can keep the lo interface from starting and only get the information from eth0 start start, but you need to statically set the IP and ifnormation for it.

    How to do this is a little vague to be due to it being ubuntu/debian derivative. I believe you have to edit the auto eth0 to somethign like:

    /etc/network/interfaces
    [code]auto eth0
    iface eth0 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    gateway 192.168.1.254
    [/code]

    Then restart the system.

    As far as I can tell the interface needs to be established before the other parts of the gui will work.



  • so sorry, that prob wasn’t sarcasm on your part, now I see your yeah as like I’m heading in the right direction.

    so I can connect to 127.0.0.1/fog but still not 192.168.1.1 which I changed to in fog UI

    maybe that doesn’t matter??



  • alright then so thats just contacting the internet? if im unplugged it says server not found and I thought I needed the server!

    Pls save me your sarcasm and look at my posts above. I need to set up isolated server. Are you really unwilling to offer help here?


  • Senior Developer

    Yeah

    That’s expected. The contacting stuff goes out to the internet. If you unplug, you’re no longer on the internet.



  • I changed the IP as the guide shows, then restarted apache service

    I login with [url]http://127.0.0.1/fog/[/url]

    then it states Error contacting server - but that is with the ethernet internet pulled out

    when I plugin again there’s “Estimated FOG sites: [B]4875”[/B]



  • Hi, I need some one to answer my question, if they could be a little patient!

    My fog server IP was set up by the install script as [url]http://192.168.0.129[/url]

    That was made because of connected to internet.

    Now I want to go on isolated network, so how do I change the IP address? what to?

    Note that installing using “isolated network” guide failed to let me connect to fog UI page.

    OK, I can see the guide how to change the IP, in the fog settings, but I can’t find those other files to make changes.

    can I use [url]http://192.168.1.1/[/url] ? but does the server IP need to change first? How do I do that??? I need step by step as I’m really tired!

    Tahnks



  • So, if I use the automatic IP which the fog install script gives me, I can connect to the fog page.

    But what do I do later on when I take the server off the internet/change network ??



  • I’m back again because, although I got to the fog management page, once I shifted the server off the internet, I couldn’t get there any more.

    I really don’t understand IP settings much. When I ran the installer today, I answered yes to the suggested IP addresses, and got on, then move the pc to where we are making the network and couldn’t get into fog anymore.

    I since found the user guide for installing for an isolated network and there it says to put in a static IP, and answer no to the next two IP questions. [url]http://www.fogproject.org/wiki/index.php/FOG_on_an_Isolated_Network[/url]

    But with that method, I couldn’t get into the fog page.



  • Today I re-installed Debian, and ran the fog install script - this time Mysql had no issue starting and I reached the fog management page.
    the only thing I can think of last time that I had changed before installing fog was interfaces, I changed auto lo to auto eth0



  • This morning, apache log does not report an error when trying to connect to fog management, only this

    [Thu Feb 12 10:02:31 2015] [notice] Apache/2.2.22 (Debian) PHP/5.4.36-0+deb7u3 configured – resuming normal operations

    [CODE]sudo lsof -i :80
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    chromium 4655 fog 155u IPv4 33318 0t0 TCP debian.local:46894->a125-252-236-186.deploy.akamaitechnologies.com:http (CLOSE_WAIT)
    apache2 9661 root 3u IPv4 32521 0t0 TCP *:http (LISTEN)
    apache2 9681 www-data 3u IPv4 32521 0t0 TCP *:http (LISTEN)
    apache2 9682 www-data 3u IPv4 32521 0t0 TCP *:http (LISTEN)
    apache2 9683 www-data 3u IPv4 32521 0t0 TCP *:http (LISTEN)
    apache2 9684 www-data 3u IPv4 32521 0t0 TCP *:http (LISTEN)
    apache2 9685 www-data 3u IPv4 32521 0t0 TCP *:http (LISTEN)[/CODE]

    [CODE]sudo netstat -lnp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 3601/mysqld
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1857/rpcbind
    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 9661/apache2
    …[/CODE]



  • I’m back, @wolf
    I said that i didn’t just cut and paste that install line for fog 0.32, I downloaded 1.2.0 from big bold link on the fog home page. That 0.32 no longer exists anyways!

    My problems: 1. Mysql failed to start during fog install… solution: I comment out bind-address

    1. Cannot get to the fog management page when prompted to… Apache error log reports not connecting on 80
      So I need a solution to this… it might be apache or mysql password - but I just installed mysql with blanks.

    Thanks


  • Developer

    If you copied and pasted the exact information in that install guide that means you copied the example that was 0.32. Please see that wiki again after the resent update. It should be more clear.

    [url]http://fogproject.org/wiki/index.php/Installation_on_Debian_Lenny[/url]



  • thanks Tom, for doing your best to help, I’ve gotta go, its 2.37am here.



  • Ok, no I didn’t copy the exact command that is on that page, because I know fog has developed pretty fast over 2014, so I downloaded straight from the link to sourceforge, the tar.gz, fog 1.2.0


  • Senior Developer

    Look,

    I’m trying to help, but I’m not getting very far. I know I’m coming off rude, but I’m trying to understand where you got the ideas to try the “tricks” you’ve tried while you’re blatently missing the idea of how to install fog following the “official” documentation.

    FOG 1.x.x is fairly new and I’m the “new kid” on the block for the developement of anything 1.x.x and potentially further.

    When I’m tryign to make suggestions it is in all honesty an attempt to assist a person out.

    I really do want to know what and how you came to the troubleshooting things you did.

    But to further add to my confusion:

    If the guide (our official documentation as you put it) tells you to download 0.32 and install it using the following instructions, where do you get downloading something COMPLETELY different and attempting to install it?


Log in to reply
 

361
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.