PXE Boot menu



  • Hi,

    i have a problem with my pxe boot menu, only acronis works, but id didn’t know why.

    greez domi

    http://${fog-ip}/fog/iso/Win7aio.iso

    chain memdisk iso raw ||

    goto MENU

    :Win8

    initrd http://${fog-ip}/fog/iso/Win81.iso

    chain memdisk iso raw ||

    goto MENU

    :acronis2013

    initrd http://${fog-ip}/fog/iso/acronis.iso

    chain memdisk iso raw ||

    goto MENU

    :gparted

    initrd http://${fog-ip}/iso/gparted.iso

    chain memdisk iso raw ||

    goto MENU

    :clonezilla

    initrd http://${fog-ip}/iso/clonezilla.iso

    chain memdisk iso raw ||

    goto MENU

    :hirens

    initrd http://${fog-ip}/iso/hirensbootcd.iso

    chain memdisk iso raw ||

    goto MENU

    :ubcd
    initrd http://${fog-ip}/iso/ultimatebootcd.iso

    chain memdisk iso raw ||

    goto MENU

    :shell

    shell ||

    goto MENU

    :hostinfo

    echo ||

    echo ||

    echo This computer : ||

    echo MAC address…${net0/mac} ||

    echo IP address…${ip} ||

    echo Netmask…${netmask} ||

    echo Serial…${serial} ||

    echo Asset number…${asset} ||

    echo Manufacturer…${manufacturer} ||

    echo Product…${product} ||

    echo BIOS platform…${platform} ||

    echo ||

    echo Zurueck mit beliebiger Taste ||

    prompt

    goto MENU

    :image1

    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.178.54 web=${fog-ip}/fog/ consoleblank=0 loglevel=4 type=down img=test ftp=${fog-ip} imgType=n osid=7 storage=${fog-ip}:/images capone=1 imgFormat=2

    imgfetch init.xz

    boot || goto MENU

    :return

    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||

    prompt

    goto MENU

    autoboot[/QUOTE]



  • and how that works?


  • Senior Developer

    While iPXE is handy and somewhat neat to make your life a little easier, I’m willing to bet you’d run into similar issues even if you used the old pxelinux.cfg menu system.

    Some of the iso’s can operate just fine being fully loaded and directly as such. However, actual OS discs, especially those that run live cd’s it seems, don’t like the approach of loading the entire disk and booting from it in ram. This isn’t because of something FOG is doing wrong, but rather how the cd was created. The ISO is actually, once loaded, trying to locate itself from within the CD it was booted from. Because it cannot find this, it cannot boot further. The way to boot these in such ways is to extract the information of the CD/DVD and mount using it’s respective vmlinuz/bzImage and init/initrd files.



  • anyone idea?



  • !



  • @domii666, post: 42121, member: 24204 said:

    false screenshot, no raspbian :O

    :oops:oh! , that would be cool if that could work as like some type of mobile Fog-IT-Tool or something a long them lines anyhow don’t wanna hijack this threads or take it off of it’s maiden voyage :p

    [B]domii666 [/B]I like the boot menu you are working on.



  • ram 8gb.

    false screenshot, no raspbian :O



  • :eek: … rasbian? as a fog server? that works? o_O that never come to mind for me! Hmmm:cool:


  • Developer

    how much ram do you have in the target computer? memdisk iso raw tries to load the entire iso into ram. also, is that a screenshot of rasbian? that’s not normally even compiled to be compatible with x86 or x86_64 systems



  • now, every iso is loading, but win7 isnt.

    win8.1 works,nice! ultimatebootcd works, also, but the others wont. here the errors.

    !

    !


  • Developer

    your Win81.iso needs to be changed to win81.iso to match your actual file name, too


  • Senior Developer

    The problem is how you’re calling the ISOs.

    You’re not calling the web-root. Try this:

    :MENU
     
    menu
     
    item --gap -- ----------------- VS Boot Menu -----------------
     
    item gap
     
    item bootlocal Festplatte booten
     
    item --gap Image installieren
     
    item --key 1 image1 Image ... installieren
     
    item --gap Betriebssystem installieren
     
    item --key 7 win7 Windows 7 AIO Setup
     
    item --key 8 Win8 Windows 8.1 Setup
     
    item --gap Partition/Image/Backup
     
    item --key a acronis2013 Acronis True Image 2013
     
    item --key p gparted Gparted
     
    item --key c clonezilla Clonezilla
     
    item --gap MultiBootCDs
     
    item --key h hirens HirensbootCD
     
    item --key u ubcd UltimateBootCD
     
    item --gap Shell
     
    item shell iPXE Shell
     
    item --gap Computer-Informationen
     
    item hostinfo Computer-Informationen
     
    item --gap --
     
    item return <---
     
    choose --default Win7 --timeout 60000 target && goto ${target}
     
    :bootlocal
     
    sanboot --no-describe --drive 0x80 || goto MENU
     
    :win7
     
    initrd http://${fog-ip}/${fog-webroot}/iso/Win7aio.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :Win8
     
    initrd http://${fog-ip}/${fog-webroot}/iso/Win81.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :acronis2013
     
    initrd http://${fog-ip}/${fog-webroot}/iso/acronis.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :gparted
     
    initrd http://${fog-ip}/${fog-webroot}/iso/gparted.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :clonezilla
     
    initrd http://${fog-ip}/${fog-webroot}/iso/clonezilla.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :hirens
     
    initrd http://${fog-ip}/${fog-webroot}/iso/hirensbootcd.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :ubcd
    initrd http://${fog-ip}/${fog-webroot}/iso/ultimatebootcd.iso
     
    chain memdisk iso raw ||
     
    goto MENU
     
    :shell
     
    shell ||
     
    goto MENU
     
    :hostinfo
     
    echo ||
     
    echo ||
     
    echo This computer : ||
     
    echo MAC address....${net0/mac} ||
     
    echo IP address.....${ip} ||
     
    echo Netmask........${netmask} ||
     
    echo Serial.........${serial} ||
     
    echo Asset number...${asset} ||
     
    echo Manufacturer...${manufacturer} ||
     
    echo Product........${product} ||
     
    echo BIOS platform..${platform} ||
     
    echo ||
     
    echo Zurueck mit beliebiger Taste ||
     
    prompt
     
    goto MENU
     
    :image1
     
    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=192.168.178.54 web=${fog-ip}/${fog-webroot}/ consoleblank=0 loglevel=4 type=down img=test ftp=${fog-ip} imgType=n osid=7 storage=${fog-ip}:/images capone=1 imgFormat=2
     
    imgfetch init.xz
     
    boot || goto MENU
     
    :return
     
    chain http://${fog-ip}/${fog-webroot}/service/ipxe/boot.php?mac=${net0/mac} ||
     
    prompt
     
    goto MENU
     
    autoboot
    


  • !

    thats my isos



  • no, it boot windows.

    isos are in place, same place as acronis.

    i post later the place from the files.


  • Developer

    Any error messages when you try the other boot menu entries? We need more information on what exactly does not work to be able to help you.

    Maybe the ISO files are not in place!? Or those ISO files might be corrupt… Could be anything, really. Please give us some more details.


Log in to reply
 

888
Online

38920
Users

10689
Topics

101411
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.