Unable to Deploy Image



  • Recently I am having issues deploying an image to clients. I am able to upload the image from the device to the fog server but then deploying to another machine - nothing.

    Download task created for [U]machine [/U]with image [U]DellAllinOne8GBWIN764[/U]

    The log show the machine ran for a total of 4 seconds.

    fog machine 2015-02-04
    20:55:04 2015-02-04
    20:55:08 00:00:04 DellAllinOne8GBWIN764 Download

    I am still able to pxe. The full registration works, but again reboots before the image deployment piece starts. Same outcome when creating a task for the machine.

    This is not specific to one device - I’ve tested other devices with the same outcome. Can someone point me in the right direction?

    Running [B]1.2.0[/B]
    Kernel 3142



  • I just wanted to chime in - my issue was the target disk was slightly smaller than the original as well (physical to ssd and assuming, without double-checking).


  • Developer

    is there a reason you can’t use a resizeable image type?



  • [quote=“Uncle Frank, post: 42045, member: 28116”]So is this causing the problem in your case??

    [B]By the way, which version of FOG are you running, Jeff??[/B][/quote]

    Uhh, I hate to admit it, but yes, my target disk was just slightly smaller than my original image. Interestingly, one reason I was confused and having issues after attempting to deploy an image was because FOG partitioned the disk with the desired size for the image. So when I ran a disk partitioning utility to check it the first thing I saw was an error because a partition was created beyond the limits of the disk. Weird it is even able to do that and not just error out.

    So, replacing the target disk with a larger one resolved the issue for me. I need to go back and recreate my original image using a much smaller disk.

    Running FOG 1.2.0

    My suggestion for an added feature would be to do some sanity check for disk size and give some sort of feedback to the user if a target disk is too small.

    Thanks for the help and the excellent cloning solution!

    JF


  • Developer

    [quote=“Just10, post: 41995, member: 28415”]after typing that… I realize the image is probably larger than 40gb. If our techs put 40gb drives in these machines - I have a bigger problem.[/quote]
    So is this causing the problem in your case??

    Maybe we have another weird issue with partprobe again. Please run another debug download session. Type ‘fog’ and hit Enter till you see ‘Mounting File System . . .’ then press Ctrl+C to get back to the console.
    [CODE]# dd if=/images/d1.mbr of=/dev/sda

    fogpartinfo --list-parts /dev/sda

    ls -al /dev/sda*

    partprobe /dev/sda

    fogpartinfo --list-parts /dev/sda

    ls -al /dev/sda*


    hdparm -z /dev/sda

    fogpartinfo --list-parts /dev/sda

    ls -al /dev/sda*

    …[/CODE]
    Sounds weird but I had a disk where device files were “missing” after running partprobe…

    [B]By the way, which version of FOG are you running, Jeff??[/B]



  • Oh, and another thing I can add is that if I let the download (either via debug or normally) run it creates the correct partition table and MBR on the disk. Once it reboots if I check it it has done exactly what I’d expect. Just no file download.



  • [quote=“Just10, post: 41992, member: 28415”]ls -al /images/DellAllinOne8GBWIN764 shows:
    d1.mbr
    d1p1.img
    d1p2.img
    The image is multiple partition - single disk.

    Any more on this? I am in exactly the same situation. Win7 image that is multiple partition - single disk. TFTP is verified working. When I run a debug and look at my disk and partition(s) it looks fine. I run a debug deploy and everything is fine except it never actually downloads anything. As I step through the steps everything appears okay and then it says it’s finished.[/quote]



  • after typing that… I realize the image is probably larger than 40gb. If our techs put 40gb drives in these machines - I have a bigger problem.



  • ls -al /images/DellAllinOne8GBWIN764 shows:
    d1.mbr
    d1p1.img
    d1p2.img
    The image is multiple partition - single disk.

    sfdisk -d /dev/sda shows:
    /dev/sda1/ : start= 2048, size= 204800, Id= 7, bootable
    /dev/sda2/ : start= 206848, size= 976564224, Id= 7
    /dev/sda3/ : start= 0, size=0, Id=0
    /dev/sda4/ : start= 0, size=0, Id=0


  • Developer

    How does your partition layout look like? Please run this command on one of your clients (e.g. bootup in debug mode):
    [CODE]sfdisk -d /dev/sda[/CODE]
    Which files do you have on your FOG server?
    [CODE]ls -al /images/DellAllinOne8GBWIN764[/CODE]
    What image type is configured? Single Disk Multiple Partitions?



  • I am now running 2948. Same issue. Running through download debug now. I will report back shortly.


  • Senior Developer

    There’s only one feature that’s “broken/disabled” for right now.

    That’s the group page membership capability to change the image right from that particular screen. Everything else should be stable and functional.


  • Developer

    do you mind upgrading to an svn version? there are a number of features that have been improved, and while i can’t guarantee that whatever is causing your problem has been “fixed” it is possible. at any rate, the debug mode in the newer versions lets you actually read what’s going on during a task instead of just blurring by.
    my production server is currently running svn 2948 and appears to be stable. normally i would recommend updating to the latest svn, but i know that tom is working on a few things pretty heavily right now and a few features might be disabled or broken.
    to update to version 2948:
    [CODE]cd ~
    mkdir svn
    cd svn
    svn checkout https://svn.code.sf.net/p/freeghost/code/trunk@2948
    cd trunk/bin
    sudo ./installfog.sh[/CODE]


  • Senior Developer

    This definitely sounds like what junkhacker states.

    Your drives are completely uninitialized and cannot find a partition to boot from.

    This isn’t a kernel issue. The unable to pxe boot sounds more like the file was just bad, not necessarily a direct problem with the kernel. This meaning, the kernel trying to load was wrong for the init and probably ended in a kernel panic, or in the case of memtest, the file memtest.bin was missing or not correct. My guess is you’ll still see issues with memtest of the file is bad as your redownloading of the kernel would have no affect on memtest directly.

    To fix the partition problem try the steps here:
    [url]http://fogproject.org/forum/threads/quick-format-to-ntfs-with-fog-for-noobs.10349/[/url]

    If this does not help, the other thing I’d think to check would be the format the mbr file is trying to push. If you do a download debug, it should pause you a whole bunch of times. When it gets to the No Extended Partitions point, ctrl + c out of it back to terminal.

    Once in debug - download, you’ll get terminal prompt. Type the command fog and wait for the no extended partitions point and ctrl+c out back to the terminal. Then run fdisk -l, what’s the output.



  • The machines were delivered to us from Dell w/ a french version on Win 7 installed - they have an OS loaded on them already.

    I’ve also attempted this using a laptop that I have imaged prior and receive the same outcome.



  • Tom,

    When I noticed I had an issue, I upgraded to the Kernel - 3.14.2. I was then unable to pxe boot to the fog page (to register the client, memtest etc). I installed Kernel - 3.18.4 and resolved that issue.

    Here is the video (excuse the auto focus). I have a task set to download. The video ends at the point that the machine restarts back to the fog pxe menu and the tasks shows complete.

    [media=youtube]X29p6H78EXw[/media]


  • Developer

    the computers that you’re trying to download images to, have the hard drives been initialized? are they brand new?


  • Senior Developer

    I guess I’m confused.

    If you’re able to boot to the Debug system, the problem is not in anyway to deal with TFTP.

    Using different/newer kernel’s poses problems?

    Can you take a video and post it so we can see what you’re referring to?


  • Developer

    if you’re running 1.2.0 and [quote=“Just10, post: 41920, member: 28415”]
    It runs through the process and displays “task complete, restarting” all in a matter of seconds. Fog thinks it has uploaded the image without issue but it never makes it to the progress screen showing the imaging partition.
    [/quote]
    then your tftp settings are likely correct, and it’s a different issue



  • I checked that as well - it is pointing to undionly.kpxe


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.