FOGFTP failed to rename file



  • At the close of uploading an image I get this error repeating:
    FOGFTP failed to rename file Remote Path: /images/LenovoE520Laptop, Local path: /images/dev/f0def1ad9bdb, Error: ftp_rename(): Rename failed

    Fog 1.2
    [RIGHT][B]Operating system[/B][/RIGHT] Ubuntu Linux 12.04.5
    [RIGHT][B]Webmin version[/B][/RIGHT] 1.730
    [RIGHT][B]Kernel and CPU[/B][/RIGHT] Linux 3.2.0-75-generic on x86_64



  • @kevinrigney
    Did you change them in each of the folders to fog and root?

    Mine had Me and root. I can’t upload an image.



  • The permissions were fog:root in /tftpboot but I changed them to fog:root in my images folder (/images) and it worked! Thanks!


  • Moderator

    @Tom Elliott, post: 45594, member: 7271 said:

    The proper permissions should be:

    >sudo chown -R fog:root /tftpboot
    >```
     
     
    hash-tagging this.
    #letsmakescripts

  • Senior Developer

    The proper permissions should be:

    sudo chown -R fog:root /tftpboot
    


  • Permissions are 777. The image is written to the temporary folder with the user and group as root. Is this correct? I expected the user and group to be www-data or fog.


  • Moderator

    Check your permissions on your /images folder.

    In order to rename, it has to have write permissions.

    Because you can READ (because imaging works), obviously the passwords are correct. It’s just permissions, probably.



  • I have the same issue. I’ve checked the password in .fogconfig and Config.class.php. I can log in as the fog user with the password in these files. I can also ftp to localhost with these credentials (user: fog) BUT I cannot rename in FTP using those credentials.

    If I move the temporary folder pulling the image completes. I then move the image to where FOG expects it and can push the image with no problem.

    I’m running FOG 1.2.0 on ubuntu 12.04 with Linux 3.13.0-44-generic x86_64



  • Storage Group set to default.


  • Testers

    This used to happen when permissions in the images folder were wrong some people recently had issues because they forgot to choose a storage group for the image.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.