PXE boot to FOG 1.2.0 from FOG 0.32 menu


  • Developer

    well, what do you get if you enter this in a web browser? [url]http://10.2.6.40/fog/service/ipxe/boot.php[/url]



  • [quote=“Junkhacker, post: 41940, member: 21583”]the command to load default.ipxe is embedded in all of the fog ipxe boot files, i believe with the exception of ipxe.krn
    the command [CODE]append dhcp && chain http://10.2.6.40/fog/service/ipxe/boot.php?mac=${net0/mac}[/CODE] is doing the basics of what the default.ipxe file is for, and is bypassing it.
    when chainloading ipxe from pxelinux.0, there is no need to make any modifications to existing dhcp services. in fact, that is the main reason people chainload from it in the first place. because in their environment, they can’t modify their dhcp services.[/quote]

    Hi Junkhacker, what do you think I should try in this case? Could you please give me some suggestions? Thanks a lot!



  • [quote=“jbsclm, post: 41936, member: 3158”]I apologise in advance if you have tried some of the following.
    This may be a basic question but, if you put your 1.2.0 server on its own isolated LAN and enable DHCP does it work.
    We need to prove your 1.2.0 is good.
    I’m not sure what tells it to load default.ipxe, presumably the dhcp server.
    is there anything in the apache log on 10.2.6.40 for boot.php

    What happens if you build a boot CD or pendrive as per the following.
    [url]http://fogproject.org/forum/threads/physical-boot-disk-for-imaging.12142/#post-40540[/url]
    just burn the iso to disk or pendrive and try booting from it.[/quote]

    No need to apologize. I appreciate your help. Will give it a try.


  • Developer

    [quote=“jbsclm, post: 41936, member: 3158”]
    I’m not sure what tells it to load default.ipxe, presumably the dhcp server.
    [/quote]

    the command to load default.ipxe is embedded in all of the fog ipxe boot files, i believe with the exception of ipxe.krn
    the command [CODE]append dhcp && chain http://10.2.6.40/fog/service/ipxe/boot.php?mac=${net0/mac}[/CODE] is doing the basics of what the default.ipxe file is for, and is bypassing it.
    when chainloading ipxe from pxelinux.0, there is no need to make any modifications to existing dhcp services. in fact, that is the main reason people chainload from it in the first place. because in their environment, they can’t modify their dhcp services.


  • Developer

    I apologise in advance if you have tried some of the following.
    This may be a basic question but, if you put your 1.2.0 server on its own isolated LAN and enable DHCP does it work.
    We need to prove your 1.2.0 is good.
    I’m not sure what tells it to load default.ipxe, presumably the dhcp server.
    is there anything in the apache log on 10.2.6.40 for boot.php

    What happens if you build a boot CD or pendrive as per the following.
    [url]http://fogproject.org/forum/threads/physical-boot-disk-for-imaging.12142/#post-40540[/url]
    just burn the iso to disk or pendrive and try booting from it.



  • [quote=“jbsclm, post: 41874, member: 3158”]No, the reason i said to disable it as you shouldn’t have 2 dhcp servers on the same network.if neither of your fog servers provide dhcp then the comment doesn’t apply.
    I suspect having a seperate dhcp server may be the problem, ipxe will be getting an address from that, which will point to the 0.32 server, i don’t know whether that would affect it.

    I’ll have a think.

    there is a recent thread on booting from a cd or pendrive, you could try that, not what you asked i know, but it may achieve what you want to do.[/quote]

    I thought of that too, but I have modified “default.ipxe” and pointed it directly to the FOG 1.2.0 ipxe server already. I’m still getting the same error message, unless I did it wrong. I got the instructions from [url]http://ipxe.org/embed[/url]


  • Developer

    No, the reason i said to disable it as you shouldn’t have 2 dhcp servers on the same network.if neither of your fog servers provide dhcp then the comment doesn’t apply.
    I suspect having a seperate dhcp server may be the problem, ipxe will be getting an address from that, which will point to the 0.32 server, i don’t know whether that would affect it.

    I’ll have a think.

    there is a recent thread on booting from a cd or pendrive, you could try that, not what you asked i know, but it may achieve what you want to do.



  • [quote=“jbsclm, post: 41855, member: 3158”]Here is what I did to get 0.33 to boot from a 0.32 menu item.
    [url]http://fogproject.org/forum/threads/chain-booting-0-33-beta-from-0-32.10156/[/url]
    Worth a try.[/quote]

    Hi jbsclm, thanks for your suggestion.
    That’s basically what I have done so far, except “[B]Disable[/B] the dhcp service on the 0.33 server, you will need to consult the O/S documentation for details on how to do that.” If I don’t use FOG as a DHCP server, do I still have to disable DHCP service on the server? Thanks!


  • Developer

    Here is what I did to get 0.33 to boot from a 0.32 menu item.
    [url]http://fogproject.org/forum/threads/chain-booting-0-33-beta-from-0-32.10156/[/url]
    Worth a try.



  • Hi guys, I tried to set up chain loading in the PXELinux menu, but it was not successful. I have done some researches online but I’m not able to figure it out. Could you guys please give me a hand? Thanks a lot!
    Here’s what I have done.

    1. added the pxelinux menu entry for chain loading to ipxe

    LABEL FOG-IT-120TEST
    #MENU PASSWD fjasjfskajgdfjgjdfgjdfjgsdfgafgjfd.
    kernel fog/kernel/ipxe.krn
    append dhcp && chain [url]http://10.2.6.40/fog/service/ipxe/boot.php?mac=${net0/mac}[/url]
    MENU LABEL FOG 1.2.0 iPXE
    TEXT HELP
    FOG 1.2.0 iPXE chainload TEST.
    ENDTEXT
    \n

    1. copied “ipxe.krn” from FOG 1.2.0 server to FOG 0.32 server /tftpboot/fog/kernel/ipxe.krn
    2. copied “default.ipxe” from FOG 1.2.0 server to FOG 0.32 server /tftpboot/default.ipxe
      Here’s the config in “default.ipxe”

    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param product ${product}
    param manufacturer ${product}
    param ipxever ${version}
    param filename ${filename}
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain [url]http://10.2.6.40/fog/service/ipxe/boot.php##params[/url]

    1. I’ve got the error saying “Could not boot: Input/output error ([url]http://ipxe.org/1d0c6139[/url])”. Please see attached image.

    I looked it up on ipxe.org, but there’s not really a solution. Hope you guys can give me some help. Thanks a lot!! :)

    [url="/_imported_xf_attachments/1/1662_Photo Feb 06, 12 32 25 PM.jpg?:"]Photo Feb 06, 12 32 25 PM.jpg[/url]



  • [SIZE=5][B][SIZE=4][FONT=Segoe UI Light]Hi Jaymes and Junkhacker, thank you guys for pointing me the direction to chain loading.[/FONT][/SIZE][/B][/SIZE]

    [SIZE=5][B][SIZE=4][FONT=Segoe UI Light]Let me give it a try! Will report back! :) [/FONT][/SIZE][/B][/SIZE]


  • Developer

    also, be sure to check out the advanced boot menu within fog. it allows you to create custom boot menu entries and supports faster file transfer protocols, like http, then pxelinux does


  • Developer

    Its called chain loading, and yes it is possible. This will cause pxelinux.0 to call undionly.kpxe.

    I am sure that with proper tweaking you can have a menu item that lead to iPXE so that you can keep your custom items in pxelinux.0

    [url]http://fogproject.org/wiki/index.php/Chainloading_PXE_to_iPXE_using_pxelinux.0[/url]


Log in to reply
 

379
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.